aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2016-05-02 22:55:22 +0000
committerBrooks Davis <brooks@FreeBSD.org>2016-05-02 22:55:22 +0000
commit71079656a7418cccc07e4fec0ecedcb0870860dd (patch)
tree4d2d22c40a159f1eb4cd8def46da966fcee1210a
parent4da3639ecf8336b2de8f2342f1abf8a38c6a2a33 (diff)
downloadports-71079656a7418cccc07e4fec0ecedcb0870860dd.tar.gz
ports-71079656a7418cccc07e4fec0ecedcb0870860dd.zip
Notes
-rw-r--r--devel/llvm38/Makefile5
-rw-r--r--devel/llvm38/files/compiler-rt-patch-no-m3214
2 files changed, 17 insertions, 2 deletions
diff --git a/devel/llvm38/Makefile b/devel/llvm38/Makefile
index 96060129aa79..82774a79b6cb 100644
--- a/devel/llvm38/Makefile
+++ b/devel/llvm38/Makefile
@@ -2,7 +2,7 @@
PORTNAME= llvm
DISTVERSION= 3.8.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/${PRE_}releases/${LLVM_RELEASE}/${RCDIR}
DISTNAME= ${PORTNAME}-${DISTVERSION}.src
@@ -217,7 +217,7 @@ _COMPILER_RT_LIBS= \
libclang_rt.ubsan_standalone_cxx-x86_64.a \
libclang_rt.ubsan_standalone_cxx-x86_64.a.syms
.endif
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+.if ${ARCH} == "i386"
_COMPILER_RT_LIBS+= \
libclang_rt.asan-i386.a \
libclang_rt.asan-i386.so \
@@ -288,6 +288,7 @@ post-patch:
post-patch-COMPILER_RT-on:
cd ${WRKSRC_compiler_rt} && patch < ${PATCHDIR}/compiler-rt-patch-svn-261229
+ cd ${WRKSRC_compiler_rt} && patch < ${PATCHDIR}/compiler-rt-patch-no-m32
post-build-COMPILER_RT-on:
${MKDIR} ${WRKDIR}/compiler-rt-build
diff --git a/devel/llvm38/files/compiler-rt-patch-no-m32 b/devel/llvm38/files/compiler-rt-patch-no-m32
new file mode 100644
index 000000000000..de42cbe1222d
--- /dev/null
+++ b/devel/llvm38/files/compiler-rt-patch-no-m32
@@ -0,0 +1,14 @@
+--- cmake/config-ix.cmake.orig 2016-05-02 20:51:53.598525522 +0000
++++ cmake/config-ix.cmake 2016-05-02 20:53:24.573519349 +0000
+@@ -189,11 +189,6 @@
+ if("${COMPILER_RT_DEFAULT_TARGET_ARCH}" MATCHES "i[2-6]86|x86|amd64")
+ if(NOT MSVC)
+ test_target_arch(x86_64 "" "-m64")
+- # FIXME: We build runtimes for both i686 and i386, as "clang -m32" may
+- # target different variant than "$CMAKE_C_COMPILER -m32". This part should
+- # be gone after we resolve PR14109.
+- test_target_arch(i686 __i686__ "-m32")
+- test_target_arch(i386 __i386__ "-m32")
+ else()
+ if (CMAKE_SIZEOF_VOID_P EQUAL 4)
+ test_target_arch(i386 "" "")