aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-01-10 16:44:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-01-10 16:44:24 +0000
commit72a6ab79881652e1f89338a8884439b3054997c7 (patch)
tree4282c6f5d647c3c53fc4a55086aa5581631c9073
parent05cf3794df65552ba3729dc0cd6d58735c40641f (diff)
downloadports-72a6ab79881652e1f89338a8884439b3054997c7.tar.gz
ports-72a6ab79881652e1f89338a8884439b3054997c7.zip
Notes
-rw-r--r--lang/newlisp-devel/Makefile2
-rw-r--r--lang/newlisp/Makefile2
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php55/Makefile.ext4
-rw-r--r--lang/php56/Makefile.ext4
-rw-r--r--lang/racket/Makefile3
-rw-r--r--lang/smalltalk/Makefile3
-rw-r--r--lang/urweb/Makefile2
-rw-r--r--mail/bogofilter-sqlite/Makefile3
-rw-r--r--mail/cyrus-imapd25/Makefile2
-rw-r--r--mail/evolution-ews/Makefile3
-rw-r--r--mail/ezmlm-idx/Makefile2
-rw-r--r--mail/greylite/Makefile3
-rw-r--r--mail/libmapi/Makefile4
-rw-r--r--mail/qsf/Makefile2
-rw-r--r--mail/rspamd-devel/Makefile3
-rw-r--r--mail/rspamd/Makefile3
-rw-r--r--multimedia/avidemux/Makefile.common3
-rw-r--r--multimedia/banshee/Makefile3
-rw-r--r--multimedia/gmerlin/Makefile3
20 files changed, 24 insertions, 34 deletions
diff --git a/lang/newlisp-devel/Makefile b/lang/newlisp-devel/Makefile
index f9c5049d0316..11037f732342 100644
--- a/lang/newlisp-devel/Makefile
+++ b/lang/newlisp-devel/Makefile
@@ -77,7 +77,7 @@ PLIST_SUB+= PGSQL="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= 3
+USES+= sqlite
MODULES+= sqlite3
PLIST_SUB+= SQLITE=""
.else
diff --git a/lang/newlisp/Makefile b/lang/newlisp/Makefile
index a1002aaf6b47..5f541abcb3bb 100644
--- a/lang/newlisp/Makefile
+++ b/lang/newlisp/Makefile
@@ -61,7 +61,7 @@ MODULES+= postgres
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= 3
+USES+= sqlite
MODULES+= sqlite3
.endif
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 9d4e605e3ba7..8c4e9635dd67 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -146,7 +146,7 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "interbase"
CONFIGURE_ARGS+=--with-interbase=${LOCALBASE}
-USE_FIREBIRD= yes
+USES+= firebird
.endif
.if ${PHP_MODNAME} == "json"
@@ -273,7 +273,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_sqlite"
-USE_SQLITE= yes
+USES+= sqlite
CONFIGURE_ARGS+=--with-pdo-sqlite=${LOCALBASE}
USE_PHP= pdo
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index cbf0d1d2c3dd..29ba6c6f1c18 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -146,7 +146,7 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "interbase"
CONFIGURE_ARGS+=--with-interbase=${LOCALBASE}
-USE_FIREBIRD= yes
+USES+= firebird
.endif
.if ${PHP_MODNAME} == "json"
@@ -277,7 +277,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_sqlite"
-USE_SQLITE= yes
+USES+= sqlite
CONFIGURE_ARGS+=--with-pdo-sqlite=${LOCALBASE}
USE_PHP= pdo
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index ebaa9efa9243..ae6632809ba1 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -146,7 +146,7 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "interbase"
CONFIGURE_ARGS+=--with-interbase=${LOCALBASE}
-USE_FIREBIRD= yes
+USES+= firebird
.endif
.if ${PHP_MODNAME} == "json"
@@ -277,7 +277,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_sqlite"
-USE_SQLITE= yes
+USE+= sqlite
CONFIGURE_ARGS+=--with-pdo-sqlite=${LOCALBASE}
USE_PHP= pdo
diff --git a/lang/racket/Makefile b/lang/racket/Makefile
index 2507fdae0fcf..042850d88949 100644
--- a/lang/racket/Makefile
+++ b/lang/racket/Makefile
@@ -35,10 +35,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/racket-${PORTVERSION}/src
-USES= iconv jpeg libtool tar:tgz
+USES= iconv jpeg libtool sqlite tar:tgz
USE_LDCONFIG= yes
USE_GNOME= pango
-USE_SQLITE= 3
ONLY_FOR_ARCHS= i386 amd64
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 38d6483045d5..999cff6356ab 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -24,9 +24,8 @@ PGSQL_USES= pgsql
SDL_USE= SDL=image,mixer,sdl,sound,ttf
USES= execinfo gmake iconv libtool localbase makeinfo pkgconfig \
- shebangfix tar:xz
+ shebangfix sqlite tar:xz
USE_GNOME= pango
-USE_SQLITE= yes
USE_XORG= ice xi xmu
USE_GL= gl glut
GNU_CONFIGURE= yes
diff --git a/lang/urweb/Makefile b/lang/urweb/Makefile
index 26ba0018e184..660b40bee9ee 100644
--- a/lang/urweb/Makefile
+++ b/lang/urweb/Makefile
@@ -49,7 +49,7 @@ CONFIGURE_ENV+= PGHEADER="no"
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
.else
CONFIGURE_ENV+= SQHEADER="no"
.endif
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
index 003bee84790d..f57d2fd75342 100644
--- a/mail/bogofilter-sqlite/Makefile
+++ b/mail/bogofilter-sqlite/Makefile
@@ -8,8 +8,7 @@ PKGNAMESUFFIX= -sqlite
MAINTAINER= mandree@FreeBSD.org
-USE_SQLITE= 3
-
+USES= sqlite
CONFLICTS_INSTALL= bogofilter-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tc-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
CONFIGURE_ARGS= --with-database=sqlite
diff --git a/mail/cyrus-imapd25/Makefile b/mail/cyrus-imapd25/Makefile
index aa3bec0c4c81..455ae861ea23 100644
--- a/mail/cyrus-imapd25/Makefile
+++ b/mail/cyrus-imapd25/Makefile
@@ -162,7 +162,7 @@ IGNORE= DRAC is not available
.endif
.if ${PORT_OPTIONS:MHTTP} || ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE=yes
+USES+= sqlite
.endif
.if !${PORT_OPTIONS:MGSSAPI_BASE} && !${PORT_OPTIONS:MGSSAPI_HEIMDAL} && \
diff --git a/mail/evolution-ews/Makefile b/mail/evolution-ews/Makefile
index f82641d7152f..aaff214092de 100644
--- a/mail/evolution-ews/Makefile
+++ b/mail/evolution-ews/Makefile
@@ -18,10 +18,9 @@ RUN_DEPENDS= evolution>=3.0.0:${PORTSDIR}/mail/evolution
PORTSCOUT= limitw:1,even
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake libtool pathfix pkgconfig sqlite tar:xz
USE_GNOME= intltool
GNU_CONFIGURE= yes
-USE_SQLITE= 3
USE_BDB= 5
USE_OPENLDAP= yes
USE_LDCONFIG= yes
diff --git a/mail/ezmlm-idx/Makefile b/mail/ezmlm-idx/Makefile
index c4402bcaddf3..c287daeb0022 100644
--- a/mail/ezmlm-idx/Makefile
+++ b/mail/ezmlm-idx/Makefile
@@ -52,7 +52,7 @@ PLIST_SUB+= MYSQL="@comment " PGSQL="" SQLITE="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
EXTRACT_INCLUDE+= -I${LOCALBASE}/include
EXTRACT_LIB+= -L${LOCALBASE}/lib -lsqlite3
ALL_TARGET+= sqlite3
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
index f998b93e107e..bc5e5bf259ac 100644
--- a/mail/greylite/Makefile
+++ b/mail/greylite/Makefile
@@ -14,8 +14,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-USES= tar:bzip2
-USE_SQLITE= 3
+USES= sqlite tar:bzip2
PLIST_FILES= bin/greylite \
%%DNSBLENV%%bin/dnsblenv \
%%UCSPI2SOCKET%%bin/ucspi2socket \
diff --git a/mail/libmapi/Makefile b/mail/libmapi/Makefile
index f43c01cfaf1a..8430472126c7 100644
--- a/mail/libmapi/Makefile
+++ b/mail/libmapi/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= ${SAMBA_DEP}
CODENAME= QUADRANT
DOWNLOADCODE= 244
-USE_SQLITE= 3
-USES= compiler:c++11-lib gmake pathfix pkgconfig python shebangfix
+USES= compiler:c++11-lib gmake pathfix pkgconfig python shebangfix \
+ sqlite
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/mail/qsf/Makefile b/mail/qsf/Makefile
index 6bf18d47dd56..ae0146f20d16 100644
--- a/mail/qsf/Makefile
+++ b/mail/qsf/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+= --without-mysql
.endif
.if ${PORT_OPTIONS:MSQLITE2}
-USE_SQLITE= 2
+USES+= sqlite:2
.else
CONFIGURE_ARGS+= --without-sqlite
.endif
diff --git a/mail/rspamd-devel/Makefile b/mail/rspamd-devel/Makefile
index 798004ff553e..f65a29235282 100644
--- a/mail/rspamd-devel/Makefile
+++ b/mail/rspamd-devel/Makefile
@@ -45,13 +45,12 @@ CMAKE_ARGS+= -DCONFDIR=${PREFIX}/etc/rspamd \
-DDEBUG=ON
USES= cmake:outsource gettext iconv pkgconfig tar:xz perl5 \
- compiler:c11
+ compiler:c11 sqlite
USE_LDCONFIG= yes
USE_PERL5= build
USE_GNOME= glib20
USE_OPENSSL= yes
-USE_SQLITE= yes
DEBUG_FLAGS= -g -O0
WITH_DEBUG= yes
diff --git a/mail/rspamd/Makefile b/mail/rspamd/Makefile
index 6228593e63dc..9b4d80a02546 100644
--- a/mail/rspamd/Makefile
+++ b/mail/rspamd/Makefile
@@ -40,13 +40,12 @@ CMAKE_ARGS+= -DCONFDIR=${PREFIX}/etc/rspamd \
-DNO_SHARED=ON
USES= cmake:outsource gettext iconv pkgconfig tar:xz perl5 \
- compiler:c11
+ compiler:c11 sqlite
USE_LDCONFIG= yes
USE_PERL5= build
USE_GNOME= glib20
USE_OPENSSL= yes
-USE_SQLITE= yes
.include <bsd.port.options.mk>
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index fcf3fd5f7592..4879709b1ae4 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -18,8 +18,7 @@ USE_QT4= # empty
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
-USE_SQLITE= yes
-USES= cmake:outsource pkgconfig iconv gmake compiler:features
+USES= cmake:outsource pkgconfig iconv gmake compiler:features sqlite
USES+= dos2unix execinfo
DOS2UNIX_FILES= cmake/admCheckMiscLibs.cmake po/CMakeLists.txt
CMAKE_ARGS+= -DGNUMAKE_EXECUTABLE=gmake
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 2933ecdf494e..7721c68d60d1 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -33,14 +33,13 @@ YOUTUBE_DESC= Build and/or install the Youtube extension
OPTIONS_DEFAULT=BPMDETECT GIO MTP WEBKIT YOUTUBE
USES= desktop-file-utils gmake libtool mono pathfix perl5 \
- pkgconfig shared-mime-info tar:xz
+ pkgconfig shared-mime-info sqlite tar:xz
USE_PERL5= build
GNU_CONFIGURE= yes
USE_GNOME= gnomedocutils gnomesharp20 gtksharp20 intltool
USE_GSTREAMER= cdparanoia
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME:C/-.*//}
USE_XORG= xrandr xxf86vm
-USE_SQLITE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/multimedia/gmerlin/Makefile b/multimedia/gmerlin/Makefile
index c107d6d8d8ea..22db7ca71821 100644
--- a/multimedia/gmerlin/Makefile
+++ b/multimedia/gmerlin/Makefile
@@ -17,11 +17,10 @@ LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
libgavl.so:${PORTSDIR}/multimedia/gavl \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-USES= gettext libtool makeinfo pathfix pkgconfig
+USES= gettext libtool makeinfo pathfix pkgconfig sqlite
USE_GNOME= gtk20 libxml2
USE_XORG= x11 xext xfixes xinerama xv
USE_GL= gl
-USE_SQLITE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_func_inotify_init=no
CONFIGURE_ARGS= --disable-v4l --disable-v4l2 --disable-v4lconvert \