aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-05-10 15:02:18 +0000
committerRene Ladan <rene@FreeBSD.org>2010-05-10 15:02:18 +0000
commit73306d764d7fab8cfd44243d40e74a17d06b4946 (patch)
treeccd8922c06fc73ef388caeef05637f56cf748b28
parenta15d20b054da0dc7adf3826192563fd85ecf1b54 (diff)
downloadports-73306d764d7fab8cfd44243d40e74a17d06b4946.tar.gz
ports-73306d764d7fab8cfd44243d40e74a17d06b4946.zip
Notes
-rw-r--r--devel/p4p/Makefile133
-rw-r--r--devel/p4p/distinfo.freebsd54x863
-rw-r--r--devel/p4p/distinfo.freebsd54x86_643
-rw-r--r--devel/p4p/distinfo.freebsd60x8618
-rw-r--r--devel/p4p/distinfo.freebsd60x86_6418
-rw-r--r--devel/p4p/distinfo.freebsd61sparc6418
-rw-r--r--devel/p4p/distinfo.freebsd70x863
-rw-r--r--devel/p4p/distinfo.freebsd70x86_643
-rw-r--r--devel/p4p/files/p4p.sh.in49
-rw-r--r--devel/p4p/files/perforce.conf.in75
-rw-r--r--devel/p4p/files/perforce.sh.in62
-rw-r--r--devel/p4p/pkg-install52
-rw-r--r--devel/p4p/pkg-plist6
13 files changed, 111 insertions, 332 deletions
diff --git a/devel/p4p/Makefile b/devel/p4p/Makefile
index 3fb53086da5b..d175301b3b4b 100644
--- a/devel/p4p/Makefile
+++ b/devel/p4p/Makefile
@@ -1,120 +1,65 @@
-# New ports collection makefile for: perforce
-# Date created: 3 Mai 2000
-# Whom: sam@inf.enst.fr
+# New ports collection makefile for: p4p
+# Date created: 3 Apr 2010
+# Whom: gordon@FreeBSD.org
#
# $FreeBSD$
#
-PORTNAME= perforce
-PORTVERSION= 08.2
-PORTREVISION= 5
-PORTEPOCH= 1
+PORTNAME= p4p
+PORTVERSION= 2009.2.238357
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/bin.${PLATFORM}/ \
- http://filehost.perforce.com/perforce/r${PORTVERSION}/bin.${PLATFORM}/
+MASTER_SITES= ftp://ftp.perforce.com/perforce/${P4VERSION}/bin.${PLATFORM}/ \
+ http://filehost.perforce.com/perforce/r${P4VERSION}/bin.${PLATFORM}/
+DISTNAME= p4p
EXTRACT_SUFX=
-DISTFILES= ${BIN_FILES} ${SBIN_FILES}
EXTRACT_ONLY= # none
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Perforce client and server
+MAINTAINER= gordon@FreeBSD.org
+COMMENT= Perforce server
+
+RUN_DEPENDS= p4:${PORTSDIR}/devel/p4
ONLY_FOR_ARCHS= amd64 i386 sparc64
-DIST_SUBDIR= perforce/${PORTVERSION}_${PORTREVISION}/${ARCH}
+P4VERSION= r${PORTVERSION:S/^20//:C/\.[0-9]+$//}
+DIST_SUBDIR= perforce/${PORTVERSION}/bin.${PLATFORM}
MD5_FILE= ${MASTERDIR}/distinfo.${PLATFORM}
-BIN_FILES= p4
-SBIN_FILES= p4d p4ftpd p4p p4web
-
-REL_NOTES= http://www.perforce.com/perforce/doc.082/user/relnotes.txt
-
RESTRICTED= Restricted distribution
+NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= ${BIN_FILES:S+^+bin/+g} \
- ${SBIN_FILES:S+^+sbin/+g}
+P4CACHE?= /var/db/p4p
+P4LOG?= /var/log/p4p.log
+
+SUB_LIST= P4CACHE=${P4CACHE} \
+ P4LOG=${P4LOG}
+
+USE_RC_SUBR= p4p.sh
.include <bsd.port.pre.mk>
-# Figure out what to install
-.if ${ARCH} == amd64
-PLATFORM= freebsd60x86_64
-.elif ${ARCH} == i386
-PLATFORM= freebsd60x86
-.elif ${ARCH} == sparc64
-PLATFORM= freebsd61sparc64
-.else
-IGNORE= unsupported OS release, sorry
-.endif
-
-.if ${OSVERSION} >= 700043
-LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
-.endif
-
-# These variables are all configurable.
-PERFORCE_USER?= p4admin
-PERFORCE_UID?= 94
-PERFORCE_GROUP?= p4admin
-PERFORCE_GID?= 94
-PERFORCE_HOME?= ${LOCALBASE}/perforce
-PERFORCE_ROOT?= ${PERFORCE_HOME}/root
-PERFORCE_LOGS?= ${PERFORCE_HOME}/logs
-PERFORCE_PORT?= 1666
-PERFORCE_CACHE?= ${PERFORCE_HOME}/cache
-PERFORCE_TARGET?= perforce:1666
-
-pre-everything::
- @${ECHO} "If the checksums fail, try doing 'make distclean'"
- @${ECHO} "to force getting the latest binaries from Perforce."
- @${ECHO} ""
- @${ECHO} "Read the release notes for this release to determine"
- @${ECHO} "how to migrate the database to the new version. In"
- @${ECHO} "most instances, it is done automatically. However,"
- @${ECHO} "sometimes it must be done manually."
- @${ECHO} ""
- @${ECHO} "The release notes for this version are at"
- @${ECHO} ${REL_NOTES}
- @${ECHO} ""
- @${ECHO} "Checkpoint and backup your data before installing!"
-
-do-build:
- ${SED} -e "s,@PERFORCE_ROOT@,${PERFORCE_ROOT},g" \
- -e "s,@PERFORCE_LOGS@,${PERFORCE_LOGS},g" \
- -e "s,@PERFORCE_USER@,${PERFORCE_USER},g" \
- -e "s,@PERFORCE_PORT@,${PERFORCE_PORT},g" \
- -e "s,@PERFORCE_CACHE@,${PERFORCE_CACHE},g" \
- -e "s,@PERFORCE_TARGET@,${PERFORCE_TARGET},g" \
- < ${FILESDIR}/perforce.conf.in > ${WRKSRC}/perforce.conf
- ${SED} -e "s,@PREFIX@,${PREFIX},g" \
- < ${FILESDIR}/perforce.sh.in > ${WRKSRC}/perforce.sh
-
-pre-su-install:
- ${SETENV} PKG_PREFIX=${PREFIX} \
- PERFORCE_USER=${PERFORCE_USER} \
- PERFORCE_UID=${PERFORCE_UID} \
- PERFORCE_GROUP=${PERFORCE_GROUP} \
- PERFORCE_GID=${PERFORCE_GID} \
- PERFORCE_HOME=${PERFORCE_HOME} \
- PERFORCE_ROOT=${PERFORCE_ROOT} \
- PERFORCE_LOGS=${PERFORCE_LOGS} \
- ${SH} ${PKGDIR}/pkg-install ${PORTNAME} PRE-INSTALL
+.include "${.CURDIR}/../p4/Makefile.inc"
+
+USERS= p4admin
+GROUPS= p4admin
do-install:
-.for f in ${BIN_FILES}
- ${INSTALL_PROGRAM} ${_DISTDIR}/${f} ${PREFIX}/bin/
-.endfor
-.for f in ${SBIN_FILES}
- ${INSTALL_PROGRAM} ${_DISTDIR}/${f} ${PREFIX}/sbin/
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/perforce.conf ${PREFIX}/etc/perforce.conf.default; \
- if [ ! -f ${PREFIX}/etc/perforce.conf ]; then \
- ${CP} -p ${PREFIX}/etc/perforce.conf.default ${PREFIX}/etc/perforce.conf; \
- fi
- ${INSTALL_SCRIPT} ${WRKSRC}/perforce.sh ${PREFIX}/etc/rc.d/
+ ${INSTALL_PROGRAM} ${_DISTDIR}/p4p ${PREFIX}/sbin/
post-install:
- ${ECHO_CMD} "@unexec ${RMDIR} ${PERFORCE_ROOT} ${PERFORCE_LOGS} ${PERFORCE_HOME} 2>/dev/null || true" >> ${TMPPLIST}
+ ${MKDIR} ${DESTDIR}${P4CACHE}
+ ${CHOWN} p4admin:p4admin ${DESTDIR}${P4CACHE}
+ ${CHMOD} 750 ${DESTDIR}${P4CACHE}
+ ${TOUCH} ${DESTDIR}${P4LOG}
+ ${CHOWN} p4admin:p4admin ${DESTDIR}${P4LOG}
+ ${CHMOD} 640 ${DESTDIR}${P4LOG}
+ @${ECHO_CMD} "@exec ${MKDIR} ${DESTDIR}${P4CACHE}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${CHOWN} p4admin:p4admin ${DESTDIR}${P4CACHE}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${CHMOD} 750 ${DESTDIR}${P4CACHE}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${TOUCH} ${DESTDIR}${P4LOG}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${CHOWN} p4admin:p4admin ${DESTDIR}${P4LOG}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${CHMOD} 640 ${DESTDIR}${P4LOG}" >> ${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/devel/p4p/distinfo.freebsd54x86 b/devel/p4p/distinfo.freebsd54x86
new file mode 100644
index 000000000000..db6adb85e544
--- /dev/null
+++ b/devel/p4p/distinfo.freebsd54x86
@@ -0,0 +1,3 @@
+MD5 (perforce/2009.2.238357/bin.freebsd54x86/p4p) = 1fbeb4f5874d687b657eb2896e5cdcf6
+SHA256 (perforce/2009.2.238357/bin.freebsd54x86/p4p) = 904fca99019958c18200d64412fe9278dbca26f8cb7dc405328b0cd9d945ab31
+SIZE (perforce/2009.2.238357/bin.freebsd54x86/p4p) = 552796
diff --git a/devel/p4p/distinfo.freebsd54x86_64 b/devel/p4p/distinfo.freebsd54x86_64
new file mode 100644
index 000000000000..fb61b9189111
--- /dev/null
+++ b/devel/p4p/distinfo.freebsd54x86_64
@@ -0,0 +1,3 @@
+MD5 (perforce/2009.2.238357/bin.freebsd54x86_64/p4p) = c1a28ce4eea7fd7739ff9bb5c9b6e9e0
+SHA256 (perforce/2009.2.238357/bin.freebsd54x86_64/p4p) = 9d78306e47c2b9b241617db558e2a5d184275b6a241e119ade954efe5a3c7d23
+SIZE (perforce/2009.2.238357/bin.freebsd54x86_64/p4p) = 669400
diff --git a/devel/p4p/distinfo.freebsd60x86 b/devel/p4p/distinfo.freebsd60x86
index d946b870c0c1..a54a467ecb63 100644
--- a/devel/p4p/distinfo.freebsd60x86
+++ b/devel/p4p/distinfo.freebsd60x86
@@ -1,15 +1,3 @@
-MD5 (perforce/08.2_5/i386/p4) = 53fdca9090ed49f924fd093fb658eadc
-SHA256 (perforce/08.2_5/i386/p4) = 0c66ac826a47f41ebd31c2d6d3ddb606c0f4fb7017a762e99b4c1e1bf661cd52
-SIZE (perforce/08.2_5/i386/p4) = 546008
-MD5 (perforce/08.2_5/i386/p4d) = ad72254781904ae2bf32b4b592698a27
-SHA256 (perforce/08.2_5/i386/p4d) = 788ded7749d8e41faf68755da4cd3dd1325bfbb72337b1ba7cb262cf1e9f5719
-SIZE (perforce/08.2_5/i386/p4d) = 1590376
-MD5 (perforce/08.2_5/i386/p4ftpd) = 46c234d7b1d6b21e3468eeafcb936b9f
-SHA256 (perforce/08.2_5/i386/p4ftpd) = be9751424a085a4d96f054e0875d2d242ecedb8f09ef8fa516da00cf55d90166
-SIZE (perforce/08.2_5/i386/p4ftpd) = 711840
-MD5 (perforce/08.2_5/i386/p4p) = ee253deeab529151e8d50c91092ef1f6
-SHA256 (perforce/08.2_5/i386/p4p) = 1b1131df308974f0ddd2bb6f70bde94b2161dc9f4fc4f382972e3471c0611c12
-SIZE (perforce/08.2_5/i386/p4p) = 502496
-MD5 (perforce/08.2_5/i386/p4web) = a86ad1a558aa4e1bb068f2ac5179cf7d
-SHA256 (perforce/08.2_5/i386/p4web) = f34a5ad92df6af2ceb57471e7737f40b28051a1d95243f12999f5b04b953f58d
-SIZE (perforce/08.2_5/i386/p4web) = 2170668
+MD5 (perforce/2009.2.238357/bin.freebsd60x86/p4p) = 190bba89529aa498b38ec2dd4dbb4d23
+SHA256 (perforce/2009.2.238357/bin.freebsd60x86/p4p) = 00006f17d2839dd06f31e6028880390e16cc93531eb8138ba14c708d0d069fe8
+SIZE (perforce/2009.2.238357/bin.freebsd60x86/p4p) = 518528
diff --git a/devel/p4p/distinfo.freebsd60x86_64 b/devel/p4p/distinfo.freebsd60x86_64
index 0869e24792da..2a06feae96b6 100644
--- a/devel/p4p/distinfo.freebsd60x86_64
+++ b/devel/p4p/distinfo.freebsd60x86_64
@@ -1,15 +1,3 @@
-MD5 (perforce/08.2_5/amd64/p4) = 8ef290ee5ccc9c156ae0d12f7856d086
-SHA256 (perforce/08.2_5/amd64/p4) = 96bee94925b162084a302ec3b73001b9913f97887d8e619e53c197d6690974b6
-SIZE (perforce/08.2_5/amd64/p4) = 615544
-MD5 (perforce/08.2_5/amd64/p4d) = d159653fd89dc540e4d8bd141098ba76
-SHA256 (perforce/08.2_5/amd64/p4d) = f8ba9df0e73f263ac49294379ab3a82956f76b3d8f37cf6cffe71764ce724196
-SIZE (perforce/08.2_5/amd64/p4d) = 1760104
-MD5 (perforce/08.2_5/amd64/p4ftpd) = 5900ccdade68d9cbd46a29e4540b2c10
-SHA256 (perforce/08.2_5/amd64/p4ftpd) = 67862a479d570e79bb1158653685d1c0980b83ac92eda77c9b79fb61a9ebe805
-SIZE (perforce/08.2_5/amd64/p4ftpd) = 752704
-MD5 (perforce/08.2_5/amd64/p4p) = 4375378956b424b9a132844b2e938682
-SHA256 (perforce/08.2_5/amd64/p4p) = d95faabf9e93916648d0556df7bec20022c4e40b13ff285ed12a347ec521fabc
-SIZE (perforce/08.2_5/amd64/p4p) = 602816
-MD5 (perforce/08.2_5/amd64/p4web) = 5c6b9fb0eb220b83c3c10cabca1ff1ba
-SHA256 (perforce/08.2_5/amd64/p4web) = ca69d11fe31c1bd5b5ddf18bed1c5bb5e7a3c6e3cb96b064d890cd1a75ec0830
-SIZE (perforce/08.2_5/amd64/p4web) = 2370088
+MD5 (perforce/2009.2.238357/bin.freebsd60x86_64/p4p) = c8b4e7d9ca6439cd45340e0bd800331a
+SHA256 (perforce/2009.2.238357/bin.freebsd60x86_64/p4p) = af9d207db0a91d3f3ad88789cc33e2b97652e8669c32f294656d534b2e7999d1
+SIZE (perforce/2009.2.238357/bin.freebsd60x86_64/p4p) = 629704
diff --git a/devel/p4p/distinfo.freebsd61sparc64 b/devel/p4p/distinfo.freebsd61sparc64
index cdc9ba52e7ef..54da53b9e2e7 100644
--- a/devel/p4p/distinfo.freebsd61sparc64
+++ b/devel/p4p/distinfo.freebsd61sparc64
@@ -1,15 +1,3 @@
-MD5 (perforce/08.2_5/sparc64/p4) = d9ee5036dd09c0c398a9095f7858bc21
-SHA256 (perforce/08.2_5/sparc64/p4) = 6cccdf7e3da105c415dbad701cb8c2d8b27fee4376227fec614749658f9632eb
-SIZE (perforce/08.2_5/sparc64/p4) = 625480
-MD5 (perforce/08.2_5/sparc64/p4d) = 8e2f6775b353e02e48bf758c7e3ac352
-SHA256 (perforce/08.2_5/sparc64/p4d) = 05c8882992970a1f53a687d26cc05730d144b95cbeee95851cfe6cc051cad0b2
-SIZE (perforce/08.2_5/sparc64/p4d) = 1777848
-MD5 (perforce/08.2_5/sparc64/p4ftpd) = 5ac8d4cca51428a6f67857e136732e7e
-SHA256 (perforce/08.2_5/sparc64/p4ftpd) = 199490569ce24d78653cd73af59213a4cd2a2b47157e713dc1144dc2ee452e6c
-SIZE (perforce/08.2_5/sparc64/p4ftpd) = 896896
-MD5 (perforce/08.2_5/sparc64/p4p) = ba53e566890df5e43dd462aaedaba11e
-SHA256 (perforce/08.2_5/sparc64/p4p) = 170ccd9ad6e0d0704ef49344b7148c273b56add8da67b472a6c929f89be9e273
-SIZE (perforce/08.2_5/sparc64/p4p) = 608368
-MD5 (perforce/08.2_5/sparc64/p4web) = 07265f0fd255456a90c4c71e0889dab7
-SHA256 (perforce/08.2_5/sparc64/p4web) = d4bd5bdd635cfbbe95febc8b37aa896c63ef7c67d7f35227853d2d7023ea88e4
-SIZE (perforce/08.2_5/sparc64/p4web) = 2341312
+MD5 (perforce/2009.2.238357/bin.freebsd61sparc64/p4p) = 5ac2d8ddef876209a9e2dbd52545b925
+SHA256 (perforce/2009.2.238357/bin.freebsd61sparc64/p4p) = 3cde4750fc0b2f14495b7a1afbfe9346b8347f926d5c8a627516f043f326441f
+SIZE (perforce/2009.2.238357/bin.freebsd61sparc64/p4p) = 632376
diff --git a/devel/p4p/distinfo.freebsd70x86 b/devel/p4p/distinfo.freebsd70x86
new file mode 100644
index 000000000000..2d68534826f9
--- /dev/null
+++ b/devel/p4p/distinfo.freebsd70x86
@@ -0,0 +1,3 @@
+MD5 (perforce/2009.2.238357/bin.freebsd70x86/p4p) = 5c92aab89107f94853e9e3f712c8de91
+SHA256 (perforce/2009.2.238357/bin.freebsd70x86/p4p) = 3c4263636acf30e4ac09d7a5f62b5de68db5d7f170f25f7afe3c6b84bdb85944
+SIZE (perforce/2009.2.238357/bin.freebsd70x86/p4p) = 554760
diff --git a/devel/p4p/distinfo.freebsd70x86_64 b/devel/p4p/distinfo.freebsd70x86_64
new file mode 100644
index 000000000000..0f46e0624782
--- /dev/null
+++ b/devel/p4p/distinfo.freebsd70x86_64
@@ -0,0 +1,3 @@
+MD5 (perforce/2009.2.238357/bin.freebsd70x86_64/p4p) = 5e6a0b3880995eb82a1377ffe5789eb7
+SHA256 (perforce/2009.2.238357/bin.freebsd70x86_64/p4p) = b26647ad3f6c562e655b04117ff9ce23f61c76ac41422f8d3bed62dca0e9bfe6
+SIZE (perforce/2009.2.238357/bin.freebsd70x86_64/p4p) = 596840
diff --git a/devel/p4p/files/p4p.sh.in b/devel/p4p/files/p4p.sh.in
new file mode 100644
index 000000000000..59e111ebfd85
--- /dev/null
+++ b/devel/p4p/files/p4p.sh.in
@@ -0,0 +1,49 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: p4p
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+# These variables (and many more) can be set via environment variables. Check
+# p4p -h for what you can set.
+#
+# Add the following line to /etc/rc.conf to enable p4p:
+# p4p_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable p4p.
+# p4p_cache (str): Default to "%%P4CACHE%%".
+# Base cache directory.
+# p4p_port (int): Default to "1666".
+# Set to TCP port to bind to.
+# p4p_target (str): Default to "perforce:1666".
+# Target server to cache.
+# p4p_debug (str): Default to "server=3".
+# Debug options. Highly recommended.
+# p4p_log (str): Default to "%%P4LOG%%".
+# Logfile for debug output.
+# p4p_args (str): Custom additional arguments to be passed
+# to p4p (default empty).
+#
+
+. /etc/rc.subr
+
+name="p4p"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${p4p_enable="NO"}
+: ${p4p_cache="%%P4CACHE%%"}
+: ${p4p_port="1666"}
+: ${p4p_target="perforce:1666"}
+: ${p4p_debug="server=3"}
+: ${p4p_log="%%P4LOG%%"}
+: ${p4p_args=""}
+
+command="%%PREFIX%%/sbin/p4p"
+command_args="-r ${p4p_cache} -p ${p4p_port} -t ${p4p_target} -v ${p4p_debug} -L ${p4p_log} -d ${p4p_args} > /dev/null 2>&1 &"
+p4p_user="p4admin"
+
+run_rc_command "$1"
diff --git a/devel/p4p/files/perforce.conf.in b/devel/p4p/files/perforce.conf.in
deleted file mode 100644
index 803c56f86d17..000000000000
--- a/devel/p4p/files/perforce.conf.in
+++ /dev/null
@@ -1,75 +0,0 @@
-#
-# Perforce FreeBSD configuration file
-#
-#
-# $FreeBSD$
-
-#
-# Perforce ROOT
-#
-PERFORCE_ROOT="@PERFORCE_ROOT@"
-
-#
-# Perforce user (it is recommended to run p4d as a non-root user)
-#
-PERFORCE_USER="@PERFORCE_USER@"
-
-#
-# p4d/p4p port (default: 1666)
-#
-PERFORCE_PORT="@PERFORCE_PORT@"
-
-#
-# p4p cache directory
-#
-PERFORCE_PROXY_CACHE="@PERFORCE_CACHE@"
-
-#
-# p4p target server (default: perforce:1666)
-#
-PERFORCE_PROXY_TARGET="@PERFORCE_TARGET@"
-
-#
-# p4d options (see man p4d)
-#
-PERFORCE_OPTIONS="-d -p $PERFORCE_PORT -v server=1 -L @PERFORCE_LOGS@/p4d.log"
-
-#
-# Uncomment this line to have the server started automatically
-#
-#PERFORCE_START=yes
-
-#
-# p4ftpd options (see p4ftpd -h)
-#
-PERFORCE_FTPD_OPTIONS="-d -p $PERFORCE_PORT -v server=1 -L @PERFORCE_LOGS@/p4ftpd.log"
-
-#
-# Uncomment this line to have the server started automatically
-#
-#PERFORCE_FTPD_START=yes
-
-#
-# p4p options (see p4p -h)
-#
-PERFORCE_PROXY_OPTIONS="-d -p $PERFORCE_PORT -t $PERFORCE_PROXY_TARGET -r $PERFORCE_PROXY_CACHE -v server=1 -L @PERFORCE_LOGS@/p4p.log"
-
-#
-# Uncomment this line to have the proxy server started automatically
-#
-#PERFORCE_PROXY_START=yes
-
-#
-# p4web port
-#
-PERFORCE_WEB_PORT="6060"
-
-#
-# p4web options (see p4web -h)
-#
-PERFORCE_WEB_OPTIONS="-B -w $PERFORCE_WEB_PORT -p $PERFORCE_PORT -v server=1"
-
-#
-# Uncomment this line to have the web server started automatically
-#
-#PERFORCE_WEB_START=yes
diff --git a/devel/p4p/files/perforce.sh.in b/devel/p4p/files/perforce.sh.in
deleted file mode 100644
index 0567a4823bad..000000000000
--- a/devel/p4p/files/perforce.sh.in
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-p4d=@PREFIX@/sbin/p4d
-p4ftpd=@PREFIX@/sbin/p4ftpd
-p4p=@PREFIX@/sbin/p4p
-p4web=@PREFIX@/sbin/p4web
-
-case $1 in
-start)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4d -a x$PERFORCE_START = xyes ]; then
- echo -n ' p4d'
- umask 027
- su -fm $PERFORCE_USER -c "$p4d -r $PERFORCE_ROOT $PERFORCE_OPTIONS"
- fi
- if [ -x $p4ftpd -a x$PERFORCE_FTPD_START = xyes ]; then
- echo -n ' p4ftpd'
- $p4ftpd $PERFORCE_FTPD_OPTIONS
- fi
- if [ -x $p4p -a x$PERFORCE_PROXY_START = xyes ]; then
- echo -n ' p4p'
- $p4p $PERFORCE_PROXY_OPTIONS
- fi
- if [ -x $p4web -a x$PERFORCE_WEB_START = xyes ]; then
- echo -n ' p4web'
- su -fm $PERFORCE_USER -c "$p4web $PERFORCE_WEB_OPTIONS &" >/dev/null 2>&1
- fi
-
- ;;
-stop)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4ftpd ]; then
- killall -u 0 p4ftpd >/dev/null 2>&1 && echo -n ' p4ftpd'
- fi
- if [ -x $p4d ]; then
- killall -u $PERFORCE_USER p4d >/dev/null 2>&1 && echo -n ' p4d'
- fi
- if [ -x $p4p ]; then
- killall -u 0 p4p > /dev/null 2>&1 && echo -n ' p4p'
- fi
- if [ -x $p4web ]; then
- killall -u $PERFORCE_USER p4web > /dev/null 2>&1 && echo -n ' p4web'
- fi
- ;;
-restart)
- $0 stop
- sleep 1
- $0 start
- ;;
-checkpoint)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4d -a x$PERFORCE_START = xyes ]; then
- su -fm $PERFORCE_USER -c "$p4d -r $PERFORCE_ROOT -jc"
- fi
- ;;
-*)
- echo "usage: $0 {start|stop|restart|checkpoint}"
- exit 64
- ;;
-esac
diff --git a/devel/p4p/pkg-install b/devel/p4p/pkg-install
deleted file mode 100644
index 6c4ff95b3e8b..000000000000
--- a/devel/p4p/pkg-install
+++ /dev/null
@@ -1,52 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-
-PATH=/bin:/usr/sbin
-
-PERFORCE_USER=${PERFORCE_USER:-p4admin}
-PERFORCE_UID=${PERFORCE_UID:-94}
-PERFORCE_GROUP=${PERFORCE_GROUP:-p4admin}
-PERFORCE_GID=${PERFORCE_GID:-94}
-PERFORCE_HOME=${PERFORCE_HOME:-$PKG_PREFIX/perforce}
-PERFORCE_LOGS=${PERFORCE_LOGS:-$PERFORCE_HOME/logs}
-PERFORCE_ROOT=${PERFORCE_ROOT:-$PERFORCE_HOME/root}
-
-case $2 in
-PRE-INSTALL)
- USER=${PERFORCE_USER}
- GROUP=${PERFORCE_GROUP}
- UID=${PERFORCE_UID}
- GID=${PERFORCE_GID}
-
- if pw group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -d ${PERFORCE_HOME} -c "Perforce admin" -s /sbin/nologin
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
-
- if [ ! -d $PERFORCE_HOME ] ; then
- mkdir -p $PERFORCE_HOME $PERFORCE_LOGS $PERFORCE_ROOT
- chown -R $USER:$GROUP $PERFORCE_HOME
- chmod 750 $PERFORCE_ROOT
- fi
- ;;
-esac
diff --git a/devel/p4p/pkg-plist b/devel/p4p/pkg-plist
index 31e0893152cc..42482fcf6bc0 100644
--- a/devel/p4p/pkg-plist
+++ b/devel/p4p/pkg-plist
@@ -1,4 +1,2 @@
-@unexec if cmp -s %D/etc/perforce.conf %D/etc/perforce.conf.default; then rm -f %D/etc/perforce.conf; fi
-etc/perforce.conf.default
-@exec [ ! -f %B/perforce.conf ] && cp -p %B/%f %B/perforce.conf || true
-etc/rc.d/perforce.sh
+@stopdaemon p4p
+sbin/p4p