aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-07-05 17:55:02 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-07-05 17:55:02 +0000
commit789bfee4f5a12c3d724ed636f2167c595032f4d0 (patch)
treed174f07ec4d68f71b50effaaa01b130241056470
parent28bb5d5abd36600a77ad349f75d332c119ac6054 (diff)
downloadports-789bfee4f5a12c3d724ed636f2167c595032f4d0.tar.gz
ports-789bfee4f5a12c3d724ed636f2167c595032f4d0.zip
Notes
-rw-r--r--textproc/ruby-libxml/Makefile25
-rw-r--r--textproc/ruby-libxml/distinfo6
-rw-r--r--textproc/ruby-libxml/pkg-plist23
3 files changed, 48 insertions, 6 deletions
diff --git a/textproc/ruby-libxml/Makefile b/textproc/ruby-libxml/Makefile
index 138335880afa..d3cd031e46da 100644
--- a/textproc/ruby-libxml/Makefile
+++ b/textproc/ruby-libxml/Makefile
@@ -20,8 +20,27 @@ COMMENT= A friendly API to libxml for Ruby
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_RUBY= yes
-USE_RUBYGEMS= yes
-GEM_NAME= ${PORTNAME}-ruby-${PORTVERSION}
-RUBYGEM_AUTOPLIST= yes
+USE_ICONV= yes
+USE_LDCONFIG= ${RUBY_SITEARCHLIBDIR}/xml
+
+EXT_ARGS= --with-iconv-dir=${LOCALBASE} \
+ --with-iconv-lib=${LOCALBASE}/lib \
+ --with-iconv-include=${LOCALBASE}/include
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|libxml_ruby|xml/libxml_ruby|' \
+ ${WRKSRC}/lib/libxml.rb
+
+do-configure:
+ cd ${WRKSRC}/ext/libxml && ${RUBY} extconf.rb build ${EXT_ARGS}
+
+do-build:
+ cd ${WRKSRC}/ext/libxml && ${MAKE}
+
+do-install:
+ ${INSTALL} -d ${RUBY_SITELIBDIR}/xml ${RUBY_SITELIBDIR}/libxml ${RUBY_SITEARCHLIBDIR}/xml
+ ${INSTALL_DATA} ${WRKSRC}/lib/libxml.rb ${RUBY_SITELIBDIR}/xml
+ (cd ${WRKSRC}/lib/libxml && ${COPYTREE_SHARE} \*.rb ${RUBY_SITELIBDIR}/libxml)
+ ${INSTALL_DATA} ${WRKSRC}/ext/libxml/libxml_ruby.so ${RUBY_SITEARCHLIBDIR}/xml/
.include <bsd.port.mk>
diff --git a/textproc/ruby-libxml/distinfo b/textproc/ruby-libxml/distinfo
index 638dfb9b86da..3c46c6a47427 100644
--- a/textproc/ruby-libxml/distinfo
+++ b/textproc/ruby-libxml/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/libxml-ruby-1.1.3.gem) = 5e35a872a1cdc7b62273a05d46c8960c
-SHA256 (rubygem/libxml-ruby-1.1.3.gem) = 91f52ed34fc0a8df8e9aecb0878d5a55246f0e264a25629fa49e0b1a2eb087a3
-SIZE (rubygem/libxml-ruby-1.1.3.gem) = 179712
+MD5 (libxml-ruby-1.1.3.tgz) = 007881e4a5a4ddc29ddf8a3b76edb8b0
+SHA256 (libxml-ruby-1.1.3.tgz) = 53eac48f6a4bdb389e84d2bdf7dda68952fae1ba83de3e520a0c85d499cf6122
+SIZE (libxml-ruby-1.1.3.tgz) = 1495372
diff --git a/textproc/ruby-libxml/pkg-plist b/textproc/ruby-libxml/pkg-plist
new file mode 100644
index 000000000000..3918a66fab36
--- /dev/null
+++ b/textproc/ruby-libxml/pkg-plist
@@ -0,0 +1,23 @@
+%%RUBY_SITEARCHLIBDIR%%/xml/libxml_ruby.so
+%%RUBY_SITELIBDIR%%/xml/libxml.rb
+%%RUBY_SITELIBDIR%%/libxml/attr.rb
+%%RUBY_SITELIBDIR%%/libxml/attr_decl.rb
+%%RUBY_SITELIBDIR%%/libxml/attributes.rb
+%%RUBY_SITELIBDIR%%/libxml/document.rb
+%%RUBY_SITELIBDIR%%/libxml/error.rb
+%%RUBY_SITELIBDIR%%/libxml/hpricot.rb
+%%RUBY_SITELIBDIR%%/libxml/html_parser.rb
+%%RUBY_SITELIBDIR%%/libxml/namespace.rb
+%%RUBY_SITELIBDIR%%/libxml/namespaces.rb
+%%RUBY_SITELIBDIR%%/libxml/node.rb
+%%RUBY_SITELIBDIR%%/libxml/ns.rb
+%%RUBY_SITELIBDIR%%/libxml/parser.rb
+%%RUBY_SITELIBDIR%%/libxml/properties.rb
+%%RUBY_SITELIBDIR%%/libxml/reader.rb
+%%RUBY_SITELIBDIR%%/libxml/sax_callbacks.rb
+%%RUBY_SITELIBDIR%%/libxml/sax_parser.rb
+%%RUBY_SITELIBDIR%%/libxml/tree.rb
+%%RUBY_SITELIBDIR%%/libxml/xpath_object.rb
+@dirrm %%RUBY_SITEARCHLIBDIR%%/xml
+@dirrm %%RUBY_SITELIBDIR%%/xml
+@dirrm %%RUBY_SITELIBDIR%%/libxml