aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-13 16:49:05 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-13 16:49:05 +0000
commit7907a55843cbf8177a99140e6a6003e567bdc89a (patch)
treea247dd4f91c92c0569aee36962ac58c426270804
parent648117b85b6041995510d7f940313534d5a8a849 (diff)
downloadports-7907a55843cbf8177a99140e6a6003e567bdc89a.tar.gz
ports-7907a55843cbf8177a99140e6a6003e567bdc89a.zip
Notes
-rw-r--r--print/Makefile1
-rw-r--r--print/p5-PDFLib/Makefile27
-rw-r--r--print/p5-PDFLib/distinfo1
-rw-r--r--print/p5-PDFLib/pkg-comment1
-rw-r--r--print/p5-PDFLib/pkg-descr1
-rw-r--r--print/p5-PDFLib/pkg-plist3
6 files changed, 34 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 8c9e67e46c48..0a20e8f7dee4 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -95,6 +95,7 @@
SUBDIR += nenscript
SUBDIR += offix-printer
SUBDIR += p5-GnomePrint
+ SUBDIR += p5-PDFLib
SUBDIR += p5-Text-PDF
SUBDIR += panda
SUBDIR += pcal
diff --git a/print/p5-PDFLib/Makefile b/print/p5-PDFLib/Makefile
new file mode 100644
index 000000000000..cef8e38f4006
--- /dev/null
+++ b/print/p5-PDFLib/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: p5-PDFLib
+# Date created: May 13, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= PDFLib
+PORTVERSION= 0.12
+CATEGORIES= print perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MS/MSERGEANT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/pdflib_pl.pm:${PORTSDIR}/print/pdflib
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+NO_BUILD= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= PDFLib.3
+
+.include <bsd.port.mk>
diff --git a/print/p5-PDFLib/distinfo b/print/p5-PDFLib/distinfo
new file mode 100644
index 000000000000..ebdf2519f051
--- /dev/null
+++ b/print/p5-PDFLib/distinfo
@@ -0,0 +1 @@
+MD5 (PDFLib-0.12.tar.gz) = 49ba9d136cc83210d37e7f4763b064cc
diff --git a/print/p5-PDFLib/pkg-comment b/print/p5-PDFLib/pkg-comment
new file mode 100644
index 000000000000..5158a15b2ca7
--- /dev/null
+++ b/print/p5-PDFLib/pkg-comment
@@ -0,0 +1 @@
+More OO interface to pdflib_pl.pm
diff --git a/print/p5-PDFLib/pkg-descr b/print/p5-PDFLib/pkg-descr
new file mode 100644
index 000000000000..069526db4817
--- /dev/null
+++ b/print/p5-PDFLib/pkg-descr
@@ -0,0 +1 @@
+A cleaner API than pdflib_pl.pm, which is a very low-level (non-OO) interface.
diff --git a/print/p5-PDFLib/pkg-plist b/print/p5-PDFLib/pkg-plist
new file mode 100644
index 000000000000..fe88530f847e
--- /dev/null
+++ b/print/p5-PDFLib/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/PDFLib.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/PDFLib/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/PDFLib