aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-05-16 02:39:50 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-05-16 02:39:50 +0000
commit7c644cf042f8a7efc2c85879e5a64cf24f8f11ea (patch)
tree2d85ed2a749bf0aa186830b0fd609fc917510bee
parentf07e29a507dec248ea01fd9a9c0aa871f5b30452 (diff)
downloadports-7c644cf042f8a7efc2c85879e5a64cf24f8f11ea.tar.gz
ports-7c644cf042f8a7efc2c85879e5a64cf24f8f11ea.zip
Notes
-rw-r--r--databases/mysql++1/Makefile25
-rw-r--r--databases/mysql++1/pkg-plist2
2 files changed, 13 insertions, 14 deletions
diff --git a/databases/mysql++1/Makefile b/databases/mysql++1/Makefile
index b902a9760bfc..54ca1f04629a 100644
--- a/databases/mysql++1/Makefile
+++ b/databases/mysql++1/Makefile
@@ -20,23 +20,22 @@ USE_LDCONFIG= yes
CONFLICTS= ${PORTNAME}*-2.*
-NO_STAGE= yes
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/userman/html ${DOCSDIR}/refman/html
- @${INSTALL_DATA} ${WRKSRC}/doc/userman/html/* ${DOCSDIR}/userman/html
- @${INSTALL_DATA} ${WRKSRC}/doc/refman/html/* ${DOCSDIR}/refman/html
- @${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${DOCSDIR}
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/*.cpp ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/*.h ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/README ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/Makefile.simple ${EXAMPLESDIR}/Makefile.temp
- @${SED} -e "s|/usr/include/mysql++|${PREFIX}/include/mysql++|" < ${EXAMPLESDIR}/Makefile.temp | \
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/userman/html ${STAGEDIR}${DOCSDIR}/refman/html
+ @${INSTALL_DATA} ${WRKSRC}/doc/userman/html/* ${STAGEDIR}${DOCSDIR}/userman/html
+ @${INSTALL_DATA} ${WRKSRC}/doc/refman/html/* ${STAGEDIR}${DOCSDIR}/refman/html
+ @${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/*.cpp ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/*.h ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/README ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/Makefile.simple ${STAGEDIR}${EXAMPLESDIR}/Makefile.temp
+ @${SED} -e "s|/usr/include/mysql++|${PREFIX}/include/mysql++|" < ${STAGEDIR}${EXAMPLESDIR}/Makefile.temp | \
${SED} -e "s|/usr/include/mysql|${LOCALBASE}/include/mysql|" | \
${SED} -e "s|-lmysqlpp|-L${PREFIX}/lib -L${LOCALBASE}/lib/mysql -lmysqlpp|" \
- > ${EXAMPLESDIR}/Makefile
- @${RM} -f ${EXAMPLESDIR}/Makefile.temp
+ > ${STAGEDIR}${EXAMPLESDIR}/Makefile
+ @${RM} -f ${STAGEDIR}${EXAMPLESDIR}/Makefile.temp
.endif
.include <bsd.port.mk>
diff --git a/databases/mysql++1/pkg-plist b/databases/mysql++1/pkg-plist
index 2434fc130958..f842f216eead 100644
--- a/databases/mysql++1/pkg-plist
+++ b/databases/mysql++1/pkg-plist
@@ -12,6 +12,7 @@ include/mysql++/field_names.h
include/mysql++/field_types.h
include/mysql++/fields.h
include/mysql++/manip.h
+include/mysql++/myset.h
include/mysql++/mysql++.h
include/mysql++/mysql++.hh
include/mysql++/null.h
@@ -20,7 +21,6 @@ include/mysql++/query.h
include/mysql++/resiter.h
include/mysql++/result.h
include/mysql++/row.h
-include/mysql++/myset.h
include/mysql++/sql_query.h
include/mysql++/sql_string.h
include/mysql++/sqlplus.hh