aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:28:48 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:28:48 +0000
commit8ca55ac87912da426b5ff12466324e5edc1b7f22 (patch)
tree3ac7eb75dd9515e51f7a0b6d343fe9624e2b1c1c
parent7bd84323106d03c2959e52613e5a608277ede726 (diff)
downloadports-8ca55ac87912da426b5ff12466324e5edc1b7f22.tar.gz
ports-8ca55ac87912da426b5ff12466324e5edc1b7f22.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/etoile-foundation/Makefile33
-rw-r--r--devel/etoile-foundation/distinfo3
-rw-r--r--devel/etoile-foundation/pkg-descr3
-rw-r--r--devel/etoile-foundation/pkg-plist14
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 71af469c3f2b..6622ede49943 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -278,6 +278,7 @@
SUBDIR += esdl
SUBDIR += esvn
SUBDIR += etoile-collectionkit
+ SUBDIR += etoile-foundation
SUBDIR += etoile-unitkit
SUBDIR += evfs
SUBDIR += evolution-gconf-tools
diff --git a/devel/etoile-foundation/Makefile b/devel/etoile-foundation/Makefile
new file mode 100644
index 000000000000..1471feacd79a
--- /dev/null
+++ b/devel/etoile-foundation/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: etoile-foundation
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= foundation
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~%%SUBDIR%%/distfiles/
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project EtoileFoundation framework
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+DEFAULT_LIBVERSION= 0.1
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/EtoileFoundation
+
+.include <bsd.port.mk>
diff --git a/devel/etoile-foundation/distinfo b/devel/etoile-foundation/distinfo
new file mode 100644
index 000000000000..545ac18e8091
--- /dev/null
+++ b/devel/etoile-foundation/distinfo
@@ -0,0 +1,3 @@
+MD5 (Etoile-20061221.tar.bz2) = 120ffa8cf06c58ff775f8a218ad91448
+SHA256 (Etoile-20061221.tar.bz2) = 7dc8acbf2cb46d9d119c9817204bbbbe72884065f3287877550c400e68f4c992
+SIZE (Etoile-20061221.tar.bz2) = 9867481
diff --git a/devel/etoile-foundation/pkg-descr b/devel/etoile-foundation/pkg-descr
new file mode 100644
index 000000000000..68405705b012
--- /dev/null
+++ b/devel/etoile-foundation/pkg-descr
@@ -0,0 +1,3 @@
+EtoileFoundation framework
+
+WWW: http://www.etoile-project.org/
diff --git a/devel/etoile-foundation/pkg-plist b/devel/etoile-foundation/pkg-plist
new file mode 100644
index 000000000000..31e4d2af40be
--- /dev/null
+++ b/devel/etoile-foundation/pkg-plist
@@ -0,0 +1,14 @@
+Local/Library/Headers/EtoileFoundation/Cocoa.h
+Local/Library/Headers/EtoileFoundation/EtoileCompatibility.h
+Local/Library/Headers/EtoileFoundation/NSFileManager+NameForTempFile.h
+Local/Library/Headers/EtoileFoundation/UKFileWatcher.h
+Local/Library/Headers/EtoileFoundation/UKKQueue.h
+Local/Library/Headers/EtoileFoundation/UKMainThreadProxy.h
+Local/Library/Headers/EtoileFoundation/UKNibOwner.h
+Local/Library/Headers/EtoileFoundation/UKPluginsRegistry.h
+Local/Library/Headers/EtoileFoundation/UKPushbackMessenger.h
+Local/Library/Headers/EtoileFoundation/UKThreadMessenger.h
+Local/Library/Libraries/libEtoileFoundation.so
+Local/Library/Libraries/libEtoileFoundation.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libEtoileFoundation.so.%%LIBVERSION%%
+@dirrm Local/Library/Headers/EtoileFoundation