aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-03-11 19:25:25 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-03-11 19:25:25 +0000
commit93a87917469e877b6055e8274006b943e2d1151f (patch)
treec01ec412d9ec7408caad6c2bfaa30391a154406e
parent1b481b766e7a0cf26ea68fdcbd0ad7e5bf5d04d9 (diff)
downloadports-93a87917469e877b6055e8274006b943e2d1151f.tar.gz
ports-93a87917469e877b6055e8274006b943e2d1151f.zip
Notes
-rw-r--r--x11-wm/blackbox/Makefile17
-rw-r--r--x11-wm/blackbox/distinfo4
-rw-r--r--x11-wm/blackbox/files/patch-lib::Image.cc11
-rw-r--r--x11-wm/blackbox/files/patch-src::Screen.cc11
-rw-r--r--x11-wm/blackbox/files/patch-src::Timer.hh15
-rw-r--r--x11-wm/blackbox/files/patch-src::Window.cc10
-rw-r--r--x11-wm/blackbox/pkg-plist115
7 files changed, 52 insertions, 131 deletions
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index 4ddec794d0ad..161d21d1c6e7 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= blackbox
-PORTVERSION= 0.65.0
+PORTVERSION= 0.70.0
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= blackboxwm
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dako@bsdberlin.org
COMMENT= A small and fast window manager for X11R6
RUN_DEPENDS= bsetbg:${PORTSDIR}/x11-wm/boxtools
@@ -21,11 +21,14 @@ MAN1= blackbox.1
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+USE_ICONV= yes
+USE_GNOME= pkgconfig gnomehack
+USE_GCC= 3.3+
-pre-patch:
- ${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's#nls src util#nls src#' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -E 's/^SUBDIRS/#SUBDIRS/' ${WRKSRC}/doc/Makefile.in
- ${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' ${WRKSRC}/doc/Makefile.in
+post-patch:
+ @${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's#nls src util#nls src#' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -E 's/^SUBDIRS/#SUBDIRS/' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' ${WRKSRC}/doc/Makefile.in
.include <bsd.port.mk>
diff --git a/x11-wm/blackbox/distinfo b/x11-wm/blackbox/distinfo
index a1dfde27307b..73cf326fb44d 100644
--- a/x11-wm/blackbox/distinfo
+++ b/x11-wm/blackbox/distinfo
@@ -1,2 +1,2 @@
-MD5 (blackbox-0.65.0.tar.gz) = 08560fa287c68d65fbe894696d04deaf
-SIZE (blackbox-0.65.0.tar.gz) = 292950
+MD5 (blackbox-0.70.0.tar.gz) = 033a92af3eecaa10bcb689e55a1ceadc
+SIZE (blackbox-0.70.0.tar.gz) = 583527
diff --git a/x11-wm/blackbox/files/patch-lib::Image.cc b/x11-wm/blackbox/files/patch-lib::Image.cc
new file mode 100644
index 000000000000..bd5cad66e49a
--- /dev/null
+++ b/x11-wm/blackbox/files/patch-lib::Image.cc
@@ -0,0 +1,11 @@
+--- lib/Image.cc.orig Thu Mar 10 18:39:23 2005
++++ lib/Image.cc Thu Mar 10 18:40:09 2005
+@@ -467,7 +467,7 @@
+ if (colors[x] != ~0ul)
+ continue;
+
+- int red, green, blue, gray;
++ int red = 0, green = 0, blue = 0, gray = 0;
+
+ switch (visual_class) {
+ case StaticGray:
diff --git a/x11-wm/blackbox/files/patch-src::Screen.cc b/x11-wm/blackbox/files/patch-src::Screen.cc
deleted file mode 100644
index d92e9d3ab10f..000000000000
--- a/x11-wm/blackbox/files/patch-src::Screen.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Screen.cc.orig Wed Sep 4 19:15:58 2002
-+++ src/Screen.cc Thu Sep 19 09:12:24 2002
-@@ -1120,7 +1120,7 @@
- focused->getScreen()->getScreenNumber() == getScreenNumber() &&
- current_workspace->getCount() > 1) {
- do {
-- next = current_workspace->getNextWindowInList(next);
-+ next = current_workspace->getPrevWindowInList(next);
- } while(next != focused && ! next->setInputFocus());
-
- if (next != focused)
diff --git a/x11-wm/blackbox/files/patch-src::Timer.hh b/x11-wm/blackbox/files/patch-src::Timer.hh
deleted file mode 100644
index 89b27ecf0e21..000000000000
--- a/x11-wm/blackbox/files/patch-src::Timer.hh
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/Timer.hh~ Sun Aug 1 17:13:29 2004
-+++ src/Timer.hh Sun Aug 1 17:14:13 2004
-@@ -98,9 +98,10 @@
- ~_timer_queue(void) {}
-
- void release(const _Tp& value) {
-- c.erase(std::remove(c.begin(), c.end(), value), c.end());
-+ _Base::c.erase(std::remove(_Base::c.begin(), _Base::c.end(), value),
-+ _Base::c.end());
- // after removing the item we need to make the heap again
-- std::make_heap(c.begin(), c.end(), comp);
-+ std::make_heap(_Base::c.begin(), _Base::c.end(), _Base::comp);
- }
- bool empty(void) const { return _Base::empty(); }
- size_t size(void) const { return _Base::size(); }
diff --git a/x11-wm/blackbox/files/patch-src::Window.cc b/x11-wm/blackbox/files/patch-src::Window.cc
deleted file mode 100644
index ec6c3afd4e04..000000000000
--- a/x11-wm/blackbox/files/patch-src::Window.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Window.cc.orig Wed Aug 13 12:40:02 2003
-+++ src/Window.cc Wed Aug 13 12:41:03 2003
-@@ -44,6 +44,8 @@
- #endif // HAVE_STDLIB_H
- }
-+#include <cassert>
-+
- #include "i18n.hh"
- #include "blackbox.hh"
- #include "GCCache.hh"
diff --git a/x11-wm/blackbox/pkg-plist b/x11-wm/blackbox/pkg-plist
index ff7978c8cf67..6f07e7330558 100644
--- a/x11-wm/blackbox/pkg-plist
+++ b/x11-wm/blackbox/pkg-plist
@@ -1,87 +1,30 @@
bin/blackbox
-share/blackbox/menu
-share/blackbox/nls/C/blackbox.cat
-share/blackbox/nls/da_DK/blackbox.cat
-share/blackbox/nls/de_DE/blackbox.cat
-share/blackbox/nls/es_AR/blackbox.cat
-share/blackbox/nls/es_ES/blackbox.cat
-share/blackbox/nls/fr_FR/blackbox.cat
-share/blackbox/nls/hu_HU/blackbox.cat
-share/blackbox/nls/it_IT/blackbox.cat
-share/blackbox/nls/ja_JP/blackbox.cat
-share/blackbox/nls/ko_KR/blackbox.cat
-share/blackbox/nls/lv_LV/blackbox.cat
-share/blackbox/nls/nl_NL/blackbox.cat
-share/blackbox/nls/no_NO/blackbox.cat
-share/blackbox/nls/pl_PL/blackbox.cat
-share/blackbox/nls/pt_BR/blackbox.cat
-share/blackbox/nls/ro_RO/blackbox.cat
-share/blackbox/nls/ru_RU/blackbox.cat
-share/blackbox/nls/sk_SK/blackbox.cat
-share/blackbox/nls/sl_SI/blackbox.cat
-share/blackbox/nls/sv_SE/blackbox.cat
-share/blackbox/nls/uk_UA/blackbox.cat
-share/blackbox/nls/zh_CN/blackbox.cat
-share/blackbox/nls/zh_TW/blackbox.cat
-share/blackbox/styles/Artwiz
-share/blackbox/styles/Cthulhain
-share/blackbox/styles/Flux
-share/blackbox/styles/Minimal
-share/blackbox/styles/Nyz
-share/blackbox/styles/Operation
-share/blackbox/styles/Outcomes
-share/blackbox/styles/Rampage
-share/blackbox/styles/Rancor
-share/blackbox/styles/Results
-share/blackbox/styles/Shade
-share/blackbox/styles/Spiff
-share/blackbox/styles/TDF
-share/blackbox/styles/Twice
-@dirrm share/blackbox/nls/C
-@dirrm share/blackbox/nls/da_DK
-@dirrm share/blackbox/nls/de_DE
-@dirrm share/blackbox/nls/es_AR
-@dirrm share/blackbox/nls/es_ES
-@dirrm share/blackbox/nls/fr_FR
-@dirrm share/blackbox/nls/hu_HU
-@dirrm share/blackbox/nls/it_IT
-@dirrm share/blackbox/nls/ja_JP
-@dirrm share/blackbox/nls/ko_KR
-@dirrm share/blackbox/nls/lv_LV
-@dirrm share/blackbox/nls/nl_NL
-@dirrm share/blackbox/nls/no_NO
-@dirrm share/blackbox/nls/pl_PL
-@dirrm share/blackbox/nls/pt_BR
-@dirrm share/blackbox/nls/ro_RO
-@dirrm share/blackbox/nls/ru_RU
-@dirrm share/blackbox/nls/sk_SK
-@dirrm share/blackbox/nls/sl_SI
-@dirrm share/blackbox/nls/sv_SE
-@dirrm share/blackbox/nls/uk_UA
-@dirrm share/blackbox/nls/zh_CN
-@dirrm share/blackbox/nls/zh_TW
-@exec ln -s C %D/share/blackbox/nls/POSIX
-@unexec rm %D/share/blackbox/nls/POSIX
-@exec ln -s C %D/share/blackbox/nls/US_ASCII
-@unexec rm %D/share/blackbox/nls/US_ASCII
-@exec ln -s de_DE %D/share/blackbox/nls/de
-@unexec rm %D/share/blackbox/nls/de
-@exec ln -s C %D/share/blackbox/nls/en
-@unexec rm %D/share/blackbox/nls/en
-@exec ln -s C %D/share/blackbox/nls/en_GB
-@unexec rm %D/share/blackbox/nls/en_GB
-@exec ln -s C %D/share/blackbox/nls/en_US
-@unexec rm %D/share/blackbox/nls/en_US
-@exec ln -s es_ES %D/share/blackbox/nls/es
-@unexec rm %D/share/blackbox/nls/es
-@exec ln -s es_ES %D/share/blackbox/nls/es_MX
-@unexec rm %D/share/blackbox/nls/es_MX
-@exec ln -s fr_FR %D/share/blackbox/nls/fr
-@unexec rm %D/share/blackbox/nls/fr
-@exec ln -s it_IT %D/share/blackbox/nls/it
-@unexec rm %D/share/blackbox/nls/it
-@exec ln -s nl_NL %D/share/blackbox/nls/nl
-@unexec rm %D/share/blackbox/nls/nl
-@dirrm share/blackbox/nls
-@dirrm share/blackbox/styles
-@dirrm share/blackbox
+bin/bstyleconvert
+include/bt/Application.hh
+include/bt/Bitmap.hh
+include/bt/Color.hh
+include/bt/Display.hh
+include/bt/EWMH.hh
+include/bt/EventHandler.hh
+include/bt/Font.hh
+include/bt/Image.hh
+include/bt/Menu.hh
+include/bt/Pen.hh
+include/bt/PixmapCache.hh
+include/bt/Rect.hh
+include/bt/Resource.hh
+include/bt/Texture.hh
+include/bt/Timer.hh
+include/bt/Unicode.hh
+include/bt/Util.hh
+lib/libbt.a
+libdata/pkgconfig/libbt.pc
+%%DATADIR%%/menu
+%%DATADIR%%/styles/Blue
+%%DATADIR%%/styles/Gray
+%%DATADIR%%/styles/Green
+%%DATADIR%%/styles/Purple
+%%DATADIR%%/styles/Red
+@dirrm include/bt
+@dirrm %%DATADIR%%/styles
+@dirrm %%DATADIR%%