aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-04-02 00:45:54 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-04-02 00:45:54 +0000
commita64022f47300fa27b3d7e4dcb38050644d28f4c8 (patch)
tree6f141af907fd65feb018101c7bec094b8124e1e5
parent6e5f15b9e3e842635df8f74f3d05075965726656 (diff)
downloadports-a64022f47300fa27b3d7e4dcb38050644d28f4c8.tar.gz
ports-a64022f47300fa27b3d7e4dcb38050644d28f4c8.zip
Notes
-rw-r--r--comms/gnokii/Makefile24
-rw-r--r--comms/gnokii/distinfo1
-rw-r--r--comms/gnokii/files/patch-aa23
-rw-r--r--comms/gnokii/files/patch-ab29
-rw-r--r--comms/gnokii/files/patch-ac29
-rw-r--r--comms/gnokii/pkg-comment1
-rw-r--r--comms/gnokii/pkg-descr7
-rw-r--r--comms/gnokii/pkg-plist1
-rw-r--r--comms/gnokii/scripts/post-extract10
9 files changed, 125 insertions, 0 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
new file mode 100644
index 000000000000..723eb3c002c8
--- /dev/null
+++ b/comms/gnokii/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gnokii
+# Version required: 0.2.3
+# Date created: 15 March 1999
+# Whom: staffanu
+#
+# $Id$
+#
+
+DISTNAME= gnokii-0.2.3
+CATEGORIES= comms
+MASTER_SITES= ftp://multivac.fatburen.org/pub/gnokii/ \
+ ftp://multivac.fatburen.org/pub/gnokii/old/
+
+MAINTAINER= staffanu@nada.kth.se
+
+USE_GMAKE= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/gnokii ${PREFIX}/bin/gnokii
+
+post-install:
+ strip ${PREFIX}/bin/gnokii
+
+.include <bsd.port.mk>
diff --git a/comms/gnokii/distinfo b/comms/gnokii/distinfo
new file mode 100644
index 000000000000..2fa91d5c3ae4
--- /dev/null
+++ b/comms/gnokii/distinfo
@@ -0,0 +1 @@
+MD5 (gnokii-0.2.3.tar.gz) = e3d511ca575b78b2f7022324fcf324ab
diff --git a/comms/gnokii/files/patch-aa b/comms/gnokii/files/patch-aa
new file mode 100644
index 000000000000..e9c6b1b9b060
--- /dev/null
+++ b/comms/gnokii/files/patch-aa
@@ -0,0 +1,23 @@
+*** Makefile.orig Fri Mar 5 00:21:14 1999
+--- Makefile Wed Mar 17 00:02:57 1999
+***************
+*** 7,15 ****
+ CC = gcc
+
+ # Set up compilation/linking flags.
+! CFLAGS = -D_REENTRANT -Wall -g -O0 -pthread
+
+! LDFLAGS = -lpthread
+
+ GNOKII_OBJS = gnokii.o gsm-api.o fbus-3810.o fbus-6110.o
+
+--- 7,15 ----
+ CC = gcc
+
+ # Set up compilation/linking flags.
+! CFLAGS = -D_THREAD_SAFE -Wall -g -O0 -pthread
+
+! LDFLAGS = -pthread
+
+ GNOKII_OBJS = gnokii.o gsm-api.o fbus-3810.o fbus-6110.o
+
diff --git a/comms/gnokii/files/patch-ab b/comms/gnokii/files/patch-ab
new file mode 100644
index 000000000000..2f64bb02ed49
--- /dev/null
+++ b/comms/gnokii/files/patch-ab
@@ -0,0 +1,29 @@
+*** fbus-3810.c.orig Wed Mar 17 00:02:05 1999
+--- fbus-3810.c Wed Mar 17 00:04:20 1999
+***************
+*** 24,30 ****
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <ctype.h>
+! #include <sys/signal.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <string.h>
+--- 24,30 ----
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <ctype.h>
+! #include <signal.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <string.h>
+***************
+*** 537,543 ****
+ /* Set up and install handler before enabling async IO on port. */
+ sig_io.sa_handler = FB38_SigHandler;
+ sig_io.sa_flags = 0;
+- sig_io.sa_restorer = NULL;
+ sigaction (SIGIO, &sig_io, NULL);
+
+ /* Allow process/thread to receive SIGIO */
+--- 537,542 ----
diff --git a/comms/gnokii/files/patch-ac b/comms/gnokii/files/patch-ac
new file mode 100644
index 000000000000..8d15b10032d3
--- /dev/null
+++ b/comms/gnokii/files/patch-ac
@@ -0,0 +1,29 @@
+*** fbus-6110.c.orig Wed Mar 17 00:05:17 1999
+--- fbus-6110.c Wed Mar 17 00:05:09 1999
+***************
+*** 24,30 ****
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <ctype.h>
+! #include <sys/signal.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <string.h>
+--- 24,30 ----
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <ctype.h>
+! #include <signal.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <string.h>
+***************
+*** 218,224 ****
+ /* Set up and install handler before enabling async IO on port. */
+ sig_io.sa_handler = FB61_SigHandler;
+ sig_io.sa_flags = 0;
+- sig_io.sa_restorer = NULL;
+ sigaction (SIGIO, &sig_io, NULL);
+
+ /* Allow process/thread to receive SIGIO */
+--- 218,223 ----
diff --git a/comms/gnokii/pkg-comment b/comms/gnokii/pkg-comment
new file mode 100644
index 000000000000..525de34361d9
--- /dev/null
+++ b/comms/gnokii/pkg-comment
@@ -0,0 +1 @@
+Software to talk to Nokia 3810/3110/8110/6110 cellular phones.
diff --git a/comms/gnokii/pkg-descr b/comms/gnokii/pkg-descr
new file mode 100644
index 000000000000..d42229c3992e
--- /dev/null
+++ b/comms/gnokii/pkg-descr
@@ -0,0 +1,7 @@
+Software to talk to Nokia 3810/3110/8110/6110 cellular phones. The
+software is under development and is currently not especially useful.
+
+http://multivac.fatburen.org/gnokii
+
+- Staffan Ulfberg
+staffanu@nada.kth.se
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
new file mode 100644
index 000000000000..0defe085ef0f
--- /dev/null
+++ b/comms/gnokii/pkg-plist
@@ -0,0 +1 @@
+bin/gnokii
diff --git a/comms/gnokii/scripts/post-extract b/comms/gnokii/scripts/post-extract
new file mode 100644
index 000000000000..ca393b3db04b
--- /dev/null
+++ b/comms/gnokii/scripts/post-extract
@@ -0,0 +1,10 @@
+#!/bin/sh
+cat <<EOF
+---------------------------------------------------------------------
+Notice: The gnokii software is currently configured to build for the
+3810/3110/8110 cellular phones. If you want to compile it for the
+6110 (not yet implemented, but might be good for testers), edit the
+file work/gnokii-0.2.3/gnokii.c and change the #define for MODEL to
+reflect this.
+---------------------------------------------------------------------
+EOF