aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-01-03 10:59:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-01-03 10:59:48 +0000
commitb1e8459a6f10a8f6d8c7d13ce7ca823e79130887 (patch)
tree651f2b79921e203f1365c51010104193bf80a7b5
parent24a8b3e695e3d2e346a7d73a4de7c6e5f272702e (diff)
downloadports-b1e8459a6f10a8f6d8c7d13ce7ca823e79130887.tar.gz
ports-b1e8459a6f10a8f6d8c7d13ce7ca823e79130887.zip
Notes
-rw-r--r--audio/aureal-kmod/Makefile8
-rw-r--r--audio/xmms-openspc/Makefile10
-rw-r--r--emulators/doscmd/Makefile9
-rw-r--r--net/cyphesis/Makefile8
-rw-r--r--net/gpxe/Makefile8
-rw-r--r--net/openospfd/Makefile8
-rw-r--r--security/openbsm-devel/Makefile8
-rw-r--r--security/ssh-copy-id/Makefile8
-rw-r--r--sysutils/apt/Makefile8
-rw-r--r--sysutils/fusefs-kmod/Makefile7
-rw-r--r--textproc/aiksaurus-gtk/Makefile4
-rw-r--r--textproc/aiksaurus/Makefile8
-rw-r--r--x11-drivers/drm-kmod/Makefile8
13 files changed, 48 insertions, 54 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index 2b78e91c8121..62b05a25abcc 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -13,7 +13,9 @@ DISTNAME= au88x0-${PORTVERSION}_4
MAINTAINER= c.kworr@gmail.com
COMMENT= Driver for Aureal Vortex based soundcards
-BROKEN= Unfetchable (google code has gone away)
+BROKEN= does not build (and fetch)
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
ONLY_FOR_ARCHS= i386
STRAYFILES= au88x0.h au88x0.c asp10.o asp20.o asp30.o
@@ -36,10 +38,6 @@ USES= kmod
EXTRA_PATCHES+= ${PATCHDIR}/extra_800000_patch-au88x0.c
-.if ${OSVERSION} >= 1000000
-BROKEN= does not build
-.endif
-
pre-everything::
.for STRAY in ${STRAYFILES}
.if exists(${SRC_BASE}/sys/dev/sound/pci/${STRAY})
diff --git a/audio/xmms-openspc/Makefile b/audio/xmms-openspc/Makefile
index 983de18a0546..1e4295124677 100644
--- a/audio/xmms-openspc/Makefile
+++ b/audio/xmms-openspc/Makefile
@@ -12,6 +12,10 @@ DISTNAME= xmms-OpenSPC-${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= SPC player for XMMS using OpenSPC
+BROKEN= does not build on FreeBSD 10.x and later
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
+
BUILD_DEPENDS= nasm:devel/nasm \
xmms:multimedia/xmms
RUN_DEPENDS= xmms:multimedia/xmms
@@ -23,10 +27,4 @@ PLIST_FILES= lib/xmms/Input/openspc.so
ONLY_FOR_ARCHS= i386 # contains x86 assembler code
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} >= 1000000
-BROKEN= does not build on FreeBSD 10.x and later
-.endif
-
.include <bsd.port.mk>
diff --git a/emulators/doscmd/Makefile b/emulators/doscmd/Makefile
index 5d385266a091..02aa8829499c 100644
--- a/emulators/doscmd/Makefile
+++ b/emulators/doscmd/Makefile
@@ -8,6 +8,10 @@ MASTER_SITES= SF/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= DOS emulator
+BROKEN= does not build (accesses field of opaque structure)
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
+
ONLY_FOR_ARCHS= i386
FONTFILES= cp437-8x8.pcf.gz cp437-8x14.pcf.gz cp437-8x16.pcf.gz
@@ -23,11 +27,6 @@ X11_MAKE_ARGS_OFF= -DNO_X
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000012
-# files/extra-patch-cwd.c will fix this, see inside
-BROKEN= does not build (accesses field of opaque structure)
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index d4d490fb398a..f14dc8b59bf5 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -12,6 +12,10 @@ COMMENT= Server for WorldForge games
LICENSE= GPLv2
+BROKEN= Does not compile on FreeBSD 10+
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
+
LIB_DEPENDS= libAtlas-0.6.so:devel/atlas-devel \
libvarconf-1.0.so:devel/varconf \
libwfmath-1.0.so:math/wfmath \
@@ -33,10 +37,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-BROKEN= Does not compile on FreeBSD 10+
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' \
diff --git a/net/gpxe/Makefile b/net/gpxe/Makefile
index 41b7031b6801..a692b82241b1 100644
--- a/net/gpxe/Makefile
+++ b/net/gpxe/Makefile
@@ -13,6 +13,10 @@ COMMENT= Open Source (GPL) gPXE network bootloader
LICENSE= GPLv2
+BROKEN= does not build on FreeBSD 10.x and later
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
+
BUILD_DEPENDS= syslinux:sysutils/syslinux \
mkisofs:sysutils/cdrtools
@@ -31,10 +35,6 @@ SUB_FILES= pkg-message
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= not yet ported to anything other than amd64/i386
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-BROKEN= does not build on FreeBSD 10.x and later
-.endif
-
.if ${ARCH} == "amd64"
MAKE_ARGS+= ARCH=i386
.endif
diff --git a/net/openospfd/Makefile b/net/openospfd/Makefile
index bef8b51964b6..b9cbe0bf8e0e 100644
--- a/net/openospfd/Makefile
+++ b/net/openospfd/Makefile
@@ -16,6 +16,10 @@ COMMENT= Free implementation of the Open Shortest Path First Protocol
LICENSE= ISCL
+BROKEN= requires old CARP implementation (interface layer)
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
+
CONFLICTS= zebra-0* quagga-0*
LIB_DEPENDS= libevent.so:devel/libevent2
@@ -54,10 +58,6 @@ post-patch:
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000003
-BROKEN= requires old CARP implementation (interface layer)
-.endif
-
do-build:
.for subdir in ospfd ospfctl
${MAKE_CMD} -C ${WRKSRC}/${subdir} COPTS="${COPTS}" LDADD="${LDADD}"
diff --git a/security/openbsm-devel/Makefile b/security/openbsm-devel/Makefile
index 61766b41fc5e..766676fa8fda 100644
--- a/security/openbsm-devel/Makefile
+++ b/security/openbsm-devel/Makefile
@@ -14,6 +14,10 @@ COMMENT= Open Source Basic Security Module (BSM) Audit Implementation
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+IGNORE= is not needed under FreeBSD 10.x or higher
+DEPRECATED= ${IGNORE}
+EXPIRATION_DATE= 2017-01-15
+
CONFLICTS= openbsm-1.[0-9]*
GNU_CONFIGURE= yes
@@ -37,10 +41,6 @@ NEEDVARDIRS= ""
NEEDVARDIRS= "@comment "
.endif
-.if ${OSVERSION} >= 1000000
-IGNORE= is not needed under FreeBSD 10.x or higher
-.endif
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libauditd.so.0.0.0
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libbsm.so.0.0.0
diff --git a/security/ssh-copy-id/Makefile b/security/ssh-copy-id/Makefile
index ef2138bfbc01..ddbc4db2e728 100644
--- a/security/ssh-copy-id/Makefile
+++ b/security/ssh-copy-id/Makefile
@@ -10,16 +10,16 @@ DISTFILES= # none
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Small script which copies your ssh public-key to a remote host
+IGNORE= is already in the base system
+DEPRECATED= ${IGNORE}
+EXPIRATION_DATE= 2017-01-15
+
NO_BUILD= yes
PLIST_FILES= bin/ssh-copy-id man/man1/ssh-copy-id.1.gz
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 1000024
-IGNORE= is already in the base system
-.endif
-
pre-patch:
.for f in ssh-copy-id ssh-copy-id.1
@${CP} ${FILESDIR}/${f} ${WRKDIR}
diff --git a/sysutils/apt/Makefile b/sysutils/apt/Makefile
index a29da44012f8..e3a1069203ba 100644
--- a/sysutils/apt/Makefile
+++ b/sysutils/apt/Makefile
@@ -11,6 +11,10 @@ DISTNAME= apt_0.6.46.4-0.1
MAINTAINER= koobs@FreeBSD.org
COMMENT= Advanced front-end for dpkg
+BROKEN= does not build on 10+
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
+
BUILD_DEPENDS= bash:shells/bash \
${LOCALBASE}/lib/libpub.a:devel/publib
RUN_DEPENDS:= ${BUILD_DEPENDS} \
@@ -35,10 +39,6 @@ PLIST_SUB+= APTDIR=${APTDIR:C,^/,,}
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-BROKEN= does not build
-.endif
-
post-patch:
${CP} ${FILESDIR}/https.cc ${FILESDIR}/https.h ${WRKSRC}/methods/
${REINPLACE_CMD} -e 's|@PREFIX@|${PREFIX}|g' -e \
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index 18479e648112..4ed85cfbfbe7 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -10,6 +10,10 @@ MASTER_SITES= https://googledrive.com/host/0B0OQnKtejJEMQlpoTy11SG1nN2s/
MAINTAINER= dpejesh@yahoo.com
COMMENT= FUSE kernel module
+IGNORE= integrated into base
+DEPRECATED= ${IGNORE}
+EXPIRATION_DATE= 2017-01-15
+
BUILD_DEPENDS= fusefs-libs>2.4.1:sysutils/fusefs-libs
ONLY_FOR_ARCHS= amd64 i386
@@ -32,9 +36,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-9-fuse_main.c
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-9-fuse_vfsops.c
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-9-fuse_vnops.c
.endif
-.if ${OSVERSION} >= 1000000
-IGNORE= integrated into base
-.endif
do-build:
cd ${WRKDIR}/modules/fuse; ${MAKE}
diff --git a/textproc/aiksaurus-gtk/Makefile b/textproc/aiksaurus-gtk/Makefile
index f6a78f14c3b8..eaa5cf8ca4e3 100644
--- a/textproc/aiksaurus-gtk/Makefile
+++ b/textproc/aiksaurus-gtk/Makefile
@@ -6,6 +6,10 @@ PKGNAMESUFFIX= -gtk
COMMENT= GTK+2 front-end for Aiksaurus, a thesaurus
+BROKEN= does not link against GTK2 on FreeBSD 10+
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2017-01-15
+
LIB_DEPENDS= libAiksaurus.so:textproc/aiksaurus
MASTERDIR= ${.CURDIR}/../aiksaurus
diff --git a/textproc/aiksaurus/Makefile b/textproc/aiksaurus/Makefile
index 5bf73a435606..3cdc3ffbfbf2 100644
--- a/textproc/aiksaurus/Makefile
+++ b/textproc/aiksaurus/Makefile
@@ -18,10 +18,4 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS?=--without-gtk
-.include <bsd.port.pre.mk>
-
-.if defined(PKGNAMESUFFIX) && ${OPSYS} == FreeBSD && ${OSVERSION} > 1000000
-BROKEN= does not link against GTK2 on FreeBSD 10+
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-drivers/drm-kmod/Makefile b/x11-drivers/drm-kmod/Makefile
index 4c08b8d72085..47f36813a3e9 100644
--- a/x11-drivers/drm-kmod/Makefile
+++ b/x11-drivers/drm-kmod/Makefile
@@ -12,6 +12,10 @@ COMMENT= FreeBSD 9.3 Kernel DRM driver
LICENSE= MIT
+IGNORE= this port is only for 9.3 systems
+DEPRECATED= ${IGNORE}
+EXPIRATION_DATE= 2017-01-15
+
USES= kmod uidfix tar:xz
ONLY_FOR_ARCHS= i386 amd64
@@ -21,10 +25,6 @@ PLIST_FILES= ${KMODDIR}/drm2_port.ko \
.include <bsd.port.options.mk>
-.if (${OSVERSION} < 903000 || ${OSVERSION} > 1000000)
-IGNORE= this port is only for 9.3 systems
-.endif
-
.if ${PORT_OPTIONS:MDEBUG}
MAKE_ARGS+=" HAVE_DEBUG=YES"
.endif