aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-19 16:51:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-19 16:51:15 +0000
commitb6b8536f1052b048563873ff19c495c9deb93028 (patch)
tree2990355aca7da6140612b9a409b89c0d6e702226
parentbd76dd64e4e646bb5785ca18870b89eebe66bd91 (diff)
downloadports-b6b8536f1052b048563873ff19c495c9deb93028.tar.gz
ports-b6b8536f1052b048563873ff19c495c9deb93028.zip
Notes
-rw-r--r--www/youtube_dl/Makefile4
-rw-r--r--www/youtube_dl/distinfo4
-rw-r--r--www/youtube_dl/files/patch-youtube_dl____init__.py38
3 files changed, 24 insertions, 22 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index 6e0ad3314cad..b60991f7c239 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= youtube_dl
-PORTVERSION= 2014.07.21
+PORTVERSION= 2014.08.10
CATEGORIES= www
MASTER_SITES= https://yt-dl.org/downloads/${PORTVERSION}/
DISTNAME= youtube-dl-${PORTVERSION}
@@ -16,7 +16,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-USE_PYTHON_RUN= 2
+USES= python:2,run
ALL_TARGET= youtube-dl
OPTIONS_DEFINE= BASH RTMPDUMP FFMPEG
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
index 716ffeae59f7..e43267a9b973 100644
--- a/www/youtube_dl/distinfo
+++ b/www/youtube_dl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (youtube-dl-2014.07.21.tar.gz) = 63b48fdb32a6e28f3dcb8928e0f372d8e2ea1eb4216f063394f0b6d64955cee4
-SIZE (youtube-dl-2014.07.21.tar.gz) = 906769
+SHA256 (youtube-dl-2014.08.10.tar.gz) = a1131ff8aa636b6e99baf1b6226dab137500cd0a5cdeb4d76db102be4138caa9
+SIZE (youtube-dl-2014.08.10.tar.gz) = 931916
diff --git a/www/youtube_dl/files/patch-youtube_dl____init__.py b/www/youtube_dl/files/patch-youtube_dl____init__.py
index 009315d090fc..3682fe111d35 100644
--- a/www/youtube_dl/files/patch-youtube_dl____init__.py
+++ b/www/youtube_dl/files/patch-youtube_dl____init__.py
@@ -1,14 +1,14 @@
---- ./youtube_dl/__init__.py.orig 2014-02-25 09:29:35.000000000 +0000
-+++ ./youtube_dl/__init__.py 2014-02-25 09:29:49.000000000 +0000
-@@ -76,7 +76,6 @@
+--- youtube_dl/__init__.py.orig 2014-07-29 23:18:51.000000000 +0800
++++ youtube_dl/__init__.py 2014-07-31 01:10:45.923443081 +0800
+@@ -97,7 +97,6 @@
std_headers,
write_string,
)
-from .update import update_self
- from .FileDownloader import (
+ from .downloader import (
FileDownloader,
)
-@@ -206,8 +205,6 @@
+@@ -230,8 +229,6 @@
action='help', help='print this help text and exit')
general.add_option('-v', '--version',
action='version', help='print program version and exit')
@@ -17,21 +17,23 @@
general.add_option('-i', '--ignore-errors',
action='store_true', dest='ignoreerrors', help='continue on download errors, for example to skip unavailable videos in a playlist', default=False)
general.add_option('--abort-on-error',
-@@ -777,17 +774,6 @@
- if opts.xattrs:
- ydl.add_post_processor(XAttrMetadataPP())
+@@ -844,10 +841,6 @@
+ ydl.add_post_processor(FFmpegAudioFixPP())
+ ydl.add_post_processor(AtomicParsleyPP())
- # Update version
- if opts.update_self:
- update_self(ydl.to_screen, opts.verbose)
-
-- # Maybe do nothing
-- if (len(all_urls) < 1) and (opts.load_info_filename is None):
-- if not opts.update_self:
-- parser.error(u'you must provide at least one URL')
-- else:
-- sys.exit()
--
- try:
- if opts.load_info_filename is not None:
- retcode = ydl.download_with_info_file(opts.load_info_filename)
+ # Remove cache dir
+ if opts.rm_cachedir:
+ if opts.cachedir is None:
+@@ -867,7 +860,7 @@
+
+ # Maybe do nothing
+ if (len(all_urls) < 1) and (opts.load_info_filename is None):
+- if not (opts.update_self or opts.rm_cachedir):
++ if not (opts.rm_cachedir):
+ parser.error(u'you must provide at least one URL')
+ else:
+ sys.exit()