aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-22 21:11:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-23 04:53:50 +0000
commitbb202c55afc9c2dc00e731623f879349468ce96f (patch)
treeaeb62f095fe4321ce02d3220943c3dc426d39a66
parent01fd57323f66fe086a9fec01e5d8079afa97287c (diff)
downloadports-bb202c55afc9c2dc00e731623f879349468ce96f.tar.gz
ports-bb202c55afc9c2dc00e731623f879349468ce96f.zip
graphics/engauge-digitizer: Fix build
openjpeg.h wasn't found. Reported by: fallout (cherry picked from commit 77dff5bd868790fb078f8d2a38a5ad783daadd8c)
-rw-r--r--graphics/engauge-digitizer/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/engauge-digitizer/Makefile b/graphics/engauge-digitizer/Makefile
index f91120b9c311..43cc75d640b4 100644
--- a/graphics/engauge-digitizer/Makefile
+++ b/graphics/engauge-digitizer/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
libopenjp2.so:graphics/openjpeg \
libpoppler-qt5.so:graphics/poppler-qt5
-USES= compiler:c++11-lang desktop-file-utils gl qmake qt:5
+USES= compiler:c++11-lang desktop-file-utils gl pkgconfig qmake qt:5 # pkgconfig is for https://github.com/markummitchell/engauge-digitizer/issues/423
USE_GITHUB= yes
GH_ACCOUNT= markummitchell
USE_QT= core gui printsupport sql xml widgets buildtools_build
@@ -24,6 +24,8 @@ CONFIGURE_ENV= OPENJPEG_INCLUDE=${PREFIX}/include/openjpeg-2.4 OPENJPEG_LIB=${PR
POPPLER_INCLUDE=${PREFIX}/include/poppler/qt5 POPPLER_LIB=${PREFIX}/lib
QMAKE_ARGS= "CONFIG+=jpeg2000 pdf"
+CXXFLAGS+= `pkg-config --cflags libopenjp2` # workaround for https://github.com/markummitchell/engauge-digitizer/issues/423
+
OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes