aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2022-04-02 19:29:00 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2022-06-02 19:30:40 +0000
commitc1944bd93df312c287d2466c65ee3cb56af7c2bd (patch)
treecf3131d09f4c12179f210d06919a4ed229d1628b
parentd2359ec9c02ed5d06d69764c77b0963241cabc4e (diff)
downloadports-c1944bd93df312c287d2466c65ee3cb56af7c2bd.tar.gz
ports-c1944bd93df312c287d2466c65ee3cb56af7c2bd.zip
devel/oci-cli: New port for Oracle Cloud CLI
WWW: https://github.com/oracle/oci-cli/ PR: 262997 (with modification) Sponsored by: The FreeBSD Foundation Submitted by: Alessandro Sagratini <ale_sagra@hotmail.com> (cherry picked from commit 28504b62bfab211394387d5c5e7ca2135a714a58)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/oci-cli/Makefile36
-rw-r--r--devel/oci-cli/distinfo3
-rw-r--r--devel/oci-cli/files/patch-setup.py23
-rw-r--r--devel/oci-cli/pkg-descr4
5 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 44accfc262e9..f195645ab0fd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1663,6 +1663,7 @@
SUBDIR += ocaml-uutf
SUBDIR += ocaml-xstr
SUBDIR += ocaml-xstrp4
+ SUBDIR += oci-cli
SUBDIR += ocl-icd
SUBDIR += oclgrind
SUBDIR += ode
diff --git a/devel/oci-cli/Makefile b/devel/oci-cli/Makefile
new file mode 100644
index 000000000000..578d45a1e82d
--- /dev/null
+++ b/devel/oci-cli/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= oci-cli
+DISTVERSION= 3.7.0
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ale_sagra@hotmail.com
+COMMENT= Command Line Interface for Oracle Cloud Infrastructure
+
+LICENSE= APACHE20 UPL
+LICENSE_COMB= dual
+LICENSE_GROUPS_UPL= FSF GPL OSI
+LICENSE_NAME_UPL= Universal Permissive License
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE_UPL= ${WRKSRC}/LICENSE.txt
+LICENSE_PERMS_UPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>=1.0.0:devel/py-arrow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click7=7.1.2:devel/py-click7@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=3.2.1<=3.4.7:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.5.3<3.0.0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jmespath>=0.10.0:devel/py-jmespath@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oci=2.62.0:devel/py-oci@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=19.1.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2016.10:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.15.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}terminaltables>=3.1.0:textproc/py-terminaltables@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.4<6:devel/py-yaml@${PY_FLAVOR}
+
+USES= python:3.6-3.9
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/oci-cli/distinfo b/devel/oci-cli/distinfo
new file mode 100644
index 000000000000..1b44410c38a5
--- /dev/null
+++ b/devel/oci-cli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1648833280
+SHA256 (oci-cli-3.7.0.tar.gz) = b666ed9d239b0ef89619dfef575c992891f2b0f2b8bf45a179ba7b0a23c3a43a
+SIZE (oci-cli-3.7.0.tar.gz) = 9069925
diff --git a/devel/oci-cli/files/patch-setup.py b/devel/oci-cli/files/patch-setup.py
new file mode 100644
index 000000000000..329d8c4eebda
--- /dev/null
+++ b/devel/oci-cli/files/patch-setup.py
@@ -0,0 +1,23 @@
+--- setup.py.orig 2022-03-28 19:01:23 UTC
++++ setup.py
+@@ -30,16 +30,16 @@ with open_relative("README.rst") as f:
+
+ requires = [
+ 'oci==2.62.0',
+- 'arrow>=1.0.0',
++ 'arrow>>=1.0.0',
+ 'certifi',
+ 'click==7.1.2',
+ 'cryptography>=3.2.1,<=3.4.7',
+- 'jmespath==0.10.0',
++ 'jmespath>=0.10.0',
+ 'python-dateutil>=2.5.3,<3.0.0',
+ 'pytz>=2016.10',
+ 'six>=1.15.0',
+- 'terminaltables==3.1.0',
+- 'pyOpenSSL==19.1.0',
++ 'terminaltables>=3.1.0',
++ 'pyOpenSSL>=19.1.0',
+ 'PyYAML>=5.4,<6'
+ ]
+
diff --git a/devel/oci-cli/pkg-descr b/devel/oci-cli/pkg-descr
new file mode 100644
index 000000000000..2b685960ecb9
--- /dev/null
+++ b/devel/oci-cli/pkg-descr
@@ -0,0 +1,4 @@
+The OCI CLI enables you to imanage Oracle Cloud Infrastructure resources
+from the command line. All OCI services and regions are supported.
+
+WWW: https://github.com/oracle/oci-cli/