aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-10-26 08:17:46 +0000
committerLars Thegler <lth@FreeBSD.org>2005-10-26 08:17:46 +0000
commitc25ca102c507c8226e77ebacd21cbc769647f976 (patch)
tree866f509872b31c51481ed7c35a3aa927d5ccdfcf
parentf24eab01de7dd70b5d5d357b65e47e60609d7428 (diff)
downloadports-c25ca102c507c8226e77ebacd21cbc769647f976.tar.gz
ports-c25ca102c507c8226e77ebacd21cbc769647f976.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Perl-MinimumVersion/Makefile38
-rw-r--r--textproc/p5-Perl-MinimumVersion/distinfo2
-rw-r--r--textproc/p5-Perl-MinimumVersion/pkg-descr5
-rw-r--r--textproc/p5-Perl-MinimumVersion/pkg-plist6
5 files changed, 52 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 751c8ac8eac0..9ec85b475265 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -339,6 +339,7 @@
SUBDIR += p5-PPI
SUBDIR += p5-PPI-HTML
SUBDIR += p5-Parse-Syslog
+ SUBDIR += p5-Perl-MinimumVersion
SUBDIR += p5-PerlPoint-Converters
SUBDIR += p5-PerlPoint-Package
SUBDIR += p5-Plucene
diff --git a/textproc/p5-Perl-MinimumVersion/Makefile b/textproc/p5-Perl-MinimumVersion/Makefile
new file mode 100644
index 000000000000..3c1ae5d80487
--- /dev/null
+++ b/textproc/p5-Perl-MinimumVersion/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: textproc/p5-Perl-MinimumVersion
+# Date created: 25 October 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl-MinimumVersion
+PORTVERSION= 0.10
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Perl
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Find a minimum required version of perl for Perl code
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/PPI.pm:${PORTSDIR}/textproc/p5-PPI \
+ ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= perlver.1
+MAN3= Perl::MinimumVersion.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires Perl 5.8.1 or newer. Install lang/perl5.8 and try again.
+.endif
+
+post-patch:
+ @${RM} ${WRKSRC}/inc/Module/Install/AutoInstall.pm
+ @${PERL} -pi -e '$$_="" if m/AutoInstall/' ${WRKSRC}/MANIFEST
+ @${PERL} -pi -e '$$_="" if m/Test::More|auto_install/' ${WRKSRC}/Makefile.PL
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Perl-MinimumVersion/distinfo b/textproc/p5-Perl-MinimumVersion/distinfo
new file mode 100644
index 000000000000..1da36da00dc2
--- /dev/null
+++ b/textproc/p5-Perl-MinimumVersion/distinfo
@@ -0,0 +1,2 @@
+MD5 (Perl-MinimumVersion-0.10.tar.gz) = 6db84a037e3b32580cd2ef041837b89f
+SIZE (Perl-MinimumVersion-0.10.tar.gz) = 28466
diff --git a/textproc/p5-Perl-MinimumVersion/pkg-descr b/textproc/p5-Perl-MinimumVersion/pkg-descr
new file mode 100644
index 000000000000..6be2322b03c2
--- /dev/null
+++ b/textproc/p5-Perl-MinimumVersion/pkg-descr
@@ -0,0 +1,5 @@
+Perl::MinimumVersion takes Perl source code and calculates the minimum
+version of perl required to be able to run it. Because it is based on
+PPI, it can do this without having to actually load the code.
+
+WWW: http://search.cpan.org/dist/Perl-MinimumVersion/
diff --git a/textproc/p5-Perl-MinimumVersion/pkg-plist b/textproc/p5-Perl-MinimumVersion/pkg-plist
new file mode 100644
index 000000000000..0ee7e6e0445c
--- /dev/null
+++ b/textproc/p5-Perl-MinimumVersion/pkg-plist
@@ -0,0 +1,6 @@
+bin/perlver
+%%SITE_PERL%%/Perl/MinimumVersion.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl/MinimumVersion/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl/MinimumVersion
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Perl 2>/dev/null || true