aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2017-06-05 13:00:21 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2017-06-05 13:00:21 +0000
commitc35bd9a5e68b7b36bd5f54b73afd659f26919492 (patch)
tree817f86f9a64e2f208c8cea8f154987e1cdbb014f
parent5819b981b111985653b2137081f503c3da97e7cf (diff)
downloadports-c35bd9a5e68b7b36bd5f54b73afd659f26919492.tar.gz
ports-c35bd9a5e68b7b36bd5f54b73afd659f26919492.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-soundscrape/Makefile32
-rw-r--r--audio/py-soundscrape/distinfo3
-rw-r--r--audio/py-soundscrape/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index c43adc657cea..7501b7eb69ae 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -647,6 +647,7 @@
SUBDIR += py-pyliblo
SUBDIR += py-shout
SUBDIR += py-soundcloud
+ SUBDIR += py-soundscrape
SUBDIR += py-speechrecognition
SUBDIR += py-speex
SUBDIR += py-tagpy
diff --git a/audio/py-soundscrape/Makefile b/audio/py-soundscrape/Makefile
new file mode 100644
index 000000000000..541e8291e6f6
--- /dev/null
+++ b/audio/py-soundscrape/Makefile
@@ -0,0 +1,32 @@
+# Created by: Carlos J. Puga Medina <cpm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= soundscrape
+PORTVERSION= 0.30.0
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cpm@FreeBSD.org
+COMMENT= SoundCloud downloader in python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=1.31.0:audio/py-mutagen \
+ ${PYTHON_PKGNAMEPREFIX}soundcloud>=0.4.1:audio/py-soundcloud \
+ ${PYTHON_PKGNAMEPREFIX}args>=0.1.0:devel/py-args \
+ ${PYTHON_PKGNAMEPREFIX}clint>=0.3.2:devel/py-clint \
+ ${PYTHON_PKGNAMEPREFIX}demjson>=2.2.2:devel/py-demjson \
+ ${PYTHON_PKGNAMEPREFIX}fudge>=1.0.3:devel/py-fudge \
+ ${PYTHON_PKGNAMEPREFIX}nose>=1.3.7:devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=3.3.1:devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.24.0:devel/py-wheel \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.9.0:www/py-requests
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-soundscrape/distinfo b/audio/py-soundscrape/distinfo
new file mode 100644
index 000000000000..f5aec6d7dc67
--- /dev/null
+++ b/audio/py-soundscrape/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496600986
+SHA256 (soundscrape-0.30.0.tar.gz) = 684ce7052ae09de1a25ca05276de220803f5b83fbac068a4fcf23de1ac52061a
+SIZE (soundscrape-0.30.0.tar.gz) = 18260
diff --git a/audio/py-soundscrape/pkg-descr b/audio/py-soundscrape/pkg-descr
new file mode 100644
index 000000000000..a2b135118c2f
--- /dev/null
+++ b/audio/py-soundscrape/pkg-descr
@@ -0,0 +1,5 @@
+SoundScrape makes it super easy to download artists from SoundCloud, Bandcamp
+and MixCloud. It automatically creates ID3 tags as well (including album art),
+which is handy.
+
+WWW: https://github.com/Miserlou/SoundScrape