aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-07-13 06:56:16 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-07-13 06:56:16 +0000
commitc6e2885a32f3e49dc915a87c3530c752f255f323 (patch)
tree3ed64e394fbeba57313615ae108225820e305b90
parenteb3523164377b479d1cbc7f1542285b1c2a77cc8 (diff)
downloadports-c6e2885a32f3e49dc915a87c3530c752f255f323.tar.gz
ports-c6e2885a32f3e49dc915a87c3530c752f255f323.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-CAM-PDF/Makefile48
-rw-r--r--textproc/p5-CAM-PDF/distinfo3
-rw-r--r--textproc/p5-CAM-PDF/pkg-descr18
-rw-r--r--textproc/p5-CAM-PDF/pkg-plist47
5 files changed, 117 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ac1b58efe3fa..9bfad48bd8d2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -309,6 +309,7 @@
SUBDIR += p5-Apache-ParseLog
SUBDIR += p5-Apache-XBEL
SUBDIR += p5-Bloom-Filter
+ SUBDIR += p5-CAM-PDF
SUBDIR += p5-CQL-Parser
SUBDIR += p5-CSS-SAC
SUBDIR += p5-CSS-Squish
diff --git a/textproc/p5-CAM-PDF/Makefile b/textproc/p5-CAM-PDF/Makefile
new file mode 100644
index 000000000000..5566eb8fc70b
--- /dev/null
+++ b/textproc/p5-CAM-PDF/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: p5-CAM-PDF
+# Date created: 2006-07-13
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CAM-PDF
+PORTVERSION= 1.07
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLOTHO
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= PDF manipulation library
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Crypt/RC4.pm:${PORTSDIR}/security/p5-Crypt-RC4 \
+ ${SITE_PERL}/Text/PDF/File.pm:${PORTSDIR}/print/p5-Text-PDF
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= appendpdf.pl.1 changepagestring.pl.1 changepdfstring.pl.1 \
+ changerefkeys.pl.1 crunchjpgs.pl.1 deillustrate.pl.1 \
+ deletepdfpage.pl.1 extractallimages.pl.1 extractjpgs.pl.1 \
+ fillpdffields.pl.1 getpdffontobject.pl.1 getpdfpage.pl.1 \
+ getpdfpageobject.pl.1 getpdftext.pl.1 listfonts.pl.1 \
+ listimages.pl.1 listpdffields.pl.1 pdfinfo.pl.1 readpdf.pl.1 \
+ renderpdf.pl.1 replacepdfobj.pl.1 revertpdf.pl.1 \
+ rewritepdf.pl.1 setpdfbackground.pl.1 setpdfpage.pl.1 \
+ stamppdf.pl.1 uninlinepdfimages.pl.1
+
+MAN3= CAM::PDF.3 CAM::PDF::Content.3 CAM::PDF::Decrypt.3 \
+ CAM::PDF::GS.3 CAM::PDF::GS::NoText.3 CAM::PDF::Node.3 \
+ CAM::PDF::PageText.3 CAM::PDF::Renderer::Dump.3 \
+ CAM::PDF::Renderer::Images.3 CAM::PDF::Renderer::Text.3 \
+ CAM::PDF::Renderer::TextFB.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-CAM-PDF/distinfo b/textproc/p5-CAM-PDF/distinfo
new file mode 100644
index 000000000000..ecd2d77fff5c
--- /dev/null
+++ b/textproc/p5-CAM-PDF/distinfo
@@ -0,0 +1,3 @@
+MD5 (CAM-PDF-1.07.tgz) = 9eece6e30c36f568e35feb2a78b0cbea
+SHA256 (CAM-PDF-1.07.tgz) = 9af0bed6fed06093c06abd8805cebe449a29cfb1f6ed0b8a32171c52164ee3ab
+SIZE (CAM-PDF-1.07.tgz) = 743537
diff --git a/textproc/p5-CAM-PDF/pkg-descr b/textproc/p5-CAM-PDF/pkg-descr
new file mode 100644
index 000000000000..f522586ce8ec
--- /dev/null
+++ b/textproc/p5-CAM-PDF/pkg-descr
@@ -0,0 +1,18 @@
+This package reads and writes any document that conforms to the PDF
+specification generously provided by Adobe at
+http://partners.adobe.com/public/developer/pdf/index_reference.html
+
+The file format is well-supported, with the exception of the
+"linearized" or "optimized" output format, which this module can read
+but not write. Many specific aspects of the document model are not
+manipulable with this package (like fonts), but if the input document
+is correctly written, then this module will preserve the model
+integrity.
+
+This library grants you some power over the PDF security model. Note
+that applications editing PDF documents via this library MUST respect
+the security preferences of the document. Any violation of this
+respect is contrary to Adobe's intellectual property position, as
+stated in the reference manual at the above URL.
+
+WWW: http://search.cpan.org/dist/CAM-PDF/
diff --git a/textproc/p5-CAM-PDF/pkg-plist b/textproc/p5-CAM-PDF/pkg-plist
new file mode 100644
index 000000000000..cd8d1a4a4c1d
--- /dev/null
+++ b/textproc/p5-CAM-PDF/pkg-plist
@@ -0,0 +1,47 @@
+@comment $FreeBSD$
+bin/appendpdf.pl
+bin/asciify
+bin/changepagestring.pl
+bin/changepdfstring.pl
+bin/changerefkeys.pl
+bin/crunchjpgs.pl
+bin/deillustrate.pl
+bin/deletepdfpage.pl
+bin/extractallimages.pl
+bin/extractjpgs.pl
+bin/fillpdffields.pl
+bin/getpdffontobject.pl
+bin/getpdfpage.pl
+bin/getpdfpageobject.pl
+bin/getpdftext.pl
+bin/listfonts.pl
+bin/listimages.pl
+bin/listpdffields.pl
+bin/pdfinfo.pl
+bin/readpdf.pl
+bin/renderpdf.pl
+bin/replacepdfobj.pl
+bin/revertpdf.pl
+bin/rewritepdf.pl
+bin/setpdfbackground.pl
+bin/setpdfpage.pl
+bin/stamppdf.pl
+bin/uninlinepdfimages.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CAM/PDF/.packlist
+%%SITE_PERL%%/CAM/PDF.pm
+%%SITE_PERL%%/CAM/PDF/Content.pm
+%%SITE_PERL%%/CAM/PDF/Decrypt.pm
+%%SITE_PERL%%/CAM/PDF/GS.pm
+%%SITE_PERL%%/CAM/PDF/GS/NoText.pm
+%%SITE_PERL%%/CAM/PDF/Node.pm
+%%SITE_PERL%%/CAM/PDF/PageText.pm
+%%SITE_PERL%%/CAM/PDF/Renderer/Dump.pm
+%%SITE_PERL%%/CAM/PDF/Renderer/Images.pm
+%%SITE_PERL%%/CAM/PDF/Renderer/Text.pm
+%%SITE_PERL%%/CAM/PDF/Renderer/TextFB.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CAM/PDF
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CAM
+@dirrmtry %%SITE_PERL%%/CAM/PDF/GS
+@dirrmtry %%SITE_PERL%%/CAM/PDF/Renderer
+@dirrmtry %%SITE_PERL%%/CAM/PDF
+@dirrmtry %%SITE_PERL%%/CAM