aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-12 13:00:06 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-12 13:00:06 +0000
commitd37adf934ba15e663e30abd0459c35c7d262f9e8 (patch)
treef7e83e0f9bc383ed8d2e631e08dc3f2e7acc9223
parentb92409df5a189a87c4212752d50a573526b75f24 (diff)
downloadports-d37adf934ba15e663e30abd0459c35c7d262f9e8.tar.gz
ports-d37adf934ba15e663e30abd0459c35c7d262f9e8.zip
Notes
-rw-r--r--cad/feappv/Makefile7
-rw-r--r--math/femlab/Makefile7
-rw-r--r--math/femlab/files/patch-fsource_makepoisson2
3 files changed, 14 insertions, 2 deletions
diff --git a/cad/feappv/Makefile b/cad/feappv/Makefile
index e242c1535add..eef1bfeff092 100644
--- a/cad/feappv/Makefile
+++ b/cad/feappv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= feappv
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= cad science
MASTER_SITES= http://www.ce.berkeley.edu/~rlt/feappv/
MASTER_SITE_SUBDIR= feap
@@ -25,7 +26,11 @@ EXTRACT_BEFORE_ARGS= -L
WRKSRC= ${WRKDIR}/ver20
USE_XLIB= yes
-FFLAGS?= -O2
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+FFLAGS+= -O2
MAKEFILE= makefile
ALL_TARGET= install
diff --git a/math/femlab/Makefile b/math/femlab/Makefile
index b7e3efe57b8f..309990042976 100644
--- a/math/femlab/Makefile
+++ b/math/femlab/Makefile
@@ -7,6 +7,7 @@
PORTNAME= femlab
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= math science
# mastersite disappeared in April 2000
MASTER_SITES= # ftp://ftp.md.chalmers.se/pub/Femlab/
@@ -18,6 +19,12 @@ COMMENT= Interactive program for solving partial differential equations in 2D
BUILD_DEPENDS= ${X11BASE}/lib/libsx.a:${PORTSDIR}/x11/libsx \
xmkmf:${X_IMAKE_PORT}
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+MAKE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+
USE_X_PREFIX= yes
FEMLAB_HOME= ${PREFIX}/lib/X11/femlab
diff --git a/math/femlab/files/patch-fsource_makepoisson b/math/femlab/files/patch-fsource_makepoisson
index 2544f6e764ca..e3ab16ae0335 100644
--- a/math/femlab/files/patch-fsource_makepoisson
+++ b/math/femlab/files/patch-fsource_makepoisson
@@ -5,7 +5,7 @@ $FreeBSD$
+++ fsource/makepoisson Wed Jul 24 00:06:17 2002
@@ -1,4 +1,4 @@
-FFLAGS= -O
-+FFLAGS= -O -fno-globals
++FFLAGS= -O2
FFILES= dwm1.f startpo.f preproc.f rhslhs.f poisson.f output.f