aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-09-13 16:58:31 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-09-13 16:58:31 +0000
commite1c60bb35d99b754e4c3cc4216f8011ab6368d6e (patch)
tree056322627e54836d5b84de7167e4666d26328c27
parent75fc796910ab5dc129a103d693f9ef66a9cee075 (diff)
downloadports-e1c60bb35d99b754e4c3cc4216f8011ab6368d6e.tar.gz
ports-e1c60bb35d99b754e4c3cc4216f8011ab6368d6e.zip
Notes
-rw-r--r--multimedia/plexhometheater/Makefile25
-rw-r--r--multimedia/plexhometheater/distinfo4
-rw-r--r--multimedia/plexhometheater/files/patch-CMakeLists.txt9
-rw-r--r--multimedia/plexhometheater/files/patch-lib__ffmpeg__CMakeLists.txt2
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc__cdrip__CMakeLists.txt10
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc__cdrip__EncoderFFmpeg.cpp16
-rw-r--r--multimedia/plexhometheater/files/pkg-message.in10
-rw-r--r--multimedia/plexhometheater/files/plexhometheater.sh.in1
-rw-r--r--multimedia/plexhometheater/pkg-plist2
9 files changed, 51 insertions, 28 deletions
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index 34249d236e9c..cb33b216a44d 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= plexhometheater
-PORTVERSION= 1.2.1
-PORTREVISION= 4
+PORTVERSION= 1.2.2
CATEGORIES= multimedia
MAINTAINER= woodsb02@gmail.com
@@ -40,7 +39,6 @@ LIB_DEPENDS= libass.so:${PORTSDIR}/multimedia/libass \
libmad.so:${PORTSDIR}/audio/libmad \
libmicrohttpd.so:${PORTSDIR}/www/libmicrohttpd \
libmodplug.so:${PORTSDIR}/audio/libmodplug \
- libmp3lame.so:${PORTSDIR}/audio/lame \
libmpeg2.so:${PORTSDIR}/multimedia/libmpeg2 \
libpcre.so:${PORTSDIR}/devel/pcre \
libplist.so:${PORTSDIR}/devel/libplist \
@@ -67,8 +65,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
USE_GITHUB= yes
GH_ACCOUNT= plexinc
GH_PROJECT= plex-home-theater-public
-GH_COMMIT= bdd03dd
-GH_TAGNAME= pht-v1.2.1
+GH_COMMIT= 2d6426d
+GH_TAGNAME= pht-v1.2.2
USES= cmake:outsource iconv pkgconfig python:2
CMAKE_ARGS+= -DENABLE_AUTOUPDATE:BOOL=false
@@ -77,16 +75,15 @@ CMAKE_ARGS+= -DENABLE_PYTHON:BOOL=false
CMAKE_ARGS+= -DUSE_INTERNAL_FFMPEG:BOOL=true
CMAKE_ARGS+= -DCREATE_BUNDLE:BOOL=false
CMAKE_ARGS+= -DCMAKE_PREFIX_PATH=${LOCALBASE}
+CFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_XORG= xt xmu xtst xrandr
USE_GL= glu
USE_SDL= image sdl mixer
-USE_JAVA= yes
-JAVA_BUILD= jre
INSTALLS_ICONS= yes
ONLY_FOR_ARCHS= i386 amd64
-SUB_FILES= ${PORTNAME}.sh
+SUB_FILES= ${PORTNAME}.sh pkg-message
DESKTOP_ENTRIES="Plex Home Theater" \
"${COMMENT}" \
@@ -117,6 +114,18 @@ PLIST_SUB+= ARCH="x86"
PLIST_SUB+= ARCH="x86_64"
.endif
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 900033
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+MAKE_ENV= COMPILER_PATH=${LOCALBASE}/bin
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's/[[:<:]]ARCH[[:>:]]/FFMPEG_ARCH/' \
+ ${WRKSRC}/lib/ffmpeg/Makefile \
+ ${WRKSRC}/lib/ffmpeg/common.mak \
+ ${WRKSRC}/lib/ffmpeg/configure \
+ ${WRKSRC}/lib/ffmpeg/libavcodec/Makefile
+
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin
diff --git a/multimedia/plexhometheater/distinfo b/multimedia/plexhometheater/distinfo
index 1f9b7b2e735c..d7243caa81a8 100644
--- a/multimedia/plexhometheater/distinfo
+++ b/multimedia/plexhometheater/distinfo
@@ -1,2 +1,2 @@
-SHA256 (plexhometheater-1.2.1.tar.gz) = d880f9dc2c893036cab0c21dfbd855c91751f97b06437c7d6e23726b089715d0
-SIZE (plexhometheater-1.2.1.tar.gz) = 91374075
+SHA256 (plexhometheater-1.2.2.tar.gz) = e49b5f226d29fb91e7aef42b4f5ed2b2afc2edfbc70cdfa49181eaada1c8c095
+SIZE (plexhometheater-1.2.2.tar.gz) = 91373872
diff --git a/multimedia/plexhometheater/files/patch-CMakeLists.txt b/multimedia/plexhometheater/files/patch-CMakeLists.txt
index fe45f079f77f..8123d1bcc7f8 100644
--- a/multimedia/plexhometheater/files/patch-CMakeLists.txt
+++ b/multimedia/plexhometheater/files/patch-CMakeLists.txt
@@ -18,3 +18,12 @@
install(DIRECTORY /usr/lib/python${PYTHON_VERSION} DESTINATION ${LIBPATH}/lib/ COMPONENT RUNTIME
PATTERN python${PYTHON_VERSION}/test EXCLUDE
REGEX .*\\.pyc$ EXCLUDE
+@@ -161,7 +161,7 @@
+ if(XRANDR_FOUND)
+ add_executable(xbmc-xrandr xbmc-xrandr.c)
+ target_link_libraries(xbmc-xrandr ${CONFIG_LIBRARY_XRANDR} ${CONFIG_LIBRARY_X11} -lm)
+- install(TARGETS xbmc-xrandr DESTINATION ${BINPATH})
++ install(TARGETS xbmc-xrandr DESTINATION ${LIBPATH})
+ endif()
+
+ include(CPackConfig)
diff --git a/multimedia/plexhometheater/files/patch-lib__ffmpeg__CMakeLists.txt b/multimedia/plexhometheater/files/patch-lib__ffmpeg__CMakeLists.txt
index 24009390bc96..9067908d388f 100644
--- a/multimedia/plexhometheater/files/patch-lib__ffmpeg__CMakeLists.txt
+++ b/multimedia/plexhometheater/files/patch-lib__ffmpeg__CMakeLists.txt
@@ -11,7 +11,7 @@
-if(NOT TARGET_RPI)
+if(TARGET_FREEBSD)
-+ set(CONFIG_FLAGS --target-os=${OS} --cc=clang --cxx=clang++ --extra-cflags=-I${CMAKE_PREFIX_PATH}/include --extra-ldflags=-L${CMAKE_PREFIX_PATH}/lib --disable-altivec --disable-amd3dnow --disable-avisynth --disable-crystalhd --disable-debug --disable-decoder=mpeg_xvmc --disable-devices --disable-doc --disable-dxva2 --disable-encoders --disable-extra-warnings --disable-ffmpeg --disable-ffplay --disable-ffprobe --disable-ffserver --disable-frei0r --disable-gray --disable-hardcoded-tables --disable-indevs --disable-iwmmxt --disable-libdc1394 --disable-libdirac --disable-libfaac --disable-libfreetype --disable-libgsm --disable-libmp3lame --disable-libnut --disable-libopencore-amrnb --disable-libopencore-amrwb --disable-libopencv --disable-libopenjpeg --disable-librtmp --disable-libschroedinger --disable-libspeex --disable-libtheora --disable-libvo-aacenc --disable-libvo-amrwbenc --disable-libvorbis --disable-libvpx --disable-libx264 --disable-libxavs --disable-libxvid --disable-memalign-hack --disable-mlib --disable-mmi --disable-muxers --disable-nonfree --disable-outdevs --disable-small --disable-sram --disable-static --disable-symver --disable-vda --disable-version3 --disable-vis --disable-w32threads --disable-x11grab --enable-aandct --enable-asm --enable-avcodec --enable-avdevice --enable-avfilter --enable-avformat --enable-bsfs --enable-bzlib --enable-dct --enable-demuxers --enable-fastdiv --enable-fft --enable-filters --enable-golomb --enable-gpl --enable-huffman --enable-hwaccels --enable-libvorbis --enable-logging --enable-lpc --enable-mdct --enable-muxer=adts --enable-muxer=ogg --enable-muxer=spdif --enable-network --enable-optimizations --enable-parsers --enable-pic --enable-postproc --enable-protocol=http --enable-pthreads --enable-rdft --enable-runtime-cpudetect --enable-shared --enable-stripping --enable-swscale --enable-swscale-alpha --enable-vaapi --enable-vdpau --enable-yasm --enable-zlib --host-libs=-lm)
++ set(CONFIG_FLAGS --target-os=${OS} --cc=${CMAKE_C_COMPILER} --cxx=${CMAKE_CXX_COMPILER} --extra-cflags=-I${CMAKE_PREFIX_PATH}/include --extra-ldflags=-L${CMAKE_PREFIX_PATH}/lib --disable-altivec --disable-amd3dnow --disable-avisynth --disable-crystalhd --disable-debug --disable-decoder=mpeg_xvmc --disable-devices --disable-doc --disable-dxva2 --disable-encoders --disable-extra-warnings --disable-ffmpeg --disable-ffplay --disable-ffprobe --disable-ffserver --disable-frei0r --disable-gray --disable-hardcoded-tables --disable-indevs --disable-iwmmxt --disable-libdc1394 --disable-libdirac --disable-libfaac --disable-libfreetype --disable-libgsm --disable-libmp3lame --disable-libnut --disable-libopencore-amrnb --disable-libopencore-amrwb --disable-libopencv --disable-libopenjpeg --disable-librtmp --disable-libschroedinger --disable-libspeex --disable-libtheora --disable-libvo-aacenc --disable-libvo-amrwbenc --disable-libvorbis --disable-libvpx --disable-libx264 --disable-libxavs --disable-libxvid --disable-memalign-hack --disable-mlib --disable-mmi --disable-muxers --disable-nonfree --disable-outdevs --disable-small --disable-sram --disable-static --disable-symver --disable-vda --disable-version3 --disable-vis --disable-w32threads --disable-x11grab --enable-aandct --enable-asm --enable-avcodec --enable-avdevice --enable-avfilter --enable-avformat --enable-bsfs --enable-bzlib --enable-dct --enable-demuxers --enable-fastdiv --enable-fft --enable-filters --enable-golomb --enable-gpl --enable-huffman --enable-hwaccels --enable-libvorbis --enable-logging --enable-lpc --enable-mdct --enable-muxer=adts --enable-muxer=ogg --enable-muxer=spdif --enable-network --enable-optimizations --enable-parsers --enable-pic --enable-postproc --enable-protocol=http --enable-pthreads --enable-rdft --enable-runtime-cpudetect --enable-shared --enable-stripping --enable-swscale --enable-swscale-alpha --enable-vaapi --enable-vdpau --enable-yasm --enable-zlib --host-libs=-lm)
+elseif(NOT TARGET_RPI)
set(CONFIG_FLAGS --target-os=${OS} --sysroot="${CMAKE_PREFIX_PATH}" --sysinclude="${CMAKE_PREFIX_PATH}/usr/include" --disable-altivec --disable-amd3dnow --disable-avisynth --disable-crystalhd --disable-debug --disable-decoder=mpeg_xvmc --disable-devices --disable-doc --disable-dxva2 --disable-encoders --disable-extra-warnings --disable-ffmpeg --disable-ffplay --disable-ffprobe --disable-ffserver --disable-frei0r --disable-gray --disable-hardcoded-tables --disable-indevs --disable-iwmmxt --disable-libdc1394 --disable-libdirac --disable-libfaac --disable-libfreetype --disable-libgsm --disable-libmp3lame --disable-libnut --disable-libopencore-amrnb --disable-libopencore-amrwb --disable-libopencv --disable-libopenjpeg --disable-librtmp --disable-libschroedinger --disable-libspeex --disable-libtheora --disable-libvo-aacenc --disable-libvo-amrwbenc --disable-libvorbis --disable-libvpx --disable-libx264 --disable-libxavs --disable-libxvid --disable-memalign-hack --disable-mlib --disable-mmi --disable-muxers --disable-nonfree --disable-outdevs --disable-small --disable-sram --disable-static --disable-symver --disable-vda --disable-version3 --disable-vis --disable-w32threads --disable-x11grab --enable-aandct --enable-asm --enable-avcodec --enable-avdevice --enable-avfilter --enable-avformat --enable-bsfs --enable-bzlib --enable-dct --enable-demuxers --enable-fastdiv --enable-fft --enable-filters --enable-golomb --enable-gpl --enable-huffman --enable-hwaccels --enable-libvorbis --enable-logging --enable-lpc --enable-mdct --enable-muxer=adts --enable-muxer=ogg --enable-muxer=spdif --enable-network --enable-optimizations --enable-parsers --enable-pic --enable-postproc --enable-protocol=http --enable-pthreads --enable-rdft --enable-runtime-cpudetect --enable-shared --enable-stripping --enable-swscale --enable-swscale-alpha --enable-vaapi --enable-vdpau --enable-yasm --enable-zlib --host-libs=-lm)
else()
diff --git a/multimedia/plexhometheater/files/patch-xbmc__cdrip__CMakeLists.txt b/multimedia/plexhometheater/files/patch-xbmc__cdrip__CMakeLists.txt
new file mode 100644
index 000000000000..5be333381042
--- /dev/null
+++ b/multimedia/plexhometheater/files/patch-xbmc__cdrip__CMakeLists.txt
@@ -0,0 +1,10 @@
+--- xbmc/cdrip/CMakeLists.txt.orig 2014-09-13 10:49:51.253607190 +0800
++++ xbmc/cdrip/CMakeLists.txt 2014-09-13 10:53:30.657607851 +0800
+@@ -1,5 +1,7 @@
+ find_all_sources(. cdrip_SRCS)
+ list(REMOVE_ITEM cdrip_SRCS ./EncoderFFmpeg.cpp)
+ list(REMOVE_ITEM cdrip_SRCS ./EncoderFFmpeg.h)
++list(REMOVE_ITEM cdrip_SRCS ./EncoderLame.cpp)
++list(REMOVE_ITEM cdrip_SRCS ./EncoderLame.h)
+ list(REMOVE_ITEM cdrip_SRCS ./CDDARipper.cpp)
+ add_sources(${cdrip_SRCS})
diff --git a/multimedia/plexhometheater/files/patch-xbmc__cdrip__EncoderFFmpeg.cpp b/multimedia/plexhometheater/files/patch-xbmc__cdrip__EncoderFFmpeg.cpp
deleted file mode 100644
index debf3072e946..000000000000
--- a/multimedia/plexhometheater/files/patch-xbmc__cdrip__EncoderFFmpeg.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- xbmc/cdrip/EncoderFFmpeg.cpp.orig 2013-02-06 19:11:19.000000000 +0100
-+++ xbmc/cdrip/EncoderFFmpeg.cpp 2013-02-06 19:11:45.000000000 +0100
-@@ -77,7 +77,13 @@
- }
-
- m_Format = m_dllAvFormat.avformat_alloc_context();
-+#if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(53,1,0)
- m_Format->pb = m_dllAvFormat.avio_alloc_context(m_BCBuffer, sizeof(m_BCBuffer), AVIO_FLAG_READ, this, NULL, MuxerReadPacket, NULL);
-+#elif LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(53,0,0)
-+ m_Format->pb = m_dllAvFormat.avio_alloc_context(m_BCBuffer, sizeof(m_BCBuffer), AVIO_RDONLY, this, NULL, MuxerReadPacket, NULL);
-+#else
-+ m_Format->pb = m_dllAvFormat.avio_alloc_context(m_BCBuffer, sizeof(m_BCBuffer), URL_RDONLY, this, NULL, MuxerReadPacket, NULL);
-+#endif
- if (!m_Format->pb)
- {
- m_dllAvUtil.av_freep(&m_Format);
diff --git a/multimedia/plexhometheater/files/pkg-message.in b/multimedia/plexhometheater/files/pkg-message.in
new file mode 100644
index 000000000000..dc01070a98ad
--- /dev/null
+++ b/multimedia/plexhometheater/files/pkg-message.in
@@ -0,0 +1,10 @@
+
+To run plexhometheater from the command line, be sure to
+use the %%PREFIX%%/bin/plexhometheater.sh shell script
+rather than the %%PREFIX%%/bin/plexhometheater binary directly.
+
+To run plexhometheater from the command line, run
+
+ %%PREFIX%%/bin/plexhometheater.sh
+
+rather than the %%PREFIX%%/bin/plexhometheater binary.
diff --git a/multimedia/plexhometheater/files/plexhometheater.sh.in b/multimedia/plexhometheater/files/plexhometheater.sh.in
index 1815d70c1525..443127237970 100644
--- a/multimedia/plexhometheater/files/plexhometheater.sh.in
+++ b/multimedia/plexhometheater/files/plexhometheater.sh.in
@@ -1,4 +1,5 @@
#!/bin/sh
export XBMC_HOME=%%PREFIX%%/share/plexhometheater
+export XBMC_BIN_HOME=%%PREFIX%%/lib/plexhometheater
exec %%PREFIX%%/bin/plexhometheater
diff --git a/multimedia/plexhometheater/pkg-plist b/multimedia/plexhometheater/pkg-plist
index 4b69d446180f..4cf569590b6b 100644
--- a/multimedia/plexhometheater/pkg-plist
+++ b/multimedia/plexhometheater/pkg-plist
@@ -1,6 +1,5 @@
bin/plexhometheater
bin/plexhometheater.sh
-bin/xbmc-xrandr
lib/plexhometheater/system/ImageLib-%%ARCH%%-freebsd.so
lib/plexhometheater/system/libcpluff-%%ARCH%%-freebsd.so
lib/plexhometheater/system/players/dvdplayer/avcodec-53-%%ARCH%%-freebsd.so
@@ -10,6 +9,7 @@ lib/plexhometheater/system/players/dvdplayer/avutil-51-%%ARCH%%-freebsd.so
lib/plexhometheater/system/players/dvdplayer/postproc-52-%%ARCH%%-freebsd.so
lib/plexhometheater/system/players/dvdplayer/swresample-0-%%ARCH%%-freebsd.so
lib/plexhometheater/system/players/dvdplayer/swscale-2-%%ARCH%%-freebsd.so
+lib/plexhometheater/xbmc-xrandr
%%DATADIR%%/Credits.html
%%DATADIR%%/addons/repository.pvr-android.xbmc.org/addon.xml
%%DATADIR%%/addons/repository.pvr-android.xbmc.org/icon.png