aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-06-03 12:35:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-06-03 12:35:42 +0000
commite3aede5bc2449c6668fa3e6484b9d8975ef34dc4 (patch)
treed4b39a7b7fe73c232801a79b9ec016e244a07bd9
parentdb4afe76a7a86d90032172a2d6c40e2f74b10a27 (diff)
downloadports-e3aede5bc2449c6668fa3e6484b9d8975ef34dc4.tar.gz
ports-e3aede5bc2449c6668fa3e6484b9d8975ef34dc4.zip
Notes
-rw-r--r--games/freesci/Makefile7
-rw-r--r--graphics/cairo/Makefile1
-rw-r--r--graphics/libggi/Makefile2
-rw-r--r--www/links/Makefile4
4 files changed, 7 insertions, 7 deletions
diff --git a/games/freesci/Makefile b/games/freesci/Makefile
index 1579e718e741..447a8923c5ae 100644
--- a/games/freesci/Makefile
+++ b/games/freesci/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freesci
PORTVERSION= 0.3.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games emulators
MASTER_SITES= http://www-plan.cs.colorado.edu/creichen/${PORTNAME}/ \
http://teksolv.de/~jameson/
@@ -44,9 +44,6 @@ CFLAGS+= -ffast-math
.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
-.if exists(${LOCALBASE}/lib/libdirectfb-1.1.so.1)
-WITH_DIRECTFB= yes
-.endif
.if exists(${LOCALBASE}/lib/libggi.so.2)
WITH_GGI= yes
.endif
@@ -63,7 +60,7 @@ CONFIGURE_ARGS+= --without-sdl
.endif
.if defined(WITH_DIRECTFB) && !defined(WITHOUT_DIRECTFB)
-LIB_DEPENDS+= directfb-1.1.1:${PORTSDIR}/devel/directfb
+LIB_DEPENDS+= directfb-1.4.3:${PORTSDIR}/devel/directfb
CONFIGURE_ARGS+= --with-directfb-include=${LOCALBASE}/include/directfb \
--with-directfb-libraries=${LOCALBASE}/lib
.else
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 4c0d598ff21f..0f748c619795 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -25,6 +25,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
pixman-1.9:${PORTSDIR}/x11/pixman
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
+ --disable-directfb \
--enable-pdf \
--enable-ps
USE_GNOME= gnomehack ltverhack referencehack
diff --git a/graphics/libggi/Makefile b/graphics/libggi/Makefile
index c948ffb28da1..2648d1131296 100644
--- a/graphics/libggi/Makefile
+++ b/graphics/libggi/Makefile
@@ -120,6 +120,8 @@ MLINKS= ggi-demo.1 demo.1 \
- ggidev-le0_3.3 \
- ggidev-lt0_3.3
+CONFIGURE_ARGS= --disable-directfb
+
.if exists(/usr/include/dev/kgi/kgi.h)
CONFIGURE_ARGS+= --enable-kgi --with-extra-includes=/usr/include/dev
.endif
diff --git a/www/links/Makefile b/www/links/Makefile
index b41dfda569d2..e705f347e082 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -7,7 +7,7 @@
PORTNAME= links
DISTVERSION= 2.2
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES?= www
MASTER_SITES= http://links.twibright.com/download/
@@ -63,7 +63,7 @@ CONFIGURE_ARGS+= --without-svgalib
.endif
.ifdef(WITH_DIRECTFB)
-LIB_DEPENDS+= directfb-1.1.1:${PORTSDIR}/devel/directfb
+LIB_DEPENDS+= directfb-1.4.3:${PORTSDIR}/devel/directfb
CONFIGURE_ARGS+= --with-directfb
.else
CONFIGURE_ARGS+= --without-directfb