aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 10:38:43 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 10:38:43 +0000
commite8450b17212e021bdb9b58c4ef40a21315cbd5f7 (patch)
tree7e5629ffd79ce7798d43d90807597f99be326948
parent64b5e76ce5d9db555e4c63220de7b749d6bb1eaa (diff)
downloadports-e8450b17212e021bdb9b58c4ef40a21315cbd5f7.tar.gz
ports-e8450b17212e021bdb9b58c4ef40a21315cbd5f7.zip
Notes
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gtk-smooth-engine/Makefile57
-rw-r--r--x11/gtk-smooth-engine/distinfo1
-rw-r--r--x11/gtk-smooth-engine/pkg-descr8
-rw-r--r--x11/gtk-smooth-engine/pkg-plist4
5 files changed, 71 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index d861071bc341..a81e6c9f6844 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -63,6 +63,7 @@
SUBDIR += grabc
SUBDIR += gromit
SUBDIR += gswitchit
+ SUBDIR += gtk-smooth-engine
SUBDIR += gtk-theme-switch
SUBDIR += gtk2-theme-switch
SUBDIR += gxset
diff --git a/x11/gtk-smooth-engine/Makefile b/x11/gtk-smooth-engine/Makefile
new file mode 100644
index 000000000000..229c6523396a
--- /dev/null
+++ b/x11/gtk-smooth-engine/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: gtk-smooth-engine
+# Date created: 19 November 2003
+# Whom: Anish Mistry
+# $FreeBSD$
+#
+
+PORTNAME= gtk-smooth-engine
+PORTVERSION= 0.5.6
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= smooth-engine
+
+MAINTAINER= amistry@am-productions.biz
+COMMENT= Flexible GTK Theme Engine
+
+.if exists(${X11BASE}/lib/libgtk-x11-2.0.so.200)
+WITH_GTK2= yes
+.endif
+
+.if exists(${X11BASE}/lib/libgtk12.so.2)
+WITH_GTK12= yes
+.endif
+
+.if defined(WITH_GTK12)
+LIB_DEPENDS+= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+.endif
+
+# if neither gtk is detected automatically pull in gtk2
+.if !defined(WITH_GTK12) && !defined(WITH_GTK2)
+WITH_GTK2= yes
+.endif
+
+.if defined(WITH_GTK2)
+LIB_DEPENDS+= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20
+.endif
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+USE_GNOME= gtk12 gtk20
+INSTALLS_SHLIB= yes
+SHLIB_VERSION= 0
+
+pre-everything::
+.if !defined(WITH_GTK2)
+ @${ECHO_MSG} "To enable gtk2 support define WITH_GTK2."
+.endif
+
+.if !defined(WITH_GTK12)
+ @${ECHO_MSG} "To enable gtk12 support define WITH_GTK12."
+.endif
+
+post-install:
+# add shared lib link
+ @${LN} -sf libsmooth.so \
+ ${X11BASE}/lib/gtk-2.0/2.2.0/engines/libsmooth.so.${SHLIB_VERSION}
+
+.include <bsd.port.mk>
diff --git a/x11/gtk-smooth-engine/distinfo b/x11/gtk-smooth-engine/distinfo
new file mode 100644
index 000000000000..6665b1559813
--- /dev/null
+++ b/x11/gtk-smooth-engine/distinfo
@@ -0,0 +1 @@
+MD5 (gtk-smooth-engine-0.5.6.tar.gz) = f2d3e1f85652db8e77c725e7b73cff4f
diff --git a/x11/gtk-smooth-engine/pkg-descr b/x11/gtk-smooth-engine/pkg-descr
new file mode 100644
index 000000000000..fbb53b110063
--- /dev/null
+++ b/x11/gtk-smooth-engine/pkg-descr
@@ -0,0 +1,8 @@
+This is the Smooth GTK engine, currently it supports GTK2 and GTK1.2, however
+GTK 1.2 support is a bit messier/less reliable then GTK2.
+
+WWW: http://sourceforge.net/projects/smooth-engine/
+
+- Anish Mistry
+amistry@am-productions.biz
+AM Productions http://am-productions.biz
diff --git a/x11/gtk-smooth-engine/pkg-plist b/x11/gtk-smooth-engine/pkg-plist
new file mode 100644
index 000000000000..7cbc7107f7c7
--- /dev/null
+++ b/x11/gtk-smooth-engine/pkg-plist
@@ -0,0 +1,4 @@
+lib/gtk-2.0/2.2.0/engines/libsmooth.so
+lib/gtk-2.0/2.2.0/engines/libsmooth.so.0
+lib/gtk-2.0/2.2.0/engines/libsmooth.la
+@dirrm lib/gtk-2.0/2.2.0/engines