aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-03-27 01:23:45 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-03-27 01:23:45 +0000
commitebaa0d86ff716b559f2991126236a1f7f2fca6e8 (patch)
tree81c0d3c71108bff2e4b03a8f46b3e1ad69adbbb4
parent8406f4871fe6c54beb1c4c2854da77b9660e6f82 (diff)
downloadports-ebaa0d86ff716b559f2991126236a1f7f2fca6e8.tar.gz
ports-ebaa0d86ff716b559f2991126236a1f7f2fca6e8.zip
Notes
-rw-r--r--security/nmap/Makefile9
-rw-r--r--security/nmap/distinfo2
-rw-r--r--security/nmap/files/patch-aa12
3 files changed, 13 insertions, 10 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 8ab7bd329469..0de0d60677a4 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,13 +7,16 @@
# $FreeBSD$
#
-DISTNAME= nmap-2.3BETA14
-PKGNAME= nmap-2.3b14
+DISTNAME= nmap-2.30BETA17
+PKGNAME= nmap-2.3b17
CATEGORIES= security net
MASTER_SITES= http://www.insecure.org/nmap/dist/ \
- ftp://relay.nuxi.com/pub/misc/
+ ftp://nuxi.ucdavis.edu/pub/misc/ \
+ http://www.mobis.com/ajax/projects/
EXTRACT_SUFX= .tgz
+#PATCH_SITES= http://www.mobis.com/ajax/projects/
+
MAINTAINER= obrien@FreeBSD.org
.include <bsd.port.pre.mk>
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index 719c249b2840..7b6fe7b089d7 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1 +1 @@
-MD5 (nmap-2.3BETA14.tgz) = 6709d218c588f595574f719a394bcf02
+MD5 (nmap-2.30BETA17.tgz) = c3d75335233317f51039d57705018ee9
diff --git a/security/nmap/files/patch-aa b/security/nmap/files/patch-aa
index 4d829c6a8f59..5b3e70edbb0f 100644
--- a/security/nmap/files/patch-aa
+++ b/security/nmap/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.in.orig Fri Dec 31 03:13:50 1999
-+++ Makefile.in Mon Jan 3 23:54:14 2000
+--- Makefile.in.orig Sun Mar 26 03:04:48 2000
++++ Makefile.in Sun Mar 26 17:16:58 2000
@@ -5,13 +5,13 @@
sbindir = @sbindir@
mandir = @mandir@
@@ -18,17 +18,17 @@
# CFLAGS = -g -Wall $(DEFS) $(INCLS)
@@ -36,7 +36,7 @@
- all: $(TARGET)
+ all: $(TARGET) nmapfe/nmapfe
--$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(OBJS) nmapfe/nmapfe
-+$(TARGET): $(DEPS) $(OBJS) nmapfe/nmapfe # @PCAP_DEPENDS@
+-$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(OBJS)
++$(TARGET): $(DEPS) $(OBJS)
@echo Compiling nmap
rm -f $@
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
@@ -128,7 +128,7 @@
$(MAKEDEPEND) $(INCLS) -s "# DO NOT DELETE" -- $(DEFS) -- $(SRCS)
- install: all
+ install: $(TARGET)
- $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(libdir) $(deskdir)
+ $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(libdir)
$(INSTALL) -c -m 755 nmap $(bindir)/nmap