aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-04-14 02:42:39 +0000
committerSteve Wills <swills@FreeBSD.org>2014-04-14 02:42:39 +0000
commitf3f431ec7437bc70de1e044e4c822ceb0a490496 (patch)
treef9b75bc0d953b27800e830c5d5bee4c7e67fe3ac
parentf902fc9654afdaf819fe6017a096a5a280f88b57 (diff)
downloadports-f3f431ec7437bc70de1e044e4c822ceb0a490496.tar.gz
ports-f3f431ec7437bc70de1e044e4c822ceb0a490496.zip
Notes
-rw-r--r--sysutils/vagrant/Makefile7
-rw-r--r--sysutils/vagrant/distinfo4
-rw-r--r--sysutils/vagrant/pkg-plist27
3 files changed, 32 insertions, 6 deletions
diff --git a/sysutils/vagrant/Makefile b/sysutils/vagrant/Makefile
index b2ade67a4f15..aaebfbff89e8 100644
--- a/sysutils/vagrant/Makefile
+++ b/sysutils/vagrant/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vagrant
-PORTVERSION= 1.5.1
-PORTREVISION= 2
+PORTVERSION= 1.5.2
CATEGORIES= sysutils rubygems devel
MASTER_SITES= LOCAL/swills https://codeload.github.com/mitchellh/vagrant/legacy.tar.gz/v${PORTVERSION}?dummy=/
@@ -31,9 +30,9 @@ RUN_DEPENDS= rubygem-main>=1.0:${PORTSDIR}/devel/rubygem-main \
rubygem-rb-kqueue>=0.2.2:${PORTSDIR}/devel/rubygem-rb-kqueue \
rubygem-wdm>=0.1.0:${PORTSDIR}/devel/rubygem-wdm
-WRKSRC= ${WRKDIR}/mitchellh-vagrant-6977e93
+WRKSRC= ${WRKDIR}/mitchellh-vagrant-5b360d0
USE_RUBY= yes
-GEMFILES= vagrant-1.5.1.gem
+GEMFILES= vagrant-${PORTVERSION}.gem
RUBYGEMBIN= gem${RUBY_SUFFIX}
PLIST_SUB+= GEMS_DIR="lib/ruby/gems/${RUBY_VER}/" \
GEM_BASE_DIR="lib/ruby/gems/${RUBY_VER}/gems" \
diff --git a/sysutils/vagrant/distinfo b/sysutils/vagrant/distinfo
index e488ca9fb63c..0ae5aed4ea22 100644
--- a/sysutils/vagrant/distinfo
+++ b/sysutils/vagrant/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vagrant-1.5.1.tar.gz) = e57257297ffae19135befeda9825ef3020e7ec73bcfceec82fc9c812787e4b9a
-SIZE (vagrant-1.5.1.tar.gz) = 2667387
+SHA256 (vagrant-1.5.2.tar.gz) = 6fd52cec74253e7bcbc4a847a9f5524b27f29dcca9bf6e5c2736b9cfc9c617f7
+SIZE (vagrant-1.5.2.tar.gz) = 2671799
diff --git a/sysutils/vagrant/pkg-plist b/sysutils/vagrant/pkg-plist
index ed0f90daa7df..a4aab91544ee 100644
--- a/sysutils/vagrant/pkg-plist
+++ b/sysutils/vagrant/pkg-plist
@@ -721,6 +721,22 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/.travis.yml
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/.vimrc
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/.yardopts
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/omnios/cap/mount_nfs_folder.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/config.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/guest.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/cap/change_host_name.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/cap/configure_networks.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/cap/halt.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/cap/mount_nfs.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/cap/rsync.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/suse/cap/halt.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/synced_folders/smb/scripts/ps_version.ps1
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/smartos/cap/change_host_name_test.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/smartos/cap/configure_networks_test.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/smartos/cap/halt_test.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/smartos/cap/mount_nfs_test.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/smartos/cap/rsync_test.rb
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/vagrant/util
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/vagrant/plugin/v2
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/vagrant/plugin/v1
@@ -755,6 +771,10 @@ bin/vagrant
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/kernel_v2
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/ubuntu/cap
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/ubuntu
+@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/cap
+@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos
+@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/smartos/cap
+@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/smartos
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/support/shared
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/support
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/test/unit/plugins/guests/redhat/cap
@@ -969,3 +989,10 @@ bin/vagrant
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/contrib
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/bin
@dirrm %%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%
+@unexec rmdir %D/%%GEMS_DIR%%/doc 2>/dev/null || true
+@unexec rmdir %D/%%GEMS_DIR%%/specifications 2>/dev/null || true
+@unexec rmdir %D/%%GEMS_DIR%%/gems 2>/dev/null || true
+@unexec rmdir %D/%%GEMS_DIR%%/cache 2>/dev/null || true
+@unexec rmdir %D/lib/ruby/gems/%%RUBY_VER%% 2>/dev/null || true
+@unexec rmdir %D/lib/ruby/gems 2>/dev/null || true
+@unexec rmdir %D/lib/ruby 2>/dev/null || true