aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2018-12-13 10:47:21 +0000
committerLarry Rosenman <ler@FreeBSD.org>2018-12-13 10:47:21 +0000
commitfea0f9bde155588c72b94fe4f32420d007b0a907 (patch)
treecd0195f6d4a488bc055666d0c6795931094e1d12
parent473719b0eacf8e6fb9a7e48597554e6d955e4307 (diff)
downloadports-fea0f9bde155588c72b94fe4f32420d007b0a907.tar.gz
ports-fea0f9bde155588c72b94fe4f32420d007b0a907.zip
Notes
-rw-r--r--astro/boinc-setiathome/Makefile4
-rw-r--r--astro/boinc-setiathome/files/patch-client_seti.h14
-rw-r--r--astro/boinc-setiathome/files/patch-configure.ac (renamed from astro/boinc-setiathome/files/patch-sah__config.h)8
3 files changed, 21 insertions, 5 deletions
diff --git a/astro/boinc-setiathome/Makefile b/astro/boinc-setiathome/Makefile
index 3fa9b1c055d4..41f448d95854 100644
--- a/astro/boinc-setiathome/Makefile
+++ b/astro/boinc-setiathome/Makefile
@@ -3,6 +3,7 @@
PORTNAME= boinc-setiathome
PORTVERSION= 8.00
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= LOCAL/ler/setiathome \
http://www.lerctr.org/setiathome/
@@ -23,9 +24,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
RUN_DEPENDS= boinc_client:net/boinc-client
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
-GNU_CONFIGURE= yes
USES= autoreconf compiler gmake libtool pkgconfig tar:xz
+GNU_CONFIGURE= yes
+
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
-L${LOCALBASE}/lib
LDFLAGS+= -lexecinfo
diff --git a/astro/boinc-setiathome/files/patch-client_seti.h b/astro/boinc-setiathome/files/patch-client_seti.h
new file mode 100644
index 000000000000..a8e2e7001e31
--- /dev/null
+++ b/astro/boinc-setiathome/files/patch-client_seti.h
@@ -0,0 +1,14 @@
+--- client/seti.h.orig 2018-12-13 10:21:28 UTC
++++ client/seti.h
+@@ -53,9 +53,9 @@ typedef uint64_t sh_uint8_t;
+
+ #ifdef PRId64
+ // If print formats are defined
+-#define SINT8_FMT "%"PRId64
++#define SINT8_FMT "%" PRId64
+ #define SINT8_FMT_CAST(x) (x)
+-#define UINT8_FMT "%"PRIu64
++#define UINT8_FMT "%" PRIu64
+ #define UINT8_FMT_CAST(x) (x)
+ #else
+ // play it safe. It'll work through 49 bits at least.
diff --git a/astro/boinc-setiathome/files/patch-sah__config.h b/astro/boinc-setiathome/files/patch-configure.ac
index 1cdb029c4141..a18209eb4f20 100644
--- a/astro/boinc-setiathome/files/patch-sah__config.h
+++ b/astro/boinc-setiathome/files/patch-configure.ac
@@ -1,11 +1,11 @@
---- sah_config.h.orig 2018-01-14 23:23:42 UTC
-+++ sah_config.h
-@@ -774,7 +774,7 @@
+--- configure.ac.orig 2018-12-13 10:20:53 UTC
++++ configure.ac
+@@ -658,7 +658,7 @@ AH_BOTTOM([
#endif
#if !defined(CUSTOM_STRING) && defined(COMPILER_STRING)
-#define CUSTOM_STRING PACKAGE_STRING" "SVN_REV" "COMPILER_STRING
-+#define CUSTOM_STRING PACKAGE_STRING" " SVN_REV" " COMPILER_STRING
++#define CUSTOM_STRING PACKAGE_STRING " " SVN_REV " " COMPILER_STRING
#endif
#include "std_fixes.h"