aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-08 02:22:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-08 02:22:07 +0000
commit03f643196eba916e32daa06622dda2782d30b089 (patch)
tree4ed9df84b3872e27a843af9421109d04cd0baa80
parent07559f548a57abaaafba0e4fda064f1cf8c05a06 (diff)
downloadports-03f643196eba916e32daa06622dda2782d30b089.tar.gz
ports-03f643196eba916e32daa06622dda2782d30b089.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/py-imdbpy/Makefile45
-rw-r--r--www/py-imdbpy/distinfo2
-rw-r--r--www/py-imdbpy/pkg-descr11
4 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 773de6ceab9f..4d62388ef93d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -544,6 +544,7 @@
SUBDIR += py-clientform
SUBDIR += py-fcgi
SUBDIR += py-htmltestcase
+ SUBDIR += py-imdbpy
SUBDIR += py-mt
SUBDIR += py-scgi
SUBDIR += py-websvcs
diff --git a/www/py-imdbpy/Makefile b/www/py-imdbpy/Makefile
new file mode 100644
index 000000000000..f7c8641f2c39
--- /dev/null
+++ b/www/py-imdbpy/Makefile
@@ -0,0 +1,45 @@
+# ex:ts=8
+# Ports collection makefile for: py-IMDbPY
+# Date created: Jul 8, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= imdbpy
+PORTVERSION= 1.3
+CATEGORIES= www python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Retrieve and manage the data of the IMDb movie database
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+WRKSRC= ${WRKDIR}/IMDbPY-${PORTVERSION}
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+PORTDOCS= *
+.endif
+
+post-install:
+ @${FIND} ${PYTHON_SITELIBDIR}/imdb ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/imdb -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/bin/ ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/py-imdbpy/distinfo b/www/py-imdbpy/distinfo
new file mode 100644
index 000000000000..c71c591c93d6
--- /dev/null
+++ b/www/py-imdbpy/distinfo
@@ -0,0 +1,2 @@
+MD5 (imdbpy-1.3.tar.gz) = ec2e0562bbb482596b62a4124f0dda11
+SIZE (imdbpy-1.3.tar.gz) = 45164
diff --git a/www/py-imdbpy/pkg-descr b/www/py-imdbpy/pkg-descr
new file mode 100644
index 000000000000..925d3dd0317e
--- /dev/null
+++ b/www/py-imdbpy/pkg-descr
@@ -0,0 +1,11 @@
+IMDbPY is a Python package useful to retrieve and manage the data of the IMDb
+movie database.
+
+IMDbPY aims to provide an easy way to access the IMDb's database using a Python
+script. Platform-independent and written in pure Python, it's theoretically
+independent from the data source (since IMDb provides two or three different
+interfaces to their database). IMDbPY is mainly intended for programmers and
+developers who want to build their Python programs using the IMDbPY package, but
+some example scripts - useful for simple users - are included.
+
+WWW: http://imdbpy.sourceforge.net/