aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-23 18:25:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-23 18:25:36 +0000
commit097021821bcdc59cd63e5ec31b6ec6b627a18178 (patch)
tree09db74c648843b8a56b2541daf1154c5eb32f551
parent2d56d286afcd8165174bfb418d6b5dfd98b8f3b9 (diff)
downloadports-097021821bcdc59cd63e5ec31b6ec6b627a18178.tar.gz
ports-097021821bcdc59cd63e5ec31b6ec6b627a18178.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xfce4-mpc-plugin/Makefile29
-rw-r--r--audio/xfce4-mpc-plugin/distinfo3
-rw-r--r--audio/xfce4-mpc-plugin/pkg-descr3
-rw-r--r--audio/xfce4-mpc-plugin/pkg-plist13
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6ff282761508..fe717cb9298b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -645,6 +645,7 @@
SUBDIR += xcd
SUBDIR += xcdplayer
SUBDIR += xfce4-mixer
+ SUBDIR += xfce4-mpc-plugin
SUBDIR += xhippo
SUBDIR += ximp3
SUBDIR += xmcd
diff --git a/audio/xfce4-mpc-plugin/Makefile b/audio/xfce4-mpc-plugin/Makefile
new file mode 100644
index 000000000000..08b2b9d71c99
--- /dev/null
+++ b/audio/xfce4-mpc-plugin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mpc plugin for xfce4
+# Date created: 12 July 2006
+# Whom: Martin Wilke (miwi@FreeBSD.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-mpc-plugin
+PORTVERSION= 0.3.0
+CATEGORIES= audio xfce
+MASTER_SITES= http://goodies.xfce.org/releases/xfce4-mpc-plugin/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A mpc plugin for xfce
+
+LIB_DEPENDS= mpd.0:${PORTSDIR}/audio/libmpd
+
+USE_GMAKE= yes
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
+USE_XFCE= configenv libgui libutil panel
+USE_XLIB= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
+.include <bsd.port.post.mk>
diff --git a/audio/xfce4-mpc-plugin/distinfo b/audio/xfce4-mpc-plugin/distinfo
new file mode 100644
index 000000000000..48e58611e7fb
--- /dev/null
+++ b/audio/xfce4-mpc-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (xfce4/xfce4-mpc-plugin-0.3.0.tar.gz) = 137214b1194a025076d361d3631cc3ae
+SHA256 (xfce4/xfce4-mpc-plugin-0.3.0.tar.gz) = 8fbc809f5fabd3ce71803912601f1a42dcdaf8206580a32344fef3fd602e47f0
+SIZE (xfce4/xfce4-mpc-plugin-0.3.0.tar.gz) = 136968
diff --git a/audio/xfce4-mpc-plugin/pkg-descr b/audio/xfce4-mpc-plugin/pkg-descr
new file mode 100644
index 000000000000..102927249b01
--- /dev/null
+++ b/audio/xfce4-mpc-plugin/pkg-descr
@@ -0,0 +1,3 @@
+A client plugin for MPD, the Music Player Daemon.
+
+WWW: http://goodies.xfce.org/
diff --git a/audio/xfce4-mpc-plugin/pkg-plist b/audio/xfce4-mpc-plugin/pkg-plist
new file mode 100644
index 000000000000..f7fb72a4f94e
--- /dev/null
+++ b/audio/xfce4-mpc-plugin/pkg-plist
@@ -0,0 +1,13 @@
+libexec/xfce4/panel-plugins/xfce4-mpc-plugin
+share/locale/cs/LC_MESSAGES/xfce4-mpc-plugin.mo
+share/locale/fr/LC_MESSAGES/xfce4-mpc-plugin.mo
+share/locale/pl/LC_MESSAGES/xfce4-mpc-plugin.mo
+share/xfce4/panel-plugins/xfce4-mpc-plugin.desktop
+@dirrmtry share/xfce4/panel-plugins
+@dirrmtry share/xfce4
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry libexec/xfce4/panel-plugins
+@dirrmtry libexec/xfce4