aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-26 18:17:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-26 18:17:21 +0000
commit13dabe55b401e358aff9fd500b6c4d52b5951cd4 (patch)
treee4843c60ce4ac5ac2d1d18f2d1a291c2b9604681
parent9ba0d068fedb9e82509bf22051431e92c44a8e2d (diff)
downloadports-13dabe55b401e358aff9fd500b6c4d52b5951cd4.tar.gz
ports-13dabe55b401e358aff9fd500b6c4d52b5951cd4.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-fog-brightbox/Makefile21
-rw-r--r--devel/rubygem-fog-brightbox/distinfo2
-rw-r--r--devel/rubygem-fog-brightbox/pkg-descr16
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 03be6e0bf984..191e0ed7b8ed 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4212,6 +4212,7 @@
SUBDIR += rubygem-file-tail
SUBDIR += rubygem-filemagic
SUBDIR += rubygem-fog
+ SUBDIR += rubygem-fog-brightbox
SUBDIR += rubygem-font-awesome-rails
SUBDIR += rubygem-foreman
SUBDIR += rubygem-foreman_api
diff --git a/devel/rubygem-fog-brightbox/Makefile b/devel/rubygem-fog-brightbox/Makefile
new file mode 100644
index 000000000000..32b93e459586
--- /dev/null
+++ b/devel/rubygem-fog-brightbox/Makefile
@@ -0,0 +1,21 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fog-brightbox
+PORTVERSION= 0.0.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Module for the 'fog' gem to support Brightbox Cloud
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-fog-core>=0:${PORTSDIR}/devel/rubygem-fog-core \
+ rubygem-fog-json>=0:${PORTSDIR}/devel/rubygem-fog-json
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-fog-brightbox/distinfo b/devel/rubygem-fog-brightbox/distinfo
new file mode 100644
index 000000000000..e88e71f78f0b
--- /dev/null
+++ b/devel/rubygem-fog-brightbox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/fog-brightbox-0.0.2.gem) = 8fc94d7e5cbeee696e40e3c90e7d8c686da147ae63941cc066e5869719857b49
+SIZE (rubygem/fog-brightbox-0.0.2.gem) = 29696
diff --git a/devel/rubygem-fog-brightbox/pkg-descr b/devel/rubygem-fog-brightbox/pkg-descr
new file mode 100644
index 000000000000..867b67843ba7
--- /dev/null
+++ b/devel/rubygem-fog-brightbox/pkg-descr
@@ -0,0 +1,16 @@
+Brightbox Cloud module for fog (The Ruby cloud services library)
+
+This gem is a modular for the `fog` gem that allows you to manage resources in
+the Brightbox Cloud.
+
+It is included by the main `fog` metagem but can used as an independent library
+in other applications.
+
+This includes support for the following services:
+- Compute
+- Images
+- Load Balancers
+- SQL Cloud instances
+
+WWW: https://github.com/fog/fog/tree/master/providers/brightbox
+RG: https://rubygems.org/gems/fog-brightbox