aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-25 01:12:13 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-25 01:12:13 +0000
commit1e58a10ad986a5e178474522ddb750d67b015288 (patch)
tree09647c6059c14fab9f197088b48af37f3368aecf
parentaf30002d716b569457f9bb296c0695d148540f5f (diff)
downloadports-1e58a10ad986a5e178474522ddb750d67b015288.tar.gz
ports-1e58a10ad986a5e178474522ddb750d67b015288.zip
Notes
-rw-r--r--devel/dulwich/Makefile5
-rw-r--r--devel/dulwich/files/patch-setup.py4
2 files changed, 5 insertions, 4 deletions
diff --git a/devel/dulwich/Makefile b/devel/dulwich/Makefile
index 7572b6b4f912..c5610fe3e6c2 100644
--- a/devel/dulwich/Makefile
+++ b/devel/dulwich/Makefile
@@ -8,7 +8,8 @@
PORTNAME= dulwich
PORTVERSION= 0.6.0
CATEGORIES= devel python
-MASTER_SITES= http://samba.org/~jelmer/${PORTNAME}/
+MASTER_SITES= http://samba.org/~jelmer/${PORTNAME}/ \
+ http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= marco.broeder@gmx.eu
@@ -17,6 +18,8 @@ COMMENT= Pure-Python implementation of the Git file formats and protocols
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+FETCH_ARGS= -pRr # default '-ApRr' prevents 302 redirects by launchpad
+
.ifndef (NOPORTDOCS)
PORTDOCS= AUTHORS COPYING HACKING NEWS README
.endif
diff --git a/devel/dulwich/files/patch-setup.py b/devel/dulwich/files/patch-setup.py
index 43379f7d34e9..04fcce8bb120 100644
--- a/devel/dulwich/files/patch-setup.py
+++ b/devel/dulwich/files/patch-setup.py
@@ -1,7 +1,6 @@
--- ./setup.py.orig 2010-03-03 16:33:52.000000000 +0100
+++ ./setup.py 2010-03-03 21:13:31.000000000 +0100
-@@ -2,10 +2,7 @@
- # Setup file for bzr-git
+@@ -3,8 +3,5 @@
# Copyright (C) 2008-2010 Jelmer Vernooij <jelmer@samba.org>
-try:
@@ -11,4 +10,3 @@
+from distutils.core import setup, Extension
from distutils.core import Distribution
- dulwich_version_string = '0.6.0'