aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-04-10 21:13:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-04-10 21:13:31 +0000
commit2c49737ca433d36900e5668cdb6eb69c55caec16 (patch)
treeb36631ce96e95cb9a26f720248d598300e990c81
parent96c7199eb5e3c5547f0cff490c92f7b7239c4c83 (diff)
downloadports-2c49737ca433d36900e5668cdb6eb69c55caec16.tar.gz
ports-2c49737ca433d36900e5668cdb6eb69c55caec16.zip
Notes
-rw-r--r--graphics/kallery/Makefile8
-rw-r--r--science/hdf/Makefile4
-rw-r--r--textproc/skim/Makefile4
-rw-r--r--www/osb-nrcit/Makefile4
4 files changed, 5 insertions, 15 deletions
diff --git a/graphics/kallery/Makefile b/graphics/kallery/Makefile
index 09b0e9483e69..d3c75c5fc4dc 100644
--- a/graphics/kallery/Makefile
+++ b/graphics/kallery/Makefile
@@ -22,12 +22,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Configure fails on amd64"
-.endif
-
post-patch:
.if !defined(NOPORTDOCS)
@${REINPLACE_CMD} -Ee \
@@ -37,4 +31,4 @@ post-patch:
@${REINPLACE_CMD} -Ee 's|(kallery po) doc|\1|' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 8fef5d9144b5..8cb7747090db 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -42,8 +42,8 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386" && ${ARCH} != "alpha"
-BROKEN= "Does not compile on !i386 and !alpha"
+.if ${ARCH} != "i386" && ${ARCH} != "alpha" && ${ARCH} != "amd64"
+BROKEN= "Does not compile on !i386, !amd64 and !alpha"
.endif
post-patch:
diff --git a/textproc/skim/Makefile b/textproc/skim/Makefile
index f2bfb7543f5e..0abd150f9d72 100644
--- a/textproc/skim/Makefile
+++ b/textproc/skim/Makefile
@@ -33,10 +33,6 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= Does not compile
-.endif
-
.if ${OSVERSION} < 500035
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
diff --git a/www/osb-nrcit/Makefile b/www/osb-nrcit/Makefile
index 8ea59d95f793..2e31e3bfca06 100644
--- a/www/osb-nrcit/Makefile
+++ b/www/osb-nrcit/Makefile
@@ -24,8 +24,8 @@ USE_LIBTOOL_VER=15
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+BROKEN= "Does not compile on !i386 and !amd64"
.endif
.include <bsd.port.post.mk>