aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2018-04-11 05:53:33 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2018-04-11 05:53:33 +0000
commit2cab66bb35abd2c5ca7a6dde484a103e8c894285 (patch)
treeeb53256aa64f81847447c1580b9991654dbcfc7d
parent0a93e19a97bd768731f43a22d241030122ac57c2 (diff)
downloadports-2cab66bb35abd2c5ca7a6dde484a103e8c894285.tar.gz
ports-2cab66bb35abd2c5ca7a6dde484a103e8c894285.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/R-cran-geometry/Makefile21
-rw-r--r--math/R-cran-geometry/distinfo3
-rw-r--r--math/R-cran-geometry/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index f34b1b33d8e1..c31b49813763 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -47,6 +47,7 @@
SUBDIR += R-cran-forecast
SUBDIR += R-cran-fracdiff
SUBDIR += R-cran-geepack
+ SUBDIR += R-cran-geometry
SUBDIR += R-cran-gmp
SUBDIR += R-cran-gower
SUBDIR += R-cran-gpclib
diff --git a/math/R-cran-geometry/Makefile b/math/R-cran-geometry/Makefile
new file mode 100644
index 000000000000..72e6fbc9a13e
--- /dev/null
+++ b/math/R-cran-geometry/Makefile
@@ -0,0 +1,21 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= geometry
+DISTVERSION= 0.3-6
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Mesh Generation and Surface Tesselation
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cran:auto-plist,compiles
+
+CRAN_DEPENDS= R-cran-magic>0:math/R-cran-magic
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+.include <bsd.port.mk>
diff --git a/math/R-cran-geometry/distinfo b/math/R-cran-geometry/distinfo
new file mode 100644
index 000000000000..838c47d1a52a
--- /dev/null
+++ b/math/R-cran-geometry/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523349959
+SHA256 (geometry_0.3-6.tar.gz) = 2be231ac99171367635cd957f27da77705329df97520ab86f655839c41dc0968
+SIZE (geometry_0.3-6.tar.gz) = 480200
diff --git a/math/R-cran-geometry/pkg-descr b/math/R-cran-geometry/pkg-descr
new file mode 100644
index 000000000000..e827575b493e
--- /dev/null
+++ b/math/R-cran-geometry/pkg-descr
@@ -0,0 +1,12 @@
+Makes the qhull library (www.qhull.org) available in R, in a similar
+manner as in Octave and MATLAB. Qhull computes convex hulls, Delaunay
+triangulations, halfspace intersections about a point, Voronoi
+diagrams, furthest-site Delaunay triangulations, and furthest-site
+Voronoi diagrams. It runs in 2-d, 3-d, 4-d, and higher dimensions.
+It implements the Quickhull algorithm for computing the convex hull.
+Qhull does not support constrained Delaunay triangulations, or mesh
+generation of non-convex objects, but the package does include some
+R functions that allow for this. Currently the package only gives
+access to Delaunay triangulation and convex hull computation.
+
+WWW: https://cran.r-project.org/web/packages/geometry/