aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-28 22:03:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-28 22:03:45 +0000
commit373e3f74076e159678d911eebe70eed65d26fd44 (patch)
tree6bb0309a632938e2fdaa083496dc02a8112033b2
parente4cf26941235219af5c6edd5e1f16ff1e9894f48 (diff)
downloadports-373e3f74076e159678d911eebe70eed65d26fd44.tar.gz
ports-373e3f74076e159678d911eebe70eed65d26fd44.zip
Notes
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/notecase/Makefile35
-rw-r--r--deskutils/notecase/distinfo3
-rw-r--r--deskutils/notecase/files/patch-Makefile109
-rw-r--r--deskutils/notecase/files/patch-src_gui_GuiLanguage.cpp10
-rw-r--r--deskutils/notecase/files/patch-src_lib_CircularBuffer.cpp11
-rw-r--r--deskutils/notecase/files/patch-src_main.cpp11
-rw-r--r--deskutils/notecase/pkg-descr6
-rw-r--r--deskutils/notecase/pkg-plist50
9 files changed, 236 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index ae9e9b3d5e3e..f5568e6c0688 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -148,6 +148,7 @@
SUBDIR += nautilus-locked-folder
SUBDIR += nautilus-open-terminal
SUBDIR += nautilus-sendto
+ SUBDIR += notecase
SUBDIR += notification-daemon
SUBDIR += ontv
SUBDIR += orage
diff --git a/deskutils/notecase/Makefile b/deskutils/notecase/Makefile
new file mode 100644
index 000000000000..c7609bf94aba
--- /dev/null
+++ b/deskutils/notecase/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: notecase
+# Date created: 19 July 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= notecase
+PORTVERSION= 1.5.8
+CATEGORIES= deskutils textproc
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}_src
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A hierarchical text notes manager
+
+USE_GMAKE= yes
+USE_GNOME= gtk20 gnomevfs2 desktopfileutils
+USE_GETTEXT= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install docinstall
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|prefix=/usr|prefix=${PREFIX}|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ @-update-mime-database ${PREFIX}/share/mime
+ @-update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/deskutils/notecase/distinfo b/deskutils/notecase/distinfo
new file mode 100644
index 000000000000..a229b2587388
--- /dev/null
+++ b/deskutils/notecase/distinfo
@@ -0,0 +1,3 @@
+MD5 (notecase-1.5.8_src.tar.gz) = 6e44c5e7bff2afdec36f63963fe18b20
+SHA256 (notecase-1.5.8_src.tar.gz) = b27ac143df957483fba88c98885551657377f173fb588ac1be395ffb0c92683f
+SIZE (notecase-1.5.8_src.tar.gz) = 667078
diff --git a/deskutils/notecase/files/patch-Makefile b/deskutils/notecase/files/patch-Makefile
new file mode 100644
index 000000000000..95b724170fb5
--- /dev/null
+++ b/deskutils/notecase/files/patch-Makefile
@@ -0,0 +1,109 @@
+--- Makefile.orig Mon Jun 25 12:53:44 2007
++++ Makefile Thu Jul 19 18:41:38 2007
+@@ -80,7 +79,7 @@
+ ifdef WINDIR
+ LD=$(QL) $(CXX) $(DEBUG) $(PROFILE) $(LOPTIMIZE) -L$(OBJ) -lz
+ else
+- LD=$(QL) $(CXX) $(DEBUG) $(PROFILE) $(LOPTIMIZE) -ldl -export-dynamic $(LOPTIMIZE)
++ LD=$(QL) $(CXX) $(DEBUG) $(PROFILE) $(LOPTIMIZE) -export-dynamic $(LOPTIMIZE)
+ endif
+
+ #
+@@ -360,7 +359,7 @@
+ $(CC) $(FLAGS) -c $(GUIPATH)/DocActionFinishDel.cpp -o $(OBJ)/DocActionFinishDel.o $(GTKCFLAGS)
+
+ $(OBJ)/libz.a:
+- @cd ./src/lib/zlib/; make; cp ./libz.a ../../../$(OBJ)/
++ @cd ./src/lib/zlib/; gmake; cp ./libz.a ../../../$(OBJ)/
+
+ $(OBJ)/ShortcutsList.o: $(GUIPATH)/ShortcutsList.cpp $(GUIPATH)/ShortcutsList.h
+ $(CC) $(FLAGS) -c $(GUIPATH)/ShortcutsList.cpp -o $(OBJ)/ShortcutsList.o $(GTKCFLAGS)
+@@ -405,7 +404,8 @@
+ rm -f po/messages.mo; \
+ msgfmt $$i -o po/messages.mo; \
+ echo "Installing: $(DESTDIR)$(datadir)/locale/$$loc/LC_MESSAGES/notecase.mo";\
+- install -D -m 644 po/messages.mo "$(DESTDIR)$(datadir)/locale/$$loc/LC_MESSAGES/notecase.mo"; \
++ install -d $(DESTDIR)$(datadir)/locale/$$loc/LC_MESSAGES; \
++ install -m 644 -c po/messages.mo "$(DESTDIR)$(datadir)/locale/$$loc/LC_MESSAGES/notecase.mo"; \
+ done; \
+ rm -f po/messages.mo;
+ @echo done installing translations
+@@ -413,16 +413,24 @@
+ pouninstall:
+ @rm -vf $(DESTDIR)$(datadir)/locale/*/LC_MESSAGES/notecase.mo
+ @echo done uninstalling translations
+-
++
++docinstall:
++ -install -d $(DESTDIR)$(datadir)/doc/notecase
++ install -m 644 -c docs/help.ncd "$(DESTDIR)$(datadir)/doc/notecase/help.ncd"
++ install -m 644 -c docs/license.txt "$(DESTDIR)$(datadir)/doc/notecase/license.txt"
++
+ #
+ # install application
+ #
+ install: notecase$(EXE) poinstall
+- install -D -m 755 $(BIN)/notecase "$(DESTDIR)$(bindir)/notecase"
+- install -D -m 644 docs/help.ncd "$(DESTDIR)$(datadir)/doc/notecase/help.ncd"
+- install -D -m 644 docs/notecase.desktop "$(DESTDIR)$(datadir)/applications/notecase.desktop"
+- install -D -m 644 docs/notecase.xml "$(DESTDIR)$(datadir)/mime/packages/notecase.xml"
+- install -D -m 644 res/notecase.xpm "$(DESTDIR)$(datadir)/pixmaps/notecase.xpm"
++ -install -d $(DESTDIR)$(bindir)
++ install -m 755 -c $(BIN)/notecase "$(DESTDIR)$(bindir)/notecase"
++ -install -d $(DESTDIR)$(datadir)/applications
++ install -m 644 -c docs/notecase.desktop "$(DESTDIR)$(datadir)/applications/notecase.desktop"
++ -install -d $(DESTDIR)$(datadir)/mime/packages
++ install -m 644 -c docs/notecase.xml "$(DESTDIR)$(datadir)/mime/packages/notecase.xml"
++ -install -d $(DESTDIR)$(datadir)/pixmaps
++ install -m 644 -c res/notecase.xpm "$(DESTDIR)$(datadir)/pixmaps/notecase.xpm"
+ @echo done installing
+
+ #
+@@ -474,23 +482,23 @@
+ # 7. update version in the control file used to build Debian/Ubuntu .deb package
+ #
+ updatesrc:
+- $(Q)sed -i 's/^Version:.*/Version: $(VERSION)/' ./docs/notecase.spec
+- $(Q)sed -i 's/^Source:.*/Source: $(archive).tar.gz/' ./docs/notecase.spec
+- $(Q)sed -i 's/\#define APP_VER_STR .*/\#define APP_VER_STR "$(VERSION)"/' ./src/config.h
+- $(Q)sed -i 's:\#define INSTALL_PREFIX .*:\#define INSTALL_PREFIX "$(DESTDIR)$(prefix)":' ./src/config.h
++ $(Q)sed -i.bak 's/^Version:.*/Version: $(VERSION)/' ./docs/notecase.spec
++ $(Q)sed -i.bak 's/^Source:.*/Source: $(archive).tar.gz/' ./docs/notecase.spec
++ $(Q)sed -i.bak 's/\#define APP_VER_STR .*/\#define APP_VER_STR "$(VERSION)"/' ./src/config.h
++ $(Q)sed -i.bak 's:\#define INSTALL_PREFIX .*:\#define INSTALL_PREFIX "$(DESTDIR)$(prefix)":' ./src/config.h
+ $(Q)if [ "$(HAVE_GNOME_VFS)" = "" ]; then \
+- sed -i 's:[/]*#define HAVE_GNOME_VFS.*://#define HAVE_GNOME_VFS:' ./src/config.h; \
++ sed -i.bak 's:[/]*#define HAVE_GNOME_VFS.*://#define HAVE_GNOME_VFS:' ./src/config.h; \
+ else \
+- sed -i 's:[/]*#define HAVE_GNOME_VFS.*:#define HAVE_GNOME_VFS:' ./src/config.h; \
++ sed -i.bak 's:[/]*#define HAVE_GNOME_VFS.*:#define HAVE_GNOME_VFS:' ./src/config.h; \
+ fi;
+ $(Q)if [ "$(ZAURUS)" = "" ]; then \
+- sed -i 's:[/]*#define _ZAURUS_BUILD.*://#define _ZAURUS_BUILD:' ./src/config.h; \
++ sed -i.bak 's:[/]*#define _ZAURUS_BUILD.*://#define _ZAURUS_BUILD:' ./src/config.h; \
+ else \
+- sed -i 's:[/]*#define _ZAURUS_BUILD.*:#define _ZAURUS_BUILD:' ./src/config.h; \
++ sed -i.bak 's:[/]*#define _ZAURUS_BUILD.*:#define _ZAURUS_BUILD:' ./src/config.h; \
+ fi;
+- $(Q)sed -i 's/^Version: .*/Version: $(VERSION)/' ./docs/control
+- $(Q)sed -i 's/^Version: .*/Version: $(VERSION)/' ./debian/control
+- $(Q)sed -i 's/^Architecture: .*/Architecture: $(ARCH)/' ./debian/control
++ $(Q)sed -i.bak 's/^Version: .*/Version: $(VERSION)/' ./docs/control
++ $(Q)sed -i.bak 's/^Version: .*/Version: $(VERSION)/' ./debian/control
++ $(Q)sed -i.bak 's/^Architecture: .*/Architecture: $(ARCH)/' ./debian/control
+
+ #
+ # - convert sources to DOS text format (this is multiplatform project)
+@@ -591,9 +599,9 @@
+ #
+ clean:
+ @echo cleaning up
+- $(Q)cd ./src/lib/zlib/; make clean;
++ $(Q)cd ./src/lib/zlib/; gmake clean;
+ $(Q)rm -f $(OBJ)/*.o $(OBJ)/*.d $(OBJ)/*.a $(BIN)/core.* $(BIN)/notecase$(EXE) ./gmon.out
+ $(Q)rm -rf ./notecase
+
+
+-.PHONY : all help poinstall pouninstall install uninstall rpm pack packdos updatesrcdos updatesrc updatemime clean ipk deb weexpc check install2
+\ No newline at end of file
++.PHONY : all help poinstall pouninstall install uninstall rpm pack packdos updatesrcdos updatesrc updatemime clean ipk deb weexpc check install2
diff --git a/deskutils/notecase/files/patch-src_gui_GuiLanguage.cpp b/deskutils/notecase/files/patch-src_gui_GuiLanguage.cpp
new file mode 100644
index 000000000000..a74f2b32331d
--- /dev/null
+++ b/deskutils/notecase/files/patch-src_gui_GuiLanguage.cpp
@@ -0,0 +1,10 @@
+--- src/gui/GuiLanguage.cpp.orig Wed Jun 6 15:38:20 2007
++++ src/gui/GuiLanguage.cpp Thu Jul 19 17:19:33 2007
+@@ -13,6 +13,7 @@
+ #include "GuiLanguage.h"
+ #include <algorithm>
+ #include <gtk/gtk.h>
++#include <libgen.h>
+ #ifdef ENABLE_NLS
+ #include <libintl.h>
+ #endif
diff --git a/deskutils/notecase/files/patch-src_lib_CircularBuffer.cpp b/deskutils/notecase/files/patch-src_lib_CircularBuffer.cpp
new file mode 100644
index 000000000000..3ea8da6e95f7
--- /dev/null
+++ b/deskutils/notecase/files/patch-src_lib_CircularBuffer.cpp
@@ -0,0 +1,11 @@
+--- src/lib/CircularBuffer.cpp.orig Tue Jul 10 16:23:18 2007
++++ src/lib/CircularBuffer.cpp Tue Jul 10 16:28:25 2007
+@@ -115,7 +115,7 @@
+ struct timeval the_time;
+ int result = gettimeofday(&the_time, NULL);
+ if(result >= 0){
+- struct tm *pTime = localtime(&the_time.tv_sec);
++ struct tm *pTime = localtime((time_t*)&the_time.tv_sec);
+ sprintf(buffer, "%02d:%02d:%02d", pTime->tm_hour, pTime->tm_min, pTime->tm_sec);
+
+ //append miliseconds
diff --git a/deskutils/notecase/files/patch-src_main.cpp b/deskutils/notecase/files/patch-src_main.cpp
new file mode 100644
index 000000000000..7257779308bc
--- /dev/null
+++ b/deskutils/notecase/files/patch-src_main.cpp
@@ -0,0 +1,11 @@
+--- src/main.cpp.orig Thu Jul 19 16:58:40 2007
++++ src/main.cpp Thu Jul 19 16:58:55 2007
+@@ -11,6 +11,8 @@
+ #include <gtk/gtk.h>
+ #include <libintl.h>
+
++#include <libgen.h>
++
+ #include "interface.h"
+ #include "callbacks.h"
+ #include "support.h"
diff --git a/deskutils/notecase/pkg-descr b/deskutils/notecase/pkg-descr
new file mode 100644
index 000000000000..a9ac628647be
--- /dev/null
+++ b/deskutils/notecase/pkg-descr
@@ -0,0 +1,6 @@
+NoteCase is a hierarchical text notes manager (a.k.a. outliner). It helps you
+organize your everyday text notes into a single document with individual notes
+placed into a tree-like structure. To ensure your privacy an encrypted document
+format is supported along with a standard unencrypted one.
+
+WWW: http://notecase.sourceforge.net/
diff --git a/deskutils/notecase/pkg-plist b/deskutils/notecase/pkg-plist
new file mode 100644
index 000000000000..eda5d66c96d5
--- /dev/null
+++ b/deskutils/notecase/pkg-plist
@@ -0,0 +1,50 @@
+bin/notecase
+share/applications/notecase.desktop
+%%PORTDOCS%%%%DOCSDIR%%/help.ncd
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+share/locale/ar/LC_MESSAGES/notecase.mo
+share/locale/ca/LC_MESSAGES/notecase.mo
+share/locale/cs/LC_MESSAGES/notecase.mo
+share/locale/da/LC_MESSAGES/notecase.mo
+share/locale/de/LC_MESSAGES/notecase.mo
+share/locale/el/LC_MESSAGES/notecase.mo
+share/locale/es/LC_MESSAGES/notecase.mo
+share/locale/et/LC_MESSAGES/notecase.mo
+share/locale/fi/LC_MESSAGES/notecase.mo
+share/locale/fr/LC_MESSAGES/notecase.mo
+share/locale/fr_CA/LC_MESSAGES/notecase.mo
+share/locale/hr/LC_MESSAGES/notecase.mo
+share/locale/hu/LC_MESSAGES/notecase.mo
+share/locale/id/LC_MESSAGES/notecase.mo
+share/locale/it/LC_MESSAGES/notecase.mo
+share/locale/ja/LC_MESSAGES/notecase.mo
+share/locale/ko/LC_MESSAGES/notecase.mo
+share/locale/ms/LC_MESSAGES/notecase.mo
+share/locale/nl/LC_MESSAGES/notecase.mo
+share/locale/nn/LC_MESSAGES/notecase.mo
+share/locale/no/LC_MESSAGES/notecase.mo
+share/locale/pl/LC_MESSAGES/notecase.mo
+share/locale/pt/LC_MESSAGES/notecase.mo
+share/locale/pt_BR/LC_MESSAGES/notecase.mo
+share/locale/ro/LC_MESSAGES/notecase.mo
+share/locale/ru/LC_MESSAGES/notecase.mo
+share/locale/sk/LC_MESSAGES/notecase.mo
+share/locale/sl/LC_MESSAGES/notecase.mo
+share/locale/sr/LC_MESSAGES/notecase.mo
+share/locale/sv/LC_MESSAGES/notecase.mo
+share/locale/ta/LC_MESSAGES/notecase.mo
+share/locale/tr/LC_MESSAGES/notecase.mo
+share/locale/zh_CN/LC_MESSAGES/notecase.mo
+share/locale/zh_TW/LC_MESSAGES/notecase.mo
+share/mime/packages/notecase.xml
+share/pixmaps/notecase.xpm
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrmtry share/locale/fr_CA/LC_MESSAGES
+@dirrmtry share/locale/fr_CA
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications