aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-09-14 23:41:41 +0000
committerCy Schubert <cy@FreeBSD.org>2023-09-15 14:07:46 +0000
commit3d3866a1abd528929cb6a357cd63402bdccc7b47 (patch)
tree17ac009ff74ebbc517d480a652f3277b17181cc0
parente242127d30cdcef77f50503bd266996c1ed8a50b (diff)
downloadports-3d3866a1abd528929cb6a357cd63402bdccc7b47.tar.gz
ports-3d3866a1abd528929cb6a357cd63402bdccc7b47.zip
devel/binutils: fix build with lld 17
Some versioned symbols in libctf are undefined when libctf-nobfd.so is linked. Suppress errors with lld >= 17 due to these undefined symbols. PR: 273791 MFH: 2023Q3 (cherry picked from commit 495843badfe7d717f01466b9f41763524e670379)
-rw-r--r--devel/binutils/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 0530c4bbc988..ff17de61ebfd 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -39,6 +39,10 @@ CONFIGURE_ARGS+= --disable-werror \
MAKE_ARGS+= LIBDL="" V=1
MAKE_ENV+= ac_cv_func_sbrk=0
+# Some versioned symbols in libctf are undefined when libctf-nobfd.so is linked.
+# Suppress errors with lld >= 17 due to these undefined symbols.
+LDFLAGS+= -Wl,--undefined-version
+
# Tests will always fail because --compress-debug-sections is always set to
# zlib-gabi regardless of the compression setting by ./configure.
# TEST_TARGET= check