aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-25 10:18:17 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-25 10:18:17 +0000
commit4fbc58c5d82b26a422044b3d00c8ee1353c5eae7 (patch)
tree9094e251fedb392d63bbad18ab1c7837dcaa70dc
parentbc4f02f8976ec59d691557693ba8b7ab59fa27ee (diff)
downloadports-4fbc58c5d82b26a422044b3d00c8ee1353c5eae7.tar.gz
ports-4fbc58c5d82b26a422044b3d00c8ee1353c5eae7.zip
Notes
-rw-r--r--audio/replay/Makefile8
-rw-r--r--editors/gxedit/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/audio/replay/Makefile b/audio/replay/Makefile
index 2b4c141e9c7d..0235ea0b5c8b 100644
--- a/audio/replay/Makefile
+++ b/audio/replay/Makefile
@@ -27,6 +27,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS+= --enable-i18n=JAPANESE
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+BROKEN= "Does not compile on alpha 5.x"
+.endif
+
pre-configure:
.if !defined(WITH_I18N)
@${ECHO_MSG}
@@ -43,4 +49,4 @@ pre-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/replay ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/gxedit/Makefile b/editors/gxedit/Makefile
index 7e0f2aff6412..532272787473 100644
--- a/editors/gxedit/Makefile
+++ b/editors/gxedit/Makefile
@@ -21,6 +21,12 @@ USE_GNOME= gtk12
ALL_TARGET= gxedit
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+BROKEN= "Does not compile on alpha 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/config.h
@@ -41,4 +47,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>