aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 17:12:10 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 17:12:10 +0000
commit740c3eaaedfe67c5c895154205f67a84370cda71 (patch)
treefbf39c42dc8f9ba0310a1b53b3881c5d8a630862
parent08fdf7d9adcd2b4ecbb3028cc346bd144f45c77b (diff)
downloadports-740c3eaaedfe67c5c895154205f67a84370cda71.tar.gz
ports-740c3eaaedfe67c5c895154205f67a84370cda71.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/epdfview/Makefile45
-rw-r--r--graphics/epdfview/distinfo3
-rw-r--r--graphics/epdfview/pkg-descr7
-rw-r--r--graphics/epdfview/pkg-plist21
5 files changed, 77 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9e3855e970d1..c26fcac7300b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -95,6 +95,7 @@
SUBDIR += enfle
SUBDIR += entice
SUBDIR += eog
+ SUBDIR += epdfview
SUBDIR += epeg
SUBDIR += epix
SUBDIR += eps2png
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
new file mode 100644
index 000000000000..e8c57a44b705
--- /dev/null
+++ b/graphics/epdfview/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: epdfview
+# Date created: 2006/06/01
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= epdfview
+PORTVERSION= 0.1.5
+CATEGORIES= graphics print gnome
+MASTER_SITES= http://www.emma-soft.com/projects/epdfview/chrome/site/releases/
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= A lightweight PDF document viewer
+
+LIB_DEPENDS= cppunit-1.10.2:${PORTSDIR}/devel/cppunit \
+ poppler-glib.1:${PORTSDIR}/graphics/poppler-gtk
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+USE_ICONV= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 intlhack
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/applications ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/data/${PORTNAME}.desktop ${PREFIX}/share/applications/
+ @-update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/graphics/epdfview/distinfo b/graphics/epdfview/distinfo
new file mode 100644
index 000000000000..c48fc18e1799
--- /dev/null
+++ b/graphics/epdfview/distinfo
@@ -0,0 +1,3 @@
+MD5 (epdfview-0.1.5.tar.bz2) = 70b4c5c36781b6e1d5d2ed30a79db9c5
+SHA256 (epdfview-0.1.5.tar.bz2) = d437b49f40f61e3ba5a3ed8edad783895dcbdfc3cd4cbe6ef37a56f7eea59573
+SIZE (epdfview-0.1.5.tar.bz2) = 392460
diff --git a/graphics/epdfview/pkg-descr b/graphics/epdfview/pkg-descr
new file mode 100644
index 000000000000..8f6a402a7018
--- /dev/null
+++ b/graphics/epdfview/pkg-descr
@@ -0,0 +1,7 @@
+ePDFView is a free lightweight PDF document viewer using Poppler and GTK+
+libraries.
+
+The aim of ePDFView is to make a simple PDF document viewer, in the lines of
+Evince but without using the Gnome libraries.
+
+WWW: http://www.emma-soft.com/projects/epdfview/
diff --git a/graphics/epdfview/pkg-plist b/graphics/epdfview/pkg-plist
new file mode 100644
index 000000000000..86c8b6d79b25
--- /dev/null
+++ b/graphics/epdfview/pkg-plist
@@ -0,0 +1,21 @@
+bin/epdfview
+%%NLS%%share/locale/ca/LC_MESSAGES/epdfview.mo
+%%NLS%%share/locale/de/LC_MESSAGES/epdfview.mo
+%%NLS%%share/locale/es/LC_MESSAGES/epdfview.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/epdfview.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/epdfview.mo
+share/applications/epdfview.desktop
+%%DATADIR%%/pixmaps/icon_epdfview-24.png
+%%DATADIR%%/pixmaps/icon_epdfview-32.png
+%%DATADIR%%/pixmaps/icon_epdfview-48.png
+%%DATADIR%%/pixmaps/stock_find_next_24.png
+%%DATADIR%%/pixmaps/stock_find_previous_24.png
+%%DATADIR%%/pixmaps/stock_rotate-90.png
+%%DATADIR%%/pixmaps/stock_rotate-270.png
+%%DATADIR%%/pixmaps/stock_zoom-page-width.png
+%%DATADIR%%/ui/epdfview-ui-print.xml
+%%DATADIR%%/ui/epdfview-ui.xml
+@dirrmtry share/applications
+@dirrmtry %%DATADIR%%/pixmaps
+@dirrmtry %%DATADIR%%/ui
+@dirrmtry %%DATADIR%%