aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-12-04 20:56:16 +0000
committerClement Laforet <clement@FreeBSD.org>2005-12-04 20:56:16 +0000
commit8ce51beeec53e83ae246169a30909b0660b06e33 (patch)
tree3a1a3915e2b8208344e8539bee22c0c5729021b3
parentfc43dd263250bd9f10fe4ff6a5c14410532adece (diff)
downloadports-8ce51beeec53e83ae246169a30909b0660b06e33.tar.gz
ports-8ce51beeec53e83ae246169a30909b0660b06e33.zip
Notes
-rw-r--r--www/apache-contrib/Makefile25
-rw-r--r--www/apache-contrib/distinfo1
-rw-r--r--www/mod_accounting/Makefile2
-rw-r--r--www/mod_accounting/distinfo1
-rw-r--r--www/mod_auth_kerb/Makefile2
-rw-r--r--www/mod_auth_kerb/distinfo1
-rw-r--r--www/mod_auth_kerb2/Makefile2
-rw-r--r--www/mod_auth_kerb2/distinfo1
-rw-r--r--www/mod_auth_pam2/Makefile5
-rw-r--r--www/mod_auth_pam2/distinfo1
10 files changed, 15 insertions, 26 deletions
diff --git a/www/apache-contrib/Makefile b/www/apache-contrib/Makefile
index 0441b0757ac5..97d176fb05c0 100644
--- a/www/apache-contrib/Makefile
+++ b/www/apache-contrib/Makefile
@@ -15,18 +15,20 @@ MASTER_SITE_SUBDIR= contrib/modules/1.3
MAINTAINER= apache@FreeBSD.org
COMMENT= Third-party modules contributed to the Apache HTTP server project
-USE_APACHE= yes
+USE_APACHE= 13
+
+.include <bsd.port.pre.mk>
.if defined(WITH_MODULES_PORTS)
PLIST_SUB+= PORTS="@comment "
-MODS_DIR= ${LOCALBASE}/libexec/apache
+MODS_DIR= ${LOCALBASE}/${APACHEMODDIR}
RUN_DEPENDS+= ${MODS_DIR}/mod_auth_external.so:${PORTSDIR}/www/mod_auth_external \
${MODS_DIR}/mod_bandwidth.so:${PORTSDIR}/www/mod_bandwidth \
${MODS_DIR}/mod_put.so:${PORTSDIR}/www/mod_put \
${MODS_DIR}/mod_ticket.so:${PORTSDIR}/www/mod_ticket \
${MODS_DIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
${MODS_DIR}/mod_cvs.so:${PORTSDIR}/www/mod_cvs \
- ${MODS_DIR}/mod_roaming.so:${PORTSDIR}/www/mod_roaming
+ ${MODS_DIR}/mod_roaming.so:${PORTSDIR}/www/mod_roaming \
${MODS_DIR}/mod_layout.so:${PORTSDIR}/www/mod_layout
PKGNAMESUFFIX+= -lite
.else
@@ -37,21 +39,6 @@ CONFLICTS= mod_auth_external-2.* mod_bandwidth-2.* mod_put-1.* \
mod_layout-3.* mod_macro-1.*
.endif
-.if exists(${APXS})
-APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
-.endif
-.if exists(${APXS}) && ${APXS_WORKS} != no
-AP_TARGET!= ${APXS} -q TARGET
-AP_SYSCONF!= ${APXS} -q SYSCONFDIR
-AP_INCLUDE!= ${APXS} -q INCLUDEDIR
-AP_LIBEXEC!= ${APXS} -q LIBEXECDIR
-.else
-AP_TARGET?= httpd
-AP_SYSCONF?= ${PREFIX}/etc/apache
-AP_INCLUDE?= ${PREFIX}/include/apache
-AP_LIBEXEC?= ${PREFIX}/libexec/apache
-.endif
-
ALL_TARGET= APXS=${APXS} all
INSTALL_TARGET= APXS=${APXS} install
@@ -60,4 +47,4 @@ pre-everything::
@${ECHO_MSG} " If you want to install their latest version from ports"
@${ECHO_MSG} " just define WITH_MODULES_PORTS."
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/apache-contrib/distinfo b/www/apache-contrib/distinfo
index 784921bc698d..e252929d4fe6 100644
--- a/www/apache-contrib/distinfo
+++ b/www/apache-contrib/distinfo
@@ -1,2 +1,3 @@
MD5 (apache-contrib-1.0.8.tar.gz) = a289d3596091ad8f7722f62aaa2d1465
+SHA256 (apache-contrib-1.0.8.tar.gz) = 9e77fa71146a0671cab7ecc148bace5215fa990b154c05ce041c2340195a29fe
SIZE (apache-contrib-1.0.8.tar.gz) = 194413
diff --git a/www/mod_accounting/Makefile b/www/mod_accounting/Makefile
index 3f6227d641ef..b786e36fb7f6 100644
--- a/www/mod_accounting/Makefile
+++ b/www/mod_accounting/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= mod-acct
MAINTAINER= apache@FreeBSD.org
COMMENT= An Apache module that records traffic statistics into a database
-USE_APACHE= YES
+USE_APACHE= 13
MAKE_ARGS+= APXS="${APXS}"
.if defined(WITHOUT_PGSQL)
diff --git a/www/mod_accounting/distinfo b/www/mod_accounting/distinfo
index cf6c5175addc..1b11cd8bc1b9 100644
--- a/www/mod_accounting/distinfo
+++ b/www/mod_accounting/distinfo
@@ -1,2 +1,3 @@
MD5 (mod_accounting-0.5.tar.gz) = fc045bbdc5ae32241765fea2967a63fb
+SHA256 (mod_accounting-0.5.tar.gz) = 7aabd36a071c764fec90d76a6d9b1b7bfd8d8991e044d205e7d53d087a6361a3
SIZE (mod_accounting-0.5.tar.gz) = 9728
diff --git a/www/mod_auth_kerb/Makefile b/www/mod_auth_kerb/Makefile
index a2f48ca70459..aa18a416c1f2 100644
--- a/www/mod_auth_kerb/Makefile
+++ b/www/mod_auth_kerb/Makefile
@@ -24,7 +24,7 @@ COMMENT= An Apache module for authenticating users with Kerberos v5
# (i.e., HTTP over SSL/TLS). Thus, we require as a dependency
# a version of Apache which can do this.
#
-USE_APACHE= yes
+USE_APACHE= 13
# Don't fsck with CFLAGS
CFLAGS:=
GNU_CONFIGURE= yes
diff --git a/www/mod_auth_kerb/distinfo b/www/mod_auth_kerb/distinfo
index ea1597f6042b..4830cf881d62 100644
--- a/www/mod_auth_kerb/distinfo
+++ b/www/mod_auth_kerb/distinfo
@@ -1,2 +1,3 @@
MD5 (mod_auth_kerb-5.0-rc6.tar.gz) = 274edfb950af20ce6ef0ddcb7c20263a
+SHA256 (mod_auth_kerb-5.0-rc6.tar.gz) = ae33ab3ae5b419819725091d154add1a1d1a5d6d97e31e9f327f71a0b6370d3e
SIZE (mod_auth_kerb-5.0-rc6.tar.gz) = 68761
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index a2f48ca70459..aa18a416c1f2 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -24,7 +24,7 @@ COMMENT= An Apache module for authenticating users with Kerberos v5
# (i.e., HTTP over SSL/TLS). Thus, we require as a dependency
# a version of Apache which can do this.
#
-USE_APACHE= yes
+USE_APACHE= 13
# Don't fsck with CFLAGS
CFLAGS:=
GNU_CONFIGURE= yes
diff --git a/www/mod_auth_kerb2/distinfo b/www/mod_auth_kerb2/distinfo
index ea1597f6042b..4830cf881d62 100644
--- a/www/mod_auth_kerb2/distinfo
+++ b/www/mod_auth_kerb2/distinfo
@@ -1,2 +1,3 @@
MD5 (mod_auth_kerb-5.0-rc6.tar.gz) = 274edfb950af20ce6ef0ddcb7c20263a
+SHA256 (mod_auth_kerb-5.0-rc6.tar.gz) = ae33ab3ae5b419819725091d154add1a1d1a5d6d97e31e9f327f71a0b6370d3e
SIZE (mod_auth_kerb-5.0-rc6.tar.gz) = 68761
diff --git a/www/mod_auth_pam2/Makefile b/www/mod_auth_pam2/Makefile
index 6e851358c890..df6b6c08c0a3 100644
--- a/www/mod_auth_pam2/Makefile
+++ b/www/mod_auth_pam2/Makefile
@@ -15,15 +15,12 @@ DISTNAME= ${PORTNAME}-2.0-${PORTVERSION}
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows users to use PAM modules for user authentication
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache20
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
LATEST_LINK= mod_auth_pam2
+USE_APACHE= 20+
USE_GMAKE= YES
MAKE_ENV+= APXS=${APXS}
WRKSRC= ${WRKDIR}/${PORTNAME}
-APXS?= ${LOCALBASE}/sbin/apxs
post-install:
${MKDIR} ${EXAMPLESDIR}
diff --git a/www/mod_auth_pam2/distinfo b/www/mod_auth_pam2/distinfo
index 24082dd5083a..bc8880ca70a3 100644
--- a/www/mod_auth_pam2/distinfo
+++ b/www/mod_auth_pam2/distinfo
@@ -1,2 +1,3 @@
MD5 (mod_auth_pam-2.0-1.1.1.tar.gz) = ab873520ddd2fee7d480dfd53e464e0a
+SHA256 (mod_auth_pam-2.0-1.1.1.tar.gz) = 21c55e3a3539e05782654d4dc6f12345b0a4eac29425c20c41f540260866977b
SIZE (mod_auth_pam-2.0-1.1.1.tar.gz) = 11456