aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-02-12 21:48:12 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-02-12 21:48:12 +0000
commit92e061b6d7668c003f6719c5d6804f15841dd54e (patch)
treed75a140ef19beb364a0cb2e0972fb89564124c6a
parentbff057c2fc037ec1beec2b859f35e9c5af16fb5e (diff)
downloadports-92e061b6d7668c003f6719c5d6804f15841dd54e.tar.gz
ports-92e061b6d7668c003f6719c5d6804f15841dd54e.zip
Notes
-rw-r--r--emulators/qemu/Makefile20
-rw-r--r--emulators/qemu/files/patch-Makefile4
2 files changed, 13 insertions, 11 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index cb73b2568d16..6cea52ab7897 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qemu
PORTVERSION= 2.12.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -19,16 +19,18 @@ LIB_DEPENDS?= libnettle.so:security/nettle \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-HAS_CONFIGURE= yes
-USES?= cpe gmake pkgconfig bison perl5 python:2.7,build tar:xz
-USE_PERL5= build
-MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
-.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} != "-utils"
+.if !defined(PKGNAMESUFFIX) || (${PKGNAMESUFFIX} != "-utils" && ${PKGNAMESUFFIX} != "-guest-agent")
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
USE_XORG= pixman
USE_GNOME+= cairo glib20 libxml2
-ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
.endif
+USES?= cpe gl gmake gnome pkgconfig bison perl5 python:2.7,build tar:xz
+USE_PERL5= build
+
+HAS_CONFIGURE= yes
+MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
+
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
VDE CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
STATIC_LINK DOCS NCURSES
@@ -61,7 +63,7 @@ PNG_LIB_DEPENDS= libpng.so:graphics/png
PNG_CONFIGURE_OFF= --disable-vnc-png
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_OFF= --disable-curl
-OPENGL_USE= GL=yes
+OPENGL_USE= GL=glu
OPENGL_CONFIGURE_OFF= --disable-opengl
USBREDIR_BUILD_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_RUN_DEPENDS= usbredir>=0.6:net/usbredir
@@ -88,7 +90,7 @@ WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS?=--localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
--extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh2 --enable-debug \
- --prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \
+ --prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
--enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
diff --git a/emulators/qemu/files/patch-Makefile b/emulators/qemu/files/patch-Makefile
index 84da60ab0b86..d855e8919ab6 100644
--- a/emulators/qemu/files/patch-Makefile
+++ b/emulators/qemu/files/patch-Makefile
@@ -6,13 +6,13 @@
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
+DOCS=qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
-+DOCS+=docs/qemu-qmp-ref.7 docs/qemu-ga-ref.7
++DOCS+=docs/interop/qemu-qmp-ref.7 docs/interop/qemu-ga-ref.7
+else
DOCS=qemu-doc.html qemu-doc.txt qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
DOCS+=docs/interop/qemu-qmp-ref.html docs/interop/qemu-qmp-ref.txt docs/interop/qemu-qmp-ref.7
DOCS+=docs/interop/qemu-ga-ref.html docs/interop/qemu-ga-ref.txt docs/interop/qemu-ga-ref.7
- DOCS+=docs/qemu-block-drivers.7
+endif
+ DOCS+=docs/qemu-block-drivers.7
ifdef CONFIG_VIRTFS
DOCS+=fsdev/virtfs-proxy-helper.1
endif