aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-05 16:56:02 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-05 16:56:02 +0000
commita177f10fd6e6b225852dd77e5ae0ce9de787ce82 (patch)
tree8d60ac88515770dd59e630a54f92797acbfb45d3
parent382f2da52afd4ae3c24c27ea0cebc021c50688c3 (diff)
downloadports-a177f10fd6e6b225852dd77e5ae0ce9de787ce82.tar.gz
ports-a177f10fd6e6b225852dd77e5ae0ce9de787ce82.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/tarsnap-periodic/Makefile49
-rw-r--r--sysutils/tarsnap-periodic/distinfo2
-rw-r--r--sysutils/tarsnap-periodic/pkg-descr4
-rw-r--r--sysutils/tarsnap-periodic/pkg-message13
5 files changed, 69 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9568caa15159..58a6a29ae31a 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1018,6 +1018,7 @@
SUBDIR += tai64nfrac
SUBDIR += tarsnap
SUBDIR += tarsnap-gui
+ SUBDIR += tarsnap-periodic
SUBDIR += tartarus
SUBDIR += tbku
SUBDIR += tclsyslog
diff --git a/sysutils/tarsnap-periodic/Makefile b/sysutils/tarsnap-periodic/Makefile
new file mode 100644
index 000000000000..6b17ae617223
--- /dev/null
+++ b/sysutils/tarsnap-periodic/Makefile
@@ -0,0 +1,49 @@
+# Created by: Kamila Souckova <kamila@ksp.sk>
+# $FreeBSD$
+
+PORTNAME= tarsnap-periodic
+PORTVERSION= 1.0.20160229
+CATEGORIES= sysutils
+
+MAINTAINER= kamila@ksp.sk
+COMMENT= Simple way of making tarsnap backups using the periodic system
+
+RUN_DEPENDS= tarsnap:${PORTSDIR}/sysutils/tarsnap
+
+USE_GITHUB= yes
+GH_ACCOUNT= anotherkamila
+GH_TAGNAME= e593907
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PERIODIC_DIRS= etc/periodic/daily etc/periodic/weekly \
+ etc/periodic/monthly etc/periodic
+
+PERIODIC_FILES= etc/periodic/daily/000.tarsnap-backup \
+ etc/periodic/weekly/000.tarsnap-backup \
+ etc/periodic/monthly/000.tarsnap-backup
+
+SCRIPT_FILE= bin/tarsnap-backup
+
+PLIST_FILES= ${PERIODIC_FILES} ${SCRIPT_FILE}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|TARSNAP_CMD=.*|TARSNAP_CMD=${PREFIX}/bin/tarsnap|" \
+ ${WRKSRC}/${SCRIPT_FILE}
+.for _file in ${PERIODIC_FILES}
+ @${REINPLACE_CMD} -e "s|tarsnap-backup|${PREFIX}/bin/tarsnap-backup|" \
+ ${WRKSRC}/${_file}
+.endfor
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/tarsnap-backup ${STAGEDIR}${PREFIX}/bin
+.for _dir in ${PERIODIC_DIRS}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${_dir}
+.endfor
+
+.for _file in ${PERIODIC_FILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${_file} ${STAGEDIR}${PREFIX}/${_file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/tarsnap-periodic/distinfo b/sysutils/tarsnap-periodic/distinfo
new file mode 100644
index 000000000000..d949028eed73
--- /dev/null
+++ b/sysutils/tarsnap-periodic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (anotherkamila-tarsnap-periodic-1.0.20160229-e593907_GH0.tar.gz) = 993515aa412b7e6d2784081f51305a5202b81d11fa420d6ad94ed1ce85bba0eb
+SIZE (anotherkamila-tarsnap-periodic-1.0.20160229-e593907_GH0.tar.gz) = 2107
diff --git a/sysutils/tarsnap-periodic/pkg-descr b/sysutils/tarsnap-periodic/pkg-descr
new file mode 100644
index 000000000000..5db64f02f774
--- /dev/null
+++ b/sysutils/tarsnap-periodic/pkg-descr
@@ -0,0 +1,4 @@
+Script that uses the periodic system to create and manage tarsnap
+backups. Easily configured via /etc/periodic.conf
+
+WWW: https://github.com/anotherkamila/tarsnap-periodic
diff --git a/sysutils/tarsnap-periodic/pkg-message b/sysutils/tarsnap-periodic/pkg-message
new file mode 100644
index 000000000000..83e10b6fc1bc
--- /dev/null
+++ b/sysutils/tarsnap-periodic/pkg-message
@@ -0,0 +1,13 @@
+
+In order to enable periodic tarsnap backups you need
+to add these lines to your /etc/periodic.conf
+
+daily_tarsnap_backup_enable="YES"
+daily_tarsnap_backup_paths="/"
+daily_tarsnap_backup_keep=7
+weekly_tarsnap_backup_enable="YES"
+weekly_tarsnap_backup_paths="/"
+weekly_tarsnap_backup_keep=5
+monthly_tarsnap_backup_enable="YES"
+monthly_tarsnap_backup_paths="/"
+monthly_tarsnap_backup_keep=2