aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 16:42:16 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 16:42:16 +0000
commitb152e773ac9d00bd31fdbbdf78c2ce29fa5c42ce (patch)
tree0242443d005095a6379ed1ed5b6b81588f96865d
parent31888b7f5a14188b827a3c1edee4317ed142b3a1 (diff)
downloadports-b152e773ac9d00bd31fdbbdf78c2ce29fa5c42ce.tar.gz
ports-b152e773ac9d00bd31fdbbdf78c2ce29fa5c42ce.zip
Notes
-rw-r--r--news/dnews/Makefile5
-rw-r--r--palm/coldsync/Makefile3
2 files changed, 5 insertions, 3 deletions
diff --git a/news/dnews/Makefile b/news/dnews/Makefile
index 863fb4a225e0..2eda67b3e5dc 100644
--- a/news/dnews/Makefile
+++ b/news/dnews/Makefile
@@ -19,12 +19,13 @@ NO_CDROM= "no answer yet, if we are allowed to put it onto CDROM"
RESTRICTED= "only free for non-profit organisations"
NO_PACKAGE= "${RESTRICTED}"
IS_INTERACTIVE= yes
+USE_REINPLACE= yes
NO_BUILD= yes
post-configure:
- @${PERL} -pi -e "s|df -k|/bin/df -k|" ${WRKSRC}/dnews.conf
- @${PERL} -pi -e "s|lib/sendmail|sbin/sendmail|" ${WRKSRC}/dnews.conf
+ @${REINPLACE_CMD} -e "s|df -k|/bin/df -k|" ${WRKSRC}/dnews.conf
+ @${REINPLACE_CMD} -e "s|lib/sendmail|sbin/sendmail|" ${WRKSRC}/dnews.conf
do-install:
@( cd ${WRKSRC}; ./dnews_setup )
diff --git a/palm/coldsync/Makefile b/palm/coldsync/Makefile
index aa2ae9851176..f4a99fc66930 100644
--- a/palm/coldsync/Makefile
+++ b/palm/coldsync/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Palm/PDB.pm:${PORTSDIR}/palm/p5-Palm
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
# The ColdSync.3 man page describes a Perl package. That's why it goes
# in the Perl manpage directory.
@@ -37,7 +38,7 @@ CONFIGURE_ARGS+= --with-i18n
CONFIGURE_ARGS+= --with-usb
.if ${OSVERSION} >= 450000
post-patch:
- ${PERL} -pi -e 's,udi\.(\S+),udi.udi_\1,g;' \
+ ${REINPLACE_CMD} -e 's,udi\.(\S+),udi.udi_\1,g;' \
-e 's,ur\.(\S+),ur.ucr_\1,g;' \
${WRKSRC}/configure ${WRKSRC}/libpconn/PConnection_usb.c
.endif