aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-04-05 23:17:29 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-04-05 23:17:29 +0000
commitbf12eff187ba937914f04e33f78ed4c0c5edd781 (patch)
treebea8a1c849d46a1798e9f7a7f4f7b3dabcdbdad4
parent282fa2e2943280b05adb5e673d268a7dd44bafdd (diff)
downloadports-bf12eff187ba937914f04e33f78ed4c0c5edd781.tar.gz
ports-bf12eff187ba937914f04e33f78ed4c0c5edd781.zip
Notes
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-pydnstable/Makefile23
-rw-r--r--dns/py-pydnstable/distinfo2
-rw-r--r--dns/py-pydnstable/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index eae5ba74bca2..63c690d37c53 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -158,6 +158,7 @@
SUBDIR += py-ldns
SUBDIR += py-namebench
SUBDIR += py-publicsuffix
+ SUBDIR += py-pydnstable
SUBDIR += py-pywdns
SUBDIR += py-twistedNames
SUBDIR += radns
diff --git a/dns/py-pydnstable/Makefile b/dns/py-pydnstable/Makefile
new file mode 100644
index 000000000000..1fe81738f6a4
--- /dev/null
+++ b/dns/py-pydnstable/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= pydnstable
+PORTVERSION= 0.4.0
+CATEGORIES= dns python
+MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= truckman@FreeBSD.org
+COMMENT= Python wrapper for dns/dnstable
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libdnstable.so:${PORTSDIR}/dns/dnstable
+
+USE_PYTHON= distutils autoplist
+USES= pkgconfig python
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}/${PYTHON_SITELIBDIR}/dnstable.so
+
+.include <bsd.port.mk>
diff --git a/dns/py-pydnstable/distinfo b/dns/py-pydnstable/distinfo
new file mode 100644
index 000000000000..9cdc8fb081a1
--- /dev/null
+++ b/dns/py-pydnstable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pydnstable-0.4.0.tar.gz) = 13261e616682bd609bacf9ef6836e4bab9bb29a485873cb9f9daf6dd258d341a
+SIZE (pydnstable-0.4.0.tar.gz) = 41037
diff --git a/dns/py-pydnstable/pkg-descr b/dns/py-pydnstable/pkg-descr
new file mode 100644
index 000000000000..561c00bddeba
--- /dev/null
+++ b/dns/py-pydnstable/pkg-descr
@@ -0,0 +1,3 @@
+Python bindings for the dnstable library
+
+WWW: https://github.com/farsightsec/pydnstable