aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-10-16 13:16:58 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-10-16 13:16:58 +0000
commitcf3087acae656ffb1cd200fc1b7b10dcabda3706 (patch)
tree6567f0ab0bca192a7cc42f8cb53e37f53caee58a
parente6087ad201f251f38cda323c65672fed81a751ca (diff)
downloadports-cf3087acae656ffb1cd200fc1b7b10dcabda3706.tar.gz
ports-cf3087acae656ffb1cd200fc1b7b10dcabda3706.zip
Notes
-rw-r--r--graphics/ufraw/Makefile26
-rw-r--r--graphics/ufraw/distinfo6
-rw-r--r--graphics/ufraw/pkg-plist3
3 files changed, 22 insertions, 13 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 1e28a387d9f9..0cd1c960dc57 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= ufraw
-PORTVERSION= 0.15
-PORTREVISION= 3
+PORTVERSION= 0.16
+PORTREVISION= 0
CATEGORIES= graphics gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -20,21 +20,20 @@ LIB_DEPENDS= jpeg.10:${PORTSDIR}/graphics/jpeg \
gtkimageview.0:${PORTSDIR}/x11-toolkits/gtkimageview \
lcms.1:${PORTSDIR}/graphics/lcms
-GCONF_SCHEMAS= ${PORTNAME}.schemas
GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk20 glib20 gnomehack intltool intlhack libartlgpl2 pkgconfig
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L"${LOCALBASE}/lib" ${PTHREAD_LIBS}
+CPPFLAGS= -I"${LOCALBASE}/include"
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
-CONFIGURE_ARGS= --enable-mime
PC_FALSE+= cinepaint
OPTIONS= EXIV2 "EXIF support via exiv2 library" on \
GIMP "Install GIMP UFRaw plugin" on \
- LENSFUN "Build with LenFun library support" on
+ LENSFUN "Build with LenFun library support" on \
+ FITS "Enable FITS output support" off
.include <bsd.port.pre.mk>
@@ -54,14 +53,23 @@ PLIST_SUB+= GIMP="@comment "
LIB_DEPENDS+= lensfun.0:${PORTSDIR}/graphics/lensfun
CONFIGURE_ARGS+= --with-lensfun
.endif
+.if defined(WITH_FITS) || exists(${LOCALBASE}/lib/libcfitsio.so)
+LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
+.endif
MAN1= ufraw.1
post-patch:
@${REINPLACE_CMD} -e '18s|^$$|#include <sys/types.h>|' ${WRKSRC}/dcraw.h
- @${REINPLACE_CMD} -e '/@schemasdir/s|datadir|sysconfdir|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/@schemasdir/s|datadir|sysconfdir|' \
+ ${WRKSRC}/Makefile.in
.for i in ${PC_FALSE}
- @${REINPLACE_CMD} -e '/PKG_CONFIG.*$i/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/PKG_CONFIG.*$i/s|$$PKG_CONFIG|${FALSE}|' \
+ ${WRKSRC}/configure
.endfor
+pre-build:
+ ${INSTALL_SCRIPT} ${LOCALBASE}/share/glib-2.0/gettext/mkinstalldirs \
+ ${WRKSRC}/
+
.include <bsd.port.post.mk>
diff --git a/graphics/ufraw/distinfo b/graphics/ufraw/distinfo
index 55c70bf54a96..f1084ac3ace5 100644
--- a/graphics/ufraw/distinfo
+++ b/graphics/ufraw/distinfo
@@ -1,3 +1,3 @@
-MD5 (ufraw-0.15.tar.gz) = 6d8f6c98a388c438784cd909dd82d540
-SHA256 (ufraw-0.15.tar.gz) = 136916d39c7bb76e8e1620066baa258186c13639d64ad87f48d44fa9a766c331
-SIZE (ufraw-0.15.tar.gz) = 976297
+MD5 (ufraw-0.16.tar.gz) = 008acc06f13efad58e0edf2dca8c6afd
+SHA256 (ufraw-0.16.tar.gz) = ed43432d04fbac1b084eed94486794c3dfb8fcd01fd9b02da066365d09687034
+SIZE (ufraw-0.16.tar.gz) = 1072175
diff --git a/graphics/ufraw/pkg-plist b/graphics/ufraw/pkg-plist
index 926cc3508022..e2ccc3891e6b 100644
--- a/graphics/ufraw/pkg-plist
+++ b/graphics/ufraw/pkg-plist
@@ -1,10 +1,10 @@
bin/ufraw
bin/ufraw-batch
%%GIMP%%libexec/gimp/2.2/plug-ins/ufraw-gimp
-share/applications/ufraw.desktop
share/locale/ca/LC_MESSAGES/ufraw.mo
share/locale/cs/LC_MESSAGES/ufraw.mo
share/locale/da/LC_MESSAGES/ufraw.mo
+share/locale/de/LC_MESSAGES/ufraw.mo
share/locale/es/LC_MESSAGES/ufraw.mo
share/locale/fr/LC_MESSAGES/ufraw.mo
share/locale/it/LC_MESSAGES/ufraw.mo
@@ -18,6 +18,7 @@ share/locale/ru/LC_MESSAGES/ufraw.mo
share/locale/sr/LC_MESSAGES/ufraw.mo
share/locale/sr@latin/LC_MESSAGES/ufraw.mo
share/locale/sv/LC_MESSAGES/ufraw.mo
+share/locale/zh_CN/LC_MESSAGES/ufraw.mo
share/pixmaps/ufraw.png
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin