aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-05-30 07:06:31 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-05-30 07:06:31 +0000
commitd027063e8c648cecb976deef897e68a5ae113676 (patch)
tree2da9274df41f96ab3ece7fefb8a0a575af6aa9f3
parent20647ee8ea400f5ed68739b2baeaa105aa2a4a53 (diff)
downloadports-d027063e8c648cecb976deef897e68a5ae113676.tar.gz
ports-d027063e8c648cecb976deef897e68a5ae113676.zip
Notes
-rw-r--r--devel/ruby-avl/Makefile8
-rw-r--r--science/ruby-dcl/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/ruby-avl/Makefile b/devel/ruby-avl/Makefile
index aa2555a1945d..70e043ae01cc 100644
--- a/devel/ruby-avl/Makefile
+++ b/devel/ruby-avl/Makefile
@@ -29,6 +29,12 @@ EXAMPLES= Dussel.txt getwords.rb \
test3.rb test4.rb
DOCS= README
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (needs to link against shared libraries)"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -41,4 +47,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/ruby-dcl/Makefile b/science/ruby-dcl/Makefile
index d7f7bceb336c..3976ded4fefd 100644
--- a/science/ruby-dcl/Makefile
+++ b/science/ruby-dcl/Makefile
@@ -43,6 +43,12 @@ DEMODAT= grph1/scpack/t810630.dat grph1/scpack/t811231.dat \
grph2/umpack/t811231.dat grph2/ximage/MEMO \
grph2/ximage/tomsclm.dat
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (Needs to link against shared libraries)"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -78,4 +84,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>