aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-07-11 11:39:59 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-07-11 11:39:59 +0000
commitd5d10fd240b77b73d15a656ff0165d98df1c17e0 (patch)
tree6b40d320cdc32e3a933a0bd0dd563d8c94c057d4
parent711ee0aaa5e6b7534089c37b64fc6be9d9fd5534 (diff)
downloadports-d5d10fd240b77b73d15a656ff0165d98df1c17e0.tar.gz
ports-d5d10fd240b77b73d15a656ff0165d98df1c17e0.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Test-HTTP/Makefile28
-rw-r--r--www/p5-Test-HTTP/distinfo3
-rw-r--r--www/p5-Test-HTTP/pkg-descr8
-rw-r--r--www/p5-Test-HTTP/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 355af7c85cf6..64f4bd1c74ad 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -951,6 +951,7 @@
SUBDIR += p5-Template-Provider-Encoding
SUBDIR += p5-Template-Timer
SUBDIR += p5-Template-Toolkit
+ SUBDIR += p5-Test-HTTP
SUBDIR += p5-Test-HTTP-Server-Simple
SUBDIR += p5-TestGen4Web-Runner
SUBDIR += p5-Text-Markdown-ApacheHandler
diff --git a/www/p5-Test-HTTP/Makefile b/www/p5-Test-HTTP/Makefile
new file mode 100644
index 000000000000..eb97cc8ab6c8
--- /dev/null
+++ b/www/p5-Test-HTTP/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Test-HTTP
+# Date created: 11 Jul 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-HTTP
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Test HTTP interactions
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
+ ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple \
+ ${SITE_PERL}/Class/Field.pm:${PORTSDIR}/devel/p5-Class-Field \
+ ${SITE_PERL}/Test/Builder/Module.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Test::HTTP.3 Test::HTTP::Syntax.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Test-HTTP/distinfo b/www/p5-Test-HTTP/distinfo
new file mode 100644
index 000000000000..b6e48675316b
--- /dev/null
+++ b/www/p5-Test-HTTP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-HTTP-0.11.tar.gz) = 839a8cf3d1d1b0c76a3ef2dd91349b23
+SHA256 (Test-HTTP-0.11.tar.gz) = f70a3614e251b5097165370cc570542d652a035f4fafa1e9c81a94a64be3c069
+SIZE (Test-HTTP-0.11.tar.gz) = 6670
diff --git a/www/p5-Test-HTTP/pkg-descr b/www/p5-Test-HTTP/pkg-descr
new file mode 100644
index 000000000000..205a6c14f5b5
--- /dev/null
+++ b/www/p5-Test-HTTP/pkg-descr
@@ -0,0 +1,8 @@
+Test::HTTP is designed to make it easier to write tests which are mainly
+about HTTP-level things, such as REST-type services.
+
+Each Test::HTTP object can contain state about a current request and its
+response. This allows convenient shorthands for sending requests,
+checking status codes, headers, and message bodies.
+
+WWW: http://search.cpan.org/dist/Test-HTTP/
diff --git a/www/p5-Test-HTTP/pkg-plist b/www/p5-Test-HTTP/pkg-plist
new file mode 100644
index 000000000000..2dfc0b574107
--- /dev/null
+++ b/www/p5-Test-HTTP/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/HTTP/.packlist
+%%SITE_PERL%%/Test/HTTP.pm
+%%SITE_PERL%%/Test/HTTP/Syntax.pm
+@dirrmtry %%SITE_PERL%%/Test/HTTP
+@dirrmtry %%SITE_PERL%%/Test
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/HTTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test