aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-11-22 21:56:37 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-11-22 21:56:37 +0000
commitdaac768104221950a0ecef0d41e0c4d73f86645b (patch)
tree05b289bd5773df2dc5def55cb9b62d98f3e0e3f0
parentda8927498eee438bc40ce9e80c6a6182690b8fe4 (diff)
downloadports-daac768104221950a0ecef0d41e0c4d73f86645b.tar.gz
ports-daac768104221950a0ecef0d41e0c4d73f86645b.zip
Notes
-rw-r--r--databases/grass/Makefile3
-rw-r--r--games/0ad/Makefile1
-rw-r--r--graphics/qgis/Makefile3
-rw-r--r--multimedia/py-mlt/Makefile3
-rw-r--r--www/chromium/Makefile1
-rw-r--r--www/webkit-gtk2/Makefile1
-rw-r--r--www/webkit-gtk3/Makefile1
-rw-r--r--www/webkit2-gtk3/Makefile3
8 files changed, 12 insertions, 4 deletions
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index 235bc45ce3ec..4f3acef0c798 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -25,7 +25,8 @@ COMMENT= Open source Geographical Information System (GIS)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.TXT
-BUILD_DEPENDS= ${LOCALBASE}/bin/swig:devel/swig13
+BUILD_DEPENDS= ${LOCALBASE}/bin/swig:devel/swig13 \
+ python:lang/python
LIB_DEPENDS= libgdal.so:graphics/gdal \
libpng.so:graphics/png \
libproj.so:graphics/proj \
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 3c1c55ec6a1d..ba06a7ee9602 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -13,6 +13,7 @@ MAINTAINER= madpilot@FreeBSD.org
COMMENT= Real-time strategy (RTS) game of ancient warfare
BUILD_DEPENDS= zip:archivers/zip \
+ python:lang/python \
cmake:devel/cmake
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libicui18n.so:devel/icu \
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 91c703d1db29..37ef37bae651 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -11,7 +11,8 @@ COMMENT= Geographical Information System (GIS) data viewer
LICENSE= GPLv2
-BUILD_DEPENDS= txt2tags:textproc/txt2tags
+BUILD_DEPENDS= txt2tags:textproc/txt2tags \
+ python:lang/python
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libgdal.so:graphics/gdal \
libgeos.so:graphics/geos \
diff --git a/multimedia/py-mlt/Makefile b/multimedia/py-mlt/Makefile
index 65ae44a0ba64..a91249a265dd 100644
--- a/multimedia/py-mlt/Makefile
+++ b/multimedia/py-mlt/Makefile
@@ -12,7 +12,8 @@ LICENSE= GPLv2
LICENSE_COMB= single
LIB_DEPENDS= libmlt.so:${MASTER_PORT}
-BUILD_DEPENDS= swig:devel/swig13
+BUILD_DEPENDS= swig:devel/swig13 \
+ python:lang/python
USES= python:2
MASTERDIR= ${.CURDIR:H:H}/multimedia/mlt
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 91669b90e60d..bed7b268761c 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -17,6 +17,7 @@ BROKEN_FreeBSD_9=does not configure
BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:devel/gperf \
bash:shells/bash \
+ python:lang/python \
yasm:devel/yasm \
flock:sysutils/flock \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat \
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index d08fede6b5f5..ed8b92f48f20 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -14,6 +14,7 @@ COMMENT= Opensource browser engine using the GTK+ 2 toolkit
BUILD_DEPENDS= gtkdoc-rebase:textproc/gtk-doc \
p5-Switch>0:lang/p5-Switch \
+ python:lang/python \
geoclue>=0:net/geoclue
LIB_DEPENDS= libenchant.so:textproc/enchant \
libsecret-1.so:security/libsecret \
diff --git a/www/webkit-gtk3/Makefile b/www/webkit-gtk3/Makefile
index 553e04e9ebe7..c59c9b402c43 100644
--- a/www/webkit-gtk3/Makefile
+++ b/www/webkit-gtk3/Makefile
@@ -14,6 +14,7 @@ COMMENT= Opensource browser engine using the GTK+ 3 toolkit
BUILD_DEPENDS= gtkdoc-rebase:textproc/gtk-doc \
p5-Switch>0:lang/p5-Switch \
+ python:lang/python \
geoclue>=0:net/geoclue
LIB_DEPENDS= libenchant.so:textproc/enchant \
libsecret-1.so:security/libsecret \
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index ac703f60a26e..d43a070c762c 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -12,7 +12,8 @@ DISTNAME= ${PORTNAME}gtk-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Opensource browser engine using the GTK+ 3 toolkit
-BUILD_DEPENDS= geoclue>=0:net/geoclue
+BUILD_DEPENDS= geoclue>=0:net/geoclue \
+ python:lang/python
LIB_DEPENDS= libenchant.so:textproc/enchant \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \