aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-28 16:04:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-28 16:04:52 +0000
commitf974ab3a04794846a719811d86e407d8e910d83e (patch)
tree903e5451da3c982036da23b9cdfe300819394011
parenta764cb4b83dd628312f941a7a3be201fd2b5fe28 (diff)
downloadports-f974ab3a04794846a719811d86e407d8e910d83e.tar.gz
ports-f974ab3a04794846a719811d86e407d8e910d83e.zip
Notes
-rw-r--r--devel/libgit2/Makefile14
-rw-r--r--devel/libgit2/distinfo4
-rw-r--r--devel/libgit2/pkg-plist2
3 files changed, 9 insertions, 11 deletions
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index 07cf0f10a7d8..555851b8d4b5 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libgit2
-PORTVERSION= 0.23.1
+PORTVERSION= 0.23.4
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -17,27 +17,25 @@ USES= cmake pkgconfig python:build
USE_LDCONFIG= yes
USE_OPENSSL= yes
-PLIST_SUB= SHLIB_VER=${PORTVERSION:R:E}
+PLIST_SUB= PORTVERSION=${PORTVERSION} SHLIB_VER=${PORTVERSION:R:E}
OPTIONS_DEFINE= SSH THREADS CURL
OPTIONS_DEFAULT=SSH THREADS CURL
SSH_DESC= Enable SSH support through libssh2
-CURL_DESC= Enable HTTP support through cURL
+CURL_DESC= Enable HTTP support through cURL
SSH_LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
SSH_CMAKE_ON= -DUSE_SSH=ON
SSH_CMAKE_OFF= -DUSE_SSH=OFF
THREADS_CMAKE_ON= -DTHREADSAFE=ON
THREADS_CMAKE_OFF= -DTHREADSAFE=OFF
-CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
CURL_CMAKE_ON= -DCURL=ON
CURL_CMAKE_OFF= -DCURL=OFF
-.include <bsd.port.pre.mk>
+BROKEN_sparc64= does not install: thread-local storage not supported
-.if ${ARCH} == "sparc64"
-BROKEN= Does not install on sparc64: thread-local storage not supported
-.endif
+.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e "s|/pkgconfig|/../libdata/pkgconfig|; \
diff --git a/devel/libgit2/distinfo b/devel/libgit2/distinfo
index 5d0b1d0b82f1..6657b1fd97f0 100644
--- a/devel/libgit2/distinfo
+++ b/devel/libgit2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libgit2-libgit2-v0.23.1_GH0.tar.gz) = 113748018e5876bea84af5c749af25b62f58cb4ca82730dcbffaac90c87f7056
-SIZE (libgit2-libgit2-v0.23.1_GH0.tar.gz) = 3717102
+SHA256 (libgit2-libgit2-v0.23.4_GH0.tar.gz) = c7f5e2d7381dbc4d7e878013d14f9993ae8a41bd23f032718e39ffba57894029
+SIZE (libgit2-libgit2-v0.23.4_GH0.tar.gz) = 4065303
diff --git a/devel/libgit2/pkg-plist b/devel/libgit2/pkg-plist
index e8106428a7c1..60a425917c59 100644
--- a/devel/libgit2/pkg-plist
+++ b/devel/libgit2/pkg-plist
@@ -74,6 +74,6 @@ include/git2/tree.h
include/git2/types.h
include/git2/version.h
lib/libgit2.so
-lib/libgit2.so.0.%%SHLIB_VER%%.1
+lib/libgit2.so.%%PORTVERSION%%
lib/libgit2.so.%%SHLIB_VER%%
libdata/pkgconfig/libgit2.pc