aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-17 18:36:01 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-17 18:36:01 +0000
commitfc56a577dfc4ebeea384194cdba6574baf72337a (patch)
treedfb3f2326aa3dcbbfe6c6eab9eb1c87283d80286
parent924199bc239550f3f935275f3a7835b79f9cb800 (diff)
downloadports-fc56a577dfc4ebeea384194cdba6574baf72337a.tar.gz
ports-fc56a577dfc4ebeea384194cdba6574baf72337a.zip
Notes
-rw-r--r--net/tintin++-devel/Makefile18
-rw-r--r--net/tintin++-devel/distinfo2
-rw-r--r--net/tintin++-devel/files/patch-aa168
-rw-r--r--net/tintin++-devel/files/patch-ab213
-rw-r--r--net/tintin++-devel/pkg-descr14
-rw-r--r--net/tintin++-devel/pkg-plist14
-rw-r--r--net/tintin++/Makefile18
-rw-r--r--net/tintin++/distinfo2
-rw-r--r--net/tintin++/pkg-descr14
-rw-r--r--net/tintin++/pkg-plist14
10 files changed, 125 insertions, 352 deletions
diff --git a/net/tintin++-devel/Makefile b/net/tintin++-devel/Makefile
index 7188e18bcaa2..7b75c2809bbf 100644
--- a/net/tintin++-devel/Makefile
+++ b/net/tintin++-devel/Makefile
@@ -6,17 +6,23 @@
#
PORTNAME= tintin
-PORTVERSION= 1.5.6
+PORTVERSION= 1.8.2
CATEGORIES= net games
-MASTER_SITES= ftp://ftp.walrus.com/pub/avatar/clients/ \
- ftp://ftp.cctpu.edu.ru/pub/comp/networking/mud/ \
- ftp://iclub.nsu.ru/pub/mud/clients/tintin++/
-DISTNAME= tintin++v1.5pl6
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= http://mail.newclear.net/tintin/download/
+DISTNAME= tintin++v1.82
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/tintin++/src
GNU_CONFIGURE= yes
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/lib/tintin
+ ${INSTALL_DATA} ${WRKSRC}/support/.tt_help.txt.Z ${PREFIX}/lib/tintin
+ ${MKDIR} ${PREFIX}/share/doc/tintin
+ ${INSTALL_DATA} ${WRKSRC}/support/.tintinrc ${PREFIX}/share/doc/tintin/tintinrc
+ ${INSTALL_DATA} ${WRKSRC}/../chat.conf ${PREFIX}/share/doc/tintin/chat.conf.example
+ cd ${WRKSRC}/.. ; ${INSTALL_DATA} CHANGES FAQ CREDITS README docs/* ${PREFIX}/share/doc/tintin
+
.include <bsd.port.mk>
diff --git a/net/tintin++-devel/distinfo b/net/tintin++-devel/distinfo
index cf0255698251..f300c5cf4edf 100644
--- a/net/tintin++-devel/distinfo
+++ b/net/tintin++-devel/distinfo
@@ -1 +1 @@
-MD5 (tintin++v1.5pl6.tar.Z) = 35e53d661606d035c3e92a249e44160f
+MD5 (tintin++v1.82.tar.gz) = 8817be7ba82283f507953f17ef4d7743
diff --git a/net/tintin++-devel/files/patch-aa b/net/tintin++-devel/files/patch-aa
index 76295f0429c0..0d0e2f66106f 100644
--- a/net/tintin++-devel/files/patch-aa
+++ b/net/tintin++-devel/files/patch-aa
@@ -1,160 +1,26 @@
-*** Makefile.in.orig Fri Sep 9 19:35:20 1994
---- Makefile.in Tue Nov 15 02:07:48 1994
+*** Makefile.in.orig Thu Jul 20 11:46:17 2000
+--- Makefile.in Sat Sep 2 09:14:06 2000
***************
-*** 10,17 ****
- # try uncommenting the 'gcc' line and commenting the 'cc' one.
- # Tintin++ doesn't *need* an ANSI compiler anymore, but gcc
- # is still better than cc on many platforms...
-! CC = @CC@ -O
-! CFLAGS = @DEFS@
- LIBS = @LIBS@
- PIPE = @PIPE@
- # If you plan on doing debugging (with gdb), it is very helpful to turn all
---- 10,16 ----
- # try uncommenting the 'gcc' line and commenting the 'cc' one.
- # Tintin++ doesn't *need* an ANSI compiler anymore, but gcc
- # is still better than cc on many platforms...
-! CFLAGS += @DEFS@
- LIBS = @LIBS@
- PIPE = @PIPE@
- # If you plan on doing debugging (with gdb), it is very helpful to turn all
-***************
-*** 22,31 ****
-
- # BINDIR is the directory you wish tt++ to be placed if you wish to use
- # make install.
-! BINDIR = ..
-
- # DEFAULT_FILE_DIR is the path to tintin files.
-! DEFAULT_FILE_DIR = @HOME@
-
- #########################################
- # You shouldn't need to change anything #
---- 21,30 ----
-
- # BINDIR is the directory you wish tt++ to be placed if you wish to use
- # make install.
-! BINDIR = /usr/local/bin
-
- # DEFAULT_FILE_DIR is the path to tintin files.
-! DEFAULT_FILE_DIR = /usr/local/lib/tintin
-
- #########################################
- # You shouldn't need to change anything #
-***************
-*** 41,54 ****
- variables.c highlight.c antisub.c ivars.c help.c text.c glob.c
- OFILES = $(CFILES:.c=.o)
-
-! all: tintin++ install
-
- tintin++: $(OFILES) tintin.h
- @echo "Linking..."
- $(CC) $(CFLAGS) $(FFLAGS) $(LFLAGS) -o tt++ $(OFILES) $(LIBS)
-
-! install: all
-! @./install.sh $(BINDIR) $(DEFAULT_FILE_DIR) $(COMPRESSED_HELP)
+*** 9,19 ****
- # Autocompile all .c files into .o files using this rule:
- .c.o:
---- 40,54 ----
- variables.c highlight.c antisub.c ivars.c help.c text.c glob.c
- OFILES = $(CFILES:.c=.o)
+ DEFINES = -D_GNU_SOURCE @DEFS@
-! all: tintin++
+- CC = @CC@
+ MAKE = @MAKE@
- tintin++: $(OFILES) tintin.h
- @echo "Linking..."
- $(CC) $(CFLAGS) $(FFLAGS) $(LFLAGS) -o tt++ $(OFILES) $(LIBS)
+ #this is the standard CFLAGS options, this is what most people should use
+! CFLAGS = -O2 $(DEFINES)
-! install:
-! @mkdir -p $(DEFAULT_FILE_DIR)
-! @./install.sh $(BINDIR) $(DEFAULT_FILE_DIR) Ok
-
- # Autocompile all .c files into .o files using this rule:
- .c.o:
-*** configure.old Sun Aug 28 14:06:38 1994
---- configure Tue Nov 15 01:42:46 1994
-***************
-*** 474,489 ****
- OLD_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -pipe"
-
-! echo "Do you want the helpfile to be compressed (yes/no)? "
-! read YESNO
-! if test $YESNO; then
-! if echo "$YESNO"|grep -i "no" >/dev/null; then
-! DEFS="$DEFS -DCOMPRESSED_HELP=0"
-! else
-! DEFS="$DEFS -DCOMPRESSED_HELP=1"
-! COMPRESSED_HELP="Ok"
-! fi
-! fi
-
- test -n "$silent" || echo "checking for -pipe"
- cat > conftest.${ac_ext} <<EOF
---- 474,492 ----
- OLD_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -pipe"
-
-! DEFS="$DEFS -DCOMPRESSED_HELP=1"
-! COMPRESSED_HELP="Ok"
-!
-! #echo "Do you want the helpfile to be compressed (yes/no)? "
-! #read YESNO
-! #if test $YESNO; then
-! # if echo "$YESNO"|grep -i "no" >/dev/null; then
-! # DEFS="$DEFS -DCOMPRESSED_HELP=0"
-! # else
-! # DEFS="$DEFS -DCOMPRESSED_HELP=1"
-! # COMPRESSED_HELP="Ok"
-! # fi
-! #fi
-
- test -n "$silent" || echo "checking for -pipe"
- cat > conftest.${ac_ext} <<EOF
-***************
-*** 854,860 ****
- :;
- fi
-
-! for ac_func in bcopy
- do
- ac_tr_func=HAVE_`echo $ac_func | tr '[a-z]' '[A-Z]'`
- test -n "$silent" || echo "checking for ${ac_func}"
---- 857,863 ----
- :;
- fi
-
-! for ac_func in
- do
- ac_tr_func=HAVE_`echo $ac_func | tr '[a-z]' '[A-Z]'`
- test -n "$silent" || echo "checking for ${ac_func}"
-*** install.sh.old Fri Sep 9 05:43:26 1994
---- install.sh Tue Nov 15 02:05:24 1994
-***************
-*** 5,16 ****
+ #this is the debugging CFLAGS options, should only be used if you want to
+ #debug/code tintin
+--- 9,18 ----
- echo " "
- echo "Copying the tintin++ executable to \"$1\"..."
-! strip tt++
-! cp tt++ "$1"
+ DEFINES = -D_GNU_SOURCE @DEFS@
- echo "Copying the tintin++ help file to \"$2\"..."
- if [ "$3" ]; then
-! cp support/.tt_help.txt.Z "$2/"
- else
- echo Uncompressing.
- uncompress -c support/.tt_help.txt.Z | cat > "$2"/.tt_help.txt
---- 5,15 ----
+ MAKE = @MAKE@
- echo " "
- echo "Copying the tintin++ executable to \"$1\"..."
-! install -c -s -o bin -g bin -m 555 tt++ "$1"
+ #this is the standard CFLAGS options, this is what most people should use
+! CFLAGS += $(DEFINES)
- echo "Copying the tintin++ help file to \"$2\"..."
- if [ "$3" ]; then
-! install -c -o bin -g bin -m 444 support/.tt_help.txt.Z "$2"
- else
- echo Uncompressing.
- uncompress -c support/.tt_help.txt.Z | cat > "$2"/.tt_help.txt
+ #this is the debugging CFLAGS options, should only be used if you want to
+ #debug/code tintin
diff --git a/net/tintin++-devel/files/patch-ab b/net/tintin++-devel/files/patch-ab
index c6a4eb4d7eea..2c4d5833b31f 100644
--- a/net/tintin++-devel/files/patch-ab
+++ b/net/tintin++-devel/files/patch-ab
@@ -1,175 +1,38 @@
-*** utils.c.old Sun Aug 28 18:12:16 1994
---- utils.c Tue Nov 15 01:58:20 1994
-***************
-*** 21,26 ****
---- 21,28 ----
- #include <unistd.h>
- #endif
-
-+ #include <sys/param.h>
-+
- void syserr();
-
- /*********************************************/
-***************
-*** 56,62 ****
---- 58,66 ----
- char *msg;
- {
- extern int errno, sys_nerr;
-+ #if !defined(BSD) || (BSD < 199306)
- extern char *sys_errlist[];
-+ #endif
-
- fprintf(stderr,"ERROR: %s (%d",msg, errno);
- if(errno>0 && errno<sys_nerr)
-*** parse.c.bak Sun Aug 28 18:12:10 1994
---- parse.c Tue Nov 15 02:21:20 1994
-***************
-*** 670,679 ****
- if(ses && !PSEUDO_PROMPT)
- write_line_mud("", ses);
- else if (!is_split)
-! write(1,"> ", 3);
- else {
- sprintf(strng,"8> 7[%d;%df", input_row, input_col);
-! write(1,strng, strlen(strng)+1);
- display_col+=2;
- }
- }
---- 670,679 ----
- if(ses && !PSEUDO_PROMPT)
- write_line_mud("", ses);
- else if (!is_split)
-! write(1,"> ", 2);
- else {
- sprintf(strng,"8> 7[%d;%df", input_row, input_col);
-! write(1,strng, strlen(strng));
- display_col+=2;
- }
- }
-*** misc.c.bak Sun Aug 28 18:12:08 1994
---- misc.c Tue Nov 15 02:28:26 1994
-***************
-*** 106,112 ****
- char temp[2];
- temp[0]=7;
- temp[1]=0;
-! write(1, temp, 2);
- }
-
-
---- 106,112 ----
- char temp[2];
- temp[0]=7;
- temp[1]=0;
-! write(1, temp, 1);
- }
-
-
-***************
-*** 172,178 ****
- cleanup_session(sesptr);
- ses=NULL;
- if (is_split)
-! write(1, "c", 3);
- tintin_puts2("TINTIN suffers from bloodlack, and the lack of a beating heart...", ses);
- tintin_puts2("TINTIN is dead! R.I.P.", ses);
- tintin_puts2("Your blood freezes as you hear TINTIN's death cry.", ses);
---- 172,178 ----
- cleanup_session(sesptr);
- ses=NULL;
- if (is_split)
-! write(1, "c", 2);
- tintin_puts2("TINTIN suffers from bloodlack, and the lack of a beating heart...", ses);
- tintin_puts2("TINTIN is dead! R.I.P.", ses);
- tintin_puts2("Your blood freezes as you hear TINTIN's death cry.", ses);
-*** main.c.bak Sun Aug 28 18:12:06 1994
---- main.c Tue Nov 15 02:33:37 1994
-***************
-*** 562,568 ****
- if(ses->logfile) {
- if (!OLD_LOG) {
- count=0;
-! for(n=0;n<=didget;n++)
- if (buffer[n]!='\r') {
- temp[count]=buffer[n];
- count++;
---- 562,568 ----
- if(ses->logfile) {
- if (!OLD_LOG) {
- count=0;
-! for(n=0;n<didget;n++)
- if (buffer[n]!='\r') {
- temp[count]=buffer[n];
- count++;
-***************
-*** 732,738 ****
- sprintf(strng,"%c8%s\n\r%c7%c[%d;%df", E, cptr, E, E, input_row, input_col);
- else
- sprintf(strng,"%s\n\r", cptr);
-! write(1,strng, strlen(strng)+1);
- display_col=1;
- if (redraw && term_echoing && !is_split)
- write(1, k_input, strlen(k_input));
---- 732,738 ----
- sprintf(strng,"%c8%s\n\r%c7%c[%d;%df", E, cptr, E, E, input_row, input_col);
- else
- sprintf(strng,"%s\n\r", cptr);
-! write(1,strng, strlen(strng));
- display_col=1;
- if (redraw && term_echoing && !is_split)
- write(1, k_input, strlen(k_input));
-***************
-*** 764,770 ****
- cptr++;
- sprintf(strng,"%s\n\r", cptr);
- }
-! write(1,strng, strlen(strng)+1);
- display_col=1;
- }
- text_came=TRUE;
---- 764,770 ----
- cptr++;
- sprintf(strng,"%s\n\r", cptr);
- }
-! write(1,strng, strlen(strng));
- display_col=1;
- }
- text_came=TRUE;
-***************
-*** 832,838 ****
- input_col=1;
- sprintf(fn, "%c[2J%c[1;%dr%c[%d;1f", E, E, display_row, E, split_line);
- write(1,fn, strlen(fn));
-! write(1,"-------------------------------------------------------------------------------", 80);
- sprintf(fn, "%c[%d;1f%c7", E, split_line-1, E);
- write(1,fn,strlen(fn));
- sprintf(fn, "%c[%d;1f", E, input_row);
---- 832,838 ----
- input_col=1;
- sprintf(fn, "%c[2J%c[1;%dr%c[%d;1f", E, E, display_row, E, split_line);
- write(1,fn, strlen(fn));
-! write(1,"--------------------------------------------------------------------------------", 80);
- sprintf(fn, "%c[%d;1f%c7", E, split_line-1, E);
- write(1,fn,strlen(fn));
- sprintf(fn, "%c[%d;1f", E, input_row);
-*** net.c.bak Sun Aug 28 18:12:10 1994
---- net.c Tue Nov 15 03:27:09 1994
-***************
-*** 80,86 ****
-
- tintin_puts("#Trying to connect..", ses);
-
-! alarm(15); /* We'll allow connect to hang in 15seconds! NO MORE! */
- ticker_interrupted=FALSE;
- connectresult=connect(sock, (struct sockaddr *)&sockaddr, sizeof(sockaddr));
- #if defined(DEBUG)
---- 80,86 ----
-
- tintin_puts("#Trying to connect..", ses);
-
-! alarm(30); /* We'll allow connect to hang in 30seconds! NO MORE! */
- ticker_interrupted=FALSE;
- connectresult=connect(sock, (struct sockaddr *)&sockaddr, sizeof(sockaddr));
- #if defined(DEBUG)
+*** main.c.orig Sat Sep 2 10:20:22 2000
+--- main.c Sat Sep 2 10:20:27 2000
+***************
+*** 70,76 ****
+ int verbatim = 0;
+ int prompt_on = 0;
+ int funcnum = 0;
+! int enable_chat = 1;
+ char homepath[1025];
+ char prompt_line[BUFFER_SIZE];
+
+--- 70,76 ----
+ int verbatim = 0;
+ int prompt_on = 0;
+ int funcnum = 0;
+! int enable_chat = 0;
+ char homepath[1025];
+ char prompt_line[BUFFER_SIZE];
+
+*** chat.c.orig Sat Sep 2 10:34:02 2000
+--- chat.c Sat Sep 2 10:33:32 2000
+***************
+*** 1458,1464 ****
+ if ((f = fopen("chat.conf", "r")) == NULL) {
+ printf("\n#ERROR: chat.conf not found!\n");
+ printf(" This file must be in your current directory.\n");
+! printf(" Using defaults...\n");
+ fflush(stdout);
+ return;
+ }
+--- 1458,1464 ----
+ if ((f = fopen("chat.conf", "r")) == NULL) {
+ printf("\n#ERROR: chat.conf not found!\n");
+ printf(" This file must be in your current directory.\n");
+! printf(" You can find example in /usr/local/share/doc/tintin\n");
+ fflush(stdout);
+ return;
+ }
diff --git a/net/tintin++-devel/pkg-descr b/net/tintin++-devel/pkg-descr
index a7d66ff3c745..2813eda4bb5d 100644
--- a/net/tintin++-devel/pkg-descr
+++ b/net/tintin++-devel/pkg-descr
@@ -1,6 +1,8 @@
- TINTIN++ is a client program specialized to help playing muds.
- This is a souped up version of TINTIN III, many new features
- have been added since III. We saw room for improvement on the
- features available from TINTIN, and since we like the format of
- the program, we decided to use TINTIN as a base for what we
- hope to make one of the most powerful clients around.
+TINTIN++ is a client program specialized to help playing muds.
+This is a souped up version of TINTIN III, many new features
+have been added since III. We saw room for improvement on the
+features available from TINTIN, and since we like the format of
+the program, we decided to use TINTIN as a base for what we
+hope to make one of the most powerful clients around.
+
+WWW: http://mail.newclear.net/tintin/
diff --git a/net/tintin++-devel/pkg-plist b/net/tintin++-devel/pkg-plist
index e2ba3502a94b..80a3e81c9ae5 100644
--- a/net/tintin++-devel/pkg-plist
+++ b/net/tintin++-devel/pkg-plist
@@ -1,3 +1,17 @@
bin/tt++
lib/tintin/.tt_help.txt.Z
+share/doc/tintin/tintinrc
+share/doc/tintin/chat.conf.example
+share/doc/tintin/CHANGES
+share/doc/tintin/FAQ
+share/doc/tintin/CREDITS
+share/doc/tintin/README
+share/doc/tintin/MODIFICATIONS
+share/doc/tintin/MODS.ycjhi
+share/doc/tintin/example1.script
+share/doc/tintin/example2.script
+share/doc/tintin/sgi
+share/doc/tintin/tintin15.ps
+share/doc/tintin/tintin15.txt
@dirrm lib/tintin
+@dirrm share/doc/tintin
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index 7188e18bcaa2..7b75c2809bbf 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -6,17 +6,23 @@
#
PORTNAME= tintin
-PORTVERSION= 1.5.6
+PORTVERSION= 1.8.2
CATEGORIES= net games
-MASTER_SITES= ftp://ftp.walrus.com/pub/avatar/clients/ \
- ftp://ftp.cctpu.edu.ru/pub/comp/networking/mud/ \
- ftp://iclub.nsu.ru/pub/mud/clients/tintin++/
-DISTNAME= tintin++v1.5pl6
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= http://mail.newclear.net/tintin/download/
+DISTNAME= tintin++v1.82
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/tintin++/src
GNU_CONFIGURE= yes
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/lib/tintin
+ ${INSTALL_DATA} ${WRKSRC}/support/.tt_help.txt.Z ${PREFIX}/lib/tintin
+ ${MKDIR} ${PREFIX}/share/doc/tintin
+ ${INSTALL_DATA} ${WRKSRC}/support/.tintinrc ${PREFIX}/share/doc/tintin/tintinrc
+ ${INSTALL_DATA} ${WRKSRC}/../chat.conf ${PREFIX}/share/doc/tintin/chat.conf.example
+ cd ${WRKSRC}/.. ; ${INSTALL_DATA} CHANGES FAQ CREDITS README docs/* ${PREFIX}/share/doc/tintin
+
.include <bsd.port.mk>
diff --git a/net/tintin++/distinfo b/net/tintin++/distinfo
index cf0255698251..f300c5cf4edf 100644
--- a/net/tintin++/distinfo
+++ b/net/tintin++/distinfo
@@ -1 +1 @@
-MD5 (tintin++v1.5pl6.tar.Z) = 35e53d661606d035c3e92a249e44160f
+MD5 (tintin++v1.82.tar.gz) = 8817be7ba82283f507953f17ef4d7743
diff --git a/net/tintin++/pkg-descr b/net/tintin++/pkg-descr
index a7d66ff3c745..2813eda4bb5d 100644
--- a/net/tintin++/pkg-descr
+++ b/net/tintin++/pkg-descr
@@ -1,6 +1,8 @@
- TINTIN++ is a client program specialized to help playing muds.
- This is a souped up version of TINTIN III, many new features
- have been added since III. We saw room for improvement on the
- features available from TINTIN, and since we like the format of
- the program, we decided to use TINTIN as a base for what we
- hope to make one of the most powerful clients around.
+TINTIN++ is a client program specialized to help playing muds.
+This is a souped up version of TINTIN III, many new features
+have been added since III. We saw room for improvement on the
+features available from TINTIN, and since we like the format of
+the program, we decided to use TINTIN as a base for what we
+hope to make one of the most powerful clients around.
+
+WWW: http://mail.newclear.net/tintin/
diff --git a/net/tintin++/pkg-plist b/net/tintin++/pkg-plist
index e2ba3502a94b..80a3e81c9ae5 100644
--- a/net/tintin++/pkg-plist
+++ b/net/tintin++/pkg-plist
@@ -1,3 +1,17 @@
bin/tt++
lib/tintin/.tt_help.txt.Z
+share/doc/tintin/tintinrc
+share/doc/tintin/chat.conf.example
+share/doc/tintin/CHANGES
+share/doc/tintin/FAQ
+share/doc/tintin/CREDITS
+share/doc/tintin/README
+share/doc/tintin/MODIFICATIONS
+share/doc/tintin/MODS.ycjhi
+share/doc/tintin/example1.script
+share/doc/tintin/example2.script
+share/doc/tintin/sgi
+share/doc/tintin/tintin15.ps
+share/doc/tintin/tintin15.txt
@dirrm lib/tintin
+@dirrm share/doc/tintin