aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-07-31 13:25:26 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-07-31 13:25:26 +0000
commit0a44979b96d899f75f2d231a8fab29d828f302a1 (patch)
tree7168669dad481efe0134b1493910c362b8b2793b
parent33825714439859db0e96c1bf9b4ead6e68311376 (diff)
downloadports-0a44979b96d899f75f2d231a8fab29d828f302a1.tar.gz
ports-0a44979b96d899f75f2d231a8fab29d828f302a1.zip
Notes
-rw-r--r--devel/qdevelop/Makefile6
-rw-r--r--games/darkplaces/Makefile2
-rw-r--r--irc/quassel/Makefile2
-rw-r--r--print/hplip/Makefile2
-rw-r--r--textproc/qstardict/Makefile2
5 files changed, 7 insertions, 7 deletions
diff --git a/devel/qdevelop/Makefile b/devel/qdevelop/Makefile
index 6c7f00159d47..ced7ad887644 100644
--- a/devel/qdevelop/Makefile
+++ b/devel/qdevelop/Makefile
@@ -70,7 +70,7 @@ post-patch:
${WRKSRC}/plugins/formatting-astyle/astyleplugin.cpp
do-configure:
-.if !${PORT_OPTIONS:MNLS}
+.if ${PORT_OPTIONS:MNLS}
cd ${WRKSRC} && ${QT_LRELEASE} ${QMAKE_PRO}
.endif
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
@@ -78,11 +78,11 @@ do-configure:
post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
${INSTALL_DATA} ${WRKSRC}/resources/images/logo.png ${PREFIX}/share/pixmaps/qdevelop.png
-.if !${PORT_OPTIONS:MNLS}
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} ${DATADIR}
cd ${WRKSRC}/resources/translations/ && ${COPYTREE_SHARE} '*.qm' ${DATADIR}/translations
.endif
-.if !${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for doc in ChangeLog.txt README.txt
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index 823d3ddaae3e..1a5b34a8e692 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -83,7 +83,7 @@ do-install:
.endfor
@${MKDIR} ${DATADIR}
@${TOUCH} ${DATADIR}/dummy
-.if !{PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/darkplaces.txt ${DOCSDIR}
.endif
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index 060a0975034a..80223dc6973b 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -79,7 +79,7 @@ PLIST_SUB+= CLIENT="@comment "
.endif
pre-configure:
-.if ${PORT_OPTIONS:MNLS}
+.if !${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e '/add_subdirectory(i18n)/d' \
${WRKSRC}/CMakeLists.txt
.endif
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 1b15384e2f08..681b50b30292 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -144,7 +144,7 @@ CONFIGURE_ARGS+= --disable-scan-build
PLIST_SUB+= SCAN="@comment "
.endif
-.if ${PORT_OPTIONS:MDOCS}
+.if !${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --enable-doc-build=no
.endif
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
index f8837c75b243..2e8275a777c1 100644
--- a/textproc/qstardict/Makefile
+++ b/textproc/qstardict/Makefile
@@ -42,7 +42,7 @@ QMAKE_ARGS+= NO_DBUS=1
post-patch:
@${REINPLACE_CMD} -e "s|/usr|${PREFIX}|g" \
${WRKSRC}/qstardict.pri
-.if ${PORT_OPTIONS:MDOCS}
+.if !${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e "/^INSTALLS/s|docs||g" \
${WRKSRC}/qstardict.pro
.endif