aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-06 12:52:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-06 12:52:10 +0000
commit655c86587ebe20214a339ed4d486ab69fe8b78f2 (patch)
tree4b363cde8fc5fc293d34fa011fba4b71f70cbd8f
parente555a1dbc30175363cba328548faa62c82a6db91 (diff)
downloadports-655c86587ebe20214a339ed4d486ab69fe8b78f2.tar.gz
ports-655c86587ebe20214a339ed4d486ab69fe8b78f2.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-LibXSLT/Makefile27
-rw-r--r--textproc/p5-XML-LibXSLT/distinfo1
-rw-r--r--textproc/p5-XML-LibXSLT/files/patch-Makefile.PL36
-rw-r--r--textproc/p5-XML-LibXSLT/pkg-comment1
-rw-r--r--textproc/p5-XML-LibXSLT/pkg-descr12
-rw-r--r--textproc/p5-XML-LibXSLT/pkg-plist8
7 files changed, 86 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b60760543034..19ce0f970e76 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -124,6 +124,7 @@
SUBDIR += p5-XML-DT
SUBDIR += p5-XML-Dumper
SUBDIR += p5-XML-LibXML
+ SUBDIR += p5-XML-LibXSLT
SUBDIR += p5-XML-Node
SUBDIR += p5-XML-Parser
SUBDIR += p5-XML-RSS
diff --git a/textproc/p5-XML-LibXSLT/Makefile b/textproc/p5-XML-LibXSLT/Makefile
new file mode 100644
index 000000000000..ae920087d849
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: XML::LibXSLT
+# Date created: 6 June 2001
+# Whom: Dom Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXSLT
+PORTVERSION= 1.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.1:${PORTSDIR}/textproc/libxslt
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC='-I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2'
+
+MAN3= XML::LibXSLT.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-LibXSLT/distinfo b/textproc/p5-XML-LibXSLT/distinfo
new file mode 100644
index 000000000000..ce700c424e0e
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/distinfo
@@ -0,0 +1 @@
+MD5 (XML-LibXSLT-1.05.tar.gz) = f43083ab4aef8b7785c4b586e77f9e4c
diff --git a/textproc/p5-XML-LibXSLT/files/patch-Makefile.PL b/textproc/p5-XML-LibXSLT/files/patch-Makefile.PL
new file mode 100644
index 000000000000..1dbd98b0db0f
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/files/patch-Makefile.PL
@@ -0,0 +1,36 @@
+--- Makefile.PL.orig Tue May 22 17:25:19 2001
++++ Makefile.PL Mon Aug 6 20:43:20 2001
+@@ -19,9 +19,6 @@
+ # get libs and inc from gnome-config
+ eval {
+ print "running xslt-config... ";
+- my $ver = backtick('xslt-config --version');
+- my ($major, $minor) = $ver =~ /(\d+)\.(\d+)/g;
+- die "VERSION" unless $minor >= 7;
+ $config{LIBS} ||= backtick('xslt-config --libs');
+ $config{INC} ||= backtick('xslt-config --cflags');
+ print "ok\n";
+@@ -102,8 +99,9 @@
+ }
+ open(OLDOUT, ">&STDOUT");
+ open(OLDERR, ">&STDERR");
+- open(STDOUT, ">" . File::Spec->devnull);
+- open(STDERR, ">" . File::Spec->devnull);
++ my $devnull = eval { File::Spec->devnull} || "/dev/null";
++ open(STDOUT, ">$devnull");
++ open(STDERR, ">$devnull");
+ my $retval = system($command);
+ open(STDOUT, ">&OLDOUT");
+ open(STDERR, ">&OLDERR");
+@@ -126,8 +124,9 @@
+ }
+ open(OLDOUT, ">&STDOUT");
+ open(OLDERR, ">&STDERR");
+- open(STDOUT, ">" . File::Spec->devnull);
+- open(STDERR, ">" . File::Spec->devnull);
++ my $devnull = eval { File::Spec->devnull} || "/dev/null";
++ open(STDOUT, ">$devnull");
++ open(STDERR, ">$devnull");
+ my $results = `$command`;
+ my $retval = $?;
+ open(STDOUT, ">&OLDOUT");
diff --git a/textproc/p5-XML-LibXSLT/pkg-comment b/textproc/p5-XML-LibXSLT/pkg-comment
new file mode 100644
index 000000000000..b43ed7f8291a
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/pkg-comment
@@ -0,0 +1 @@
+A Perl interface to the GNOME XSLT library.
diff --git a/textproc/p5-XML-LibXSLT/pkg-descr b/textproc/p5-XML-LibXSLT/pkg-descr
new file mode 100644
index 000000000000..c9a1146591f4
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/pkg-descr
@@ -0,0 +1,12 @@
+This module is a fast XSLT library, based on the Gnome libxslt engine
+that you can find at http://www.xmlsoft.org/XSLT/
+
+Performance is currently about twice that of XML::Sablotron (based on
+XSLTMark tests converted to Perl).
+
+The libxslt processor is also highly standards compliant, with
+practically
+all of XSLT 1.0 being supported in version 0.9 of libxslt.
+
+This is free software, you may use it and distribute it under the same
+terms as Perl itself. Copyright 2001 AxKit.com Ltd, All rights reserved.
diff --git a/textproc/p5-XML-LibXSLT/pkg-plist b/textproc/p5-XML-LibXSLT/pkg-plist
new file mode 100644
index 000000000000..cc3aeea08de7
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/LibXSLT.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML/benchmark.pl
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXSLT/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXSLT/LibXSLT.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXSLT/LibXSLT.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/LibXSLT
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true