aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2020-03-28 15:57:26 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2020-03-28 15:57:26 +0000
commite68265d9fe75cd03073a91515ede116948541bfd (patch)
tree69c134ded059b4e6ee07e728a537e3378cb2de1d
parentae990f34231c03fdeb3c6aee52ff10d7eb905d2f (diff)
downloadports-e68265d9fe75cd03073a91515ede116948541bfd.tar.gz
ports-e68265d9fe75cd03073a91515ede116948541bfd.zip
Notes
-rw-r--r--graphics/poppler-glib/Makefile2
-rw-r--r--graphics/poppler-qt5/Makefile2
-rw-r--r--graphics/poppler-utils/Makefile2
-rw-r--r--graphics/poppler/Makefile1
-rw-r--r--graphics/poppler/files/patch-glib_poppler-action.cc51
-rw-r--r--graphics/poppler/files/patch-utils_HtmlOutputDev.cc11
6 files changed, 66 insertions, 3 deletions
diff --git a/graphics/poppler-glib/Makefile b/graphics/poppler-glib/Makefile
index 90bce729270a..fc61a3effe42 100644
--- a/graphics/poppler-glib/Makefile
+++ b/graphics/poppler-glib/Makefile
@@ -1,7 +1,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= GLib bindings to poppler
diff --git a/graphics/poppler-qt5/Makefile b/graphics/poppler-qt5/Makefile
index 686ee8cf48b0..32f0fe55ef5b 100644
--- a/graphics/poppler-qt5/Makefile
+++ b/graphics/poppler-qt5/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -qt5
COMMENT= Qt 5 bindings to poppler
diff --git a/graphics/poppler-utils/Makefile b/graphics/poppler-utils/Makefile
index 67fa87041131..6b1a3cb38f05 100644
--- a/graphics/poppler-utils/Makefile
+++ b/graphics/poppler-utils/Makefile
@@ -1,7 +1,7 @@
# Created by: Michael Nottebrock <lofi@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
COMMENT= Poppler's xpdf-workalike command line utilities # '
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index 684b30714050..54de06cc855c 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -3,6 +3,7 @@
PORTNAME= poppler
DISTVERSION= 0.86.1
+PORTREVISION?= 1
CATEGORIES= graphics print
MASTER_SITES= https://poppler.freedesktop.org/
diff --git a/graphics/poppler/files/patch-glib_poppler-action.cc b/graphics/poppler/files/patch-glib_poppler-action.cc
new file mode 100644
index 000000000000..fd5b93f8717a
--- /dev/null
+++ b/graphics/poppler/files/patch-glib_poppler-action.cc
@@ -0,0 +1,51 @@
+--- glib/poppler-action.cc.orig 2020-03-01 19:52:52 UTC
++++ glib/poppler-action.cc
+@@ -627,39 +627,39 @@ _poppler_action_new (PopplerDocument *document,
+ switch (link->getKind ()) {
+ case actionGoTo:
+ action->type = POPPLER_ACTION_GOTO_DEST;
+- build_goto_dest (document, action, dynamic_cast <const LinkGoTo *> (link));
++ build_goto_dest (document, action, static_cast <const LinkGoTo *> (link));
+ break;
+ case actionGoToR:
+ action->type = POPPLER_ACTION_GOTO_REMOTE;
+- build_goto_remote (action, dynamic_cast <const LinkGoToR *> (link));
++ build_goto_remote (action, static_cast <const LinkGoToR *> (link));
+ break;
+ case actionLaunch:
+ action->type = POPPLER_ACTION_LAUNCH;
+- build_launch (action, dynamic_cast <const LinkLaunch *> (link));
++ build_launch (action, static_cast <const LinkLaunch *> (link));
+ break;
+ case actionURI:
+ action->type = POPPLER_ACTION_URI;
+- build_uri (action, dynamic_cast <const LinkURI *> (link));
++ build_uri (action, static_cast <const LinkURI *> (link));
+ break;
+ case actionNamed:
+ action->type = POPPLER_ACTION_NAMED;
+- build_named (action, dynamic_cast <const LinkNamed *> (link));
++ build_named (action, static_cast <const LinkNamed *> (link));
+ break;
+ case actionMovie:
+ action->type = POPPLER_ACTION_MOVIE;
+- build_movie (document, action, dynamic_cast<const LinkMovie*> (link));
++ build_movie (document, action, static_cast<const LinkMovie*> (link));
+ break;
+ case actionRendition:
+ action->type = POPPLER_ACTION_RENDITION;
+- build_rendition (action, dynamic_cast<const LinkRendition*> (link));
++ build_rendition (action, static_cast<const LinkRendition*> (link));
+ break;
+ case actionOCGState:
+ action->type = POPPLER_ACTION_OCG_STATE;
+- build_ocg_state (document, action, dynamic_cast<const LinkOCGState*> (link));
++ build_ocg_state (document, action, static_cast<const LinkOCGState*> (link));
+ break;
+ case actionJavaScript:
+ action->type = POPPLER_ACTION_JAVASCRIPT;
+- build_javascript (action, dynamic_cast<const LinkJavaScript*> (link));
++ build_javascript (action, static_cast<const LinkJavaScript*> (link));
+ break;
+ case actionUnknown:
+ default:
diff --git a/graphics/poppler/files/patch-utils_HtmlOutputDev.cc b/graphics/poppler/files/patch-utils_HtmlOutputDev.cc
new file mode 100644
index 000000000000..b26c3a71513e
--- /dev/null
+++ b/graphics/poppler/files/patch-utils_HtmlOutputDev.cc
@@ -0,0 +1,11 @@
+--- utils/HtmlOutputDev.cc.orig 2020-03-01 19:52:52 UTC
++++ utils/HtmlOutputDev.cc
+@@ -1838,7 +1838,7 @@ int HtmlOutputDev::getOutlinePageNum(OutlineItem *item
+ if (!action || action->getKind() != actionGoTo)
+ return pagenum;
+
+- link = dynamic_cast<const LinkGoTo*>(action);
++ link = static_cast<const LinkGoTo*>(action);
+
+ if (!link || !link->isOk())
+ return pagenum;