aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2024-03-23 12:29:07 +0000
committerDimitry Andric <dim@FreeBSD.org>2024-03-23 12:46:10 +0000
commit23192ad3f732fbe4b4a22a66832429e2e70c8096 (patch)
treef8236911db732ae7f6f9e8dc74b87e55ab828cc1
parent655a41f5657eab0aec8342fb0ad9c569562e43c7 (diff)
downloadports-23192ad3f732fbe4b4a22a66832429e2e70c8096.tar.gz
ports-23192ad3f732fbe4b4a22a66832429e2e70c8096.zip
devel/boost-all: Use clang from base for OSVERSION >= 1500017
In https://cgit.freebsd.org/src/commit/?id=bcd401b5a39c I committed a fix for clang's assertion failures when building recent boost libraries. I also bumped __FreeBSD_version to 1500017 so this can be detected from devel/boost-all/compiled.mk. The fix was also merged to stable/14, with __FreeBSD_version 1400509, and stable/13, with __FreeBSD_version 1303502. Adjust the ranges to use the default llvm port to [1500000..1500017>, [1400000..1400509>, and [1300000..1303502>. PR: 277850 Approved by: fluffy (maintainer) MFH: 2024Q1 (cherry picked from commit 3b8c51bd37b02a367217533a1bf0761655a77570)
-rw-r--r--devel/boost-all/compiled.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index ef3efa81963d..6062ce1d7666 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -43,8 +43,10 @@ MAKE_ARGS+= pch=off
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1500000 || \
- (${OSVERSION} >= 1400000 && ${OSVERSION} < 1400097))
+.if ${OPSYS} == FreeBSD && \
+ ((${OSVERSION} >= 1500000 && ${OSVERSION} < 1500017) || \
+ (${OSVERSION} >= 1400000 && ${OSVERSION} < 1400509) || \
+ (${OSVERSION} >= 1300000 && ${OSVERSION} < 1303502))
USES+= llvm:build
CHOSEN_COMPILER_TYPE= clang
.else