aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-06-09 23:14:41 +0000
committerJohn Marino <marino@FreeBSD.org>2016-06-09 23:14:41 +0000
commita12efa22af8b31ab70aa66d5ef5b3d02c7d80a7b (patch)
tree2269e1465e70d3aad805dc71da8c5847fef6e534
parent5f5680f08f7eb4a6c5d1af7bc6d692292fcc4d09 (diff)
downloadports-a12efa22af8b31ab70aa66d5ef5b3d02c7d80a7b.tar.gz
ports-a12efa22af8b31ab70aa66d5ef5b3d02c7d80a7b.zip
Notes
-rw-r--r--devel/gps/Makefile2
-rw-r--r--textproc/templates_parser/Makefile12
-rw-r--r--textproc/templates_parser/distinfo5
-rw-r--r--textproc/templates_parser/files/patch-Makefile13
-rw-r--r--textproc/templates_parser/pkg-plist7
-rw-r--r--www/aws-demos/Makefile2
-rw-r--r--www/aws/Makefile2
7 files changed, 21 insertions, 22 deletions
diff --git a/devel/gps/Makefile b/devel/gps/Makefile
index 3313652e1d63..b34f52576a2c 100644
--- a/devel/gps/Makefile
+++ b/devel/gps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gps
PORTVERSION= 6.1.1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTNAME= gps-6.1.1-src
diff --git a/textproc/templates_parser/Makefile b/textproc/templates_parser/Makefile
index b976c9fa8d4e..1c9a45b72cb1 100644
--- a/textproc/templates_parser/Makefile
+++ b/textproc/templates_parser/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= templates_parser
-PORTVERSION= 11.10.0.0
-PORTREVISION= 4
+PORTVERSION= 17.0.0
CATEGORIES= textproc
-MASTER_SITES= http://downloads.dragonlace.net/src/
MAINTAINER= marino@FreeBSD.org
COMMENT= Web page template engine module for the Ada Web Server
@@ -16,7 +14,12 @@ BUILD_DEPENDS= gprbuild:devel/gprbuild \
xmlada>=4.4:textproc/xmlada
RUN_DEPENDS= xmlada>=4.4:textproc/xmlada
-USES= ada gmake tar:bzip2
+USES= ada:run gmake tar:bzip2
+USE_GITHUB= yes
+GH_ACCOUNT= AdaCore
+GH_PROJECT= templates-parser
+GH_TAGNAME= 1d62939
+
DESTINC= ${STAGEDIR}${PREFIX}/include/templates_parser
PLIST_SUB= LIBVER=${PORTVERSION:R}
MAKE_ARGS+= PROCESSORS=${MAKE_JOBS_NUMBER} \
@@ -49,5 +52,6 @@ post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat
${INSTALL_DATA} ${FILESDIR}/templates_parser.gpr \
${STAGEDIR}${PREFIX}/lib/gnat
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/templates*
.include <bsd.port.mk>
diff --git a/textproc/templates_parser/distinfo b/textproc/templates_parser/distinfo
index c4ada89bec5c..481225b73fbb 100644
--- a/textproc/templates_parser/distinfo
+++ b/textproc/templates_parser/distinfo
@@ -1,2 +1,3 @@
-SHA256 (templates_parser-11.10.0.0.tar.bz2) = bd1a332cbc9284488dadc13600d7735fbcea462a9d0df2b6cf796ef95e3d184e
-SIZE (templates_parser-11.10.0.0.tar.bz2) = 168905
+TIMESTAMP = 1465511680
+SHA256 (AdaCore-templates-parser-17.0.0-1d62939_GH0.tar.gz) = fd90fd9a0ac879ab62040abaa1e7cbcbf9261150c081d9ae678e5e31da515f51
+SIZE (AdaCore-templates-parser-17.0.0-1d62939_GH0.tar.gz) = 216712
diff --git a/textproc/templates_parser/files/patch-Makefile b/textproc/templates_parser/files/patch-Makefile
deleted file mode 100644
index 391f31c666a8..000000000000
--- a/textproc/templates_parser/files/patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig 2015-06-21 07:30:14 UTC
-+++ Makefile
-@@ -112,8 +112,8 @@ GPROPTS += -XPRJ_BUILD=$(PRJ_BUILD) -XTP
-
- GPR_DEFAULT = -XLIBRARY_TYPE=$(DEFAULT_LIBRARY_TYPE) \
- -XXMLADA_BUILD=$(DEFAULT_LIBRARY_TYPE)
--GPR_OTHER = -XLIBRARY_TYPE=$(DEFAULT_LIBRARY_TYPE) \
-- -XXMLADA_BUILD=$(DEFAULT_LIBRARY_TYPE)
-+GPR_OTHER = -XLIBRARY_TYPE=$(OTHER_LIBRARY_TYPE) \
-+ -XXMLADA_BUILD=$(OTHER_LIBRARY_TYPE)
-
- #######################################################################
- # build
diff --git a/textproc/templates_parser/pkg-plist b/textproc/templates_parser/pkg-plist
index cc286c955f46..0c62b7ea7b88 100644
--- a/textproc/templates_parser/pkg-plist
+++ b/textproc/templates_parser/pkg-plist
@@ -3,6 +3,7 @@ bin/templatespp
include/templates_parser.relocatable/templates_parser-cached_files.adb
include/templates_parser.relocatable/templates_parser-configuration.ads
include/templates_parser.relocatable/templates_parser-data.adb
+include/templates_parser.relocatable/templates_parser-debug.adb
include/templates_parser.relocatable/templates_parser-debug.ads
include/templates_parser.relocatable/templates_parser-definitions.adb
include/templates_parser.relocatable/templates_parser-expr.adb
@@ -11,10 +12,12 @@ include/templates_parser.relocatable/templates_parser-input.ads
include/templates_parser.relocatable/templates_parser-input__standalone.adb
include/templates_parser.relocatable/templates_parser-macro.adb
include/templates_parser.relocatable/templates_parser-print_tree.adb
+include/templates_parser.relocatable/templates_parser-query.adb
include/templates_parser.relocatable/templates_parser-query.ads
include/templates_parser.relocatable/templates_parser-simplifier.adb
include/templates_parser.relocatable/templates_parser-utils.adb
include/templates_parser.relocatable/templates_parser-utils.ads
+include/templates_parser.relocatable/templates_parser-xml.adb
include/templates_parser.relocatable/templates_parser-xml.ads
include/templates_parser.relocatable/templates_parser.adb
include/templates_parser.relocatable/templates_parser.ads
@@ -23,6 +26,7 @@ include/templates_parser.relocatable/templates_parser_tasking__standard_tasking.
include/templates_parser/templates_parser-cached_files.adb
include/templates_parser/templates_parser-configuration.ads
include/templates_parser/templates_parser-data.adb
+include/templates_parser/templates_parser-debug.adb
include/templates_parser/templates_parser-debug.ads
include/templates_parser/templates_parser-definitions.adb
include/templates_parser/templates_parser-expr.adb
@@ -31,16 +35,19 @@ include/templates_parser/templates_parser-input.ads
include/templates_parser/templates_parser-input__standalone.adb
include/templates_parser/templates_parser-macro.adb
include/templates_parser/templates_parser-print_tree.adb
+include/templates_parser/templates_parser-query.adb
include/templates_parser/templates_parser-query.ads
include/templates_parser/templates_parser-simplifier.adb
include/templates_parser/templates_parser-utils.adb
include/templates_parser/templates_parser-utils.ads
+include/templates_parser/templates_parser-xml.adb
include/templates_parser/templates_parser-xml.ads
include/templates_parser/templates_parser.adb
include/templates_parser/templates_parser.ads
include/templates_parser/templates_parser_tasking.ads
include/templates_parser/templates_parser_tasking__standard_tasking.adb
lib/gnat/templates_parser.gpr
+lib/libtemplates_parser-%%LIBVER%%.so
lib/libtemplates_parser.so
lib/templates_parser.relocatable/libtemplates_parser-%%LIBVER%%.so
lib/templates_parser.relocatable/libtemplates_parser.so
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
index 095491ae1d6a..c06287e93ad4 100644
--- a/www/aws-demos/Makefile
+++ b/www/aws-demos/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aws
PORTVERSION= 3.3.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://downloads.dragonlace.net/src/
PKGNAMESUFFIX= -demos
diff --git a/www/aws/Makefile b/www/aws/Makefile
index 251eedb60205..ef383fbfe1ff 100644
--- a/www/aws/Makefile
+++ b/www/aws/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aws
PORTVERSION= 3.3.0.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= http://downloads.dragonlace.net/src/