aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-21 18:01:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-21 18:01:52 +0000
commita4cf2f638417e28d02f378b34caca049b59e2b6a (patch)
treefd886506b6515528b3d5f42592d1cf75ab47b71d
parent5006d4c0cc7c956307c151b84287aa124ed4467a (diff)
downloadports-a4cf2f638417e28d02f378b34caca049b59e2b6a.tar.gz
ports-a4cf2f638417e28d02f378b34caca049b59e2b6a.zip
Notes
-rw-r--r--www/p5-Catalyst-Plugin-ErrorCatcher/Makefile29
1 files changed, 16 insertions, 13 deletions
diff --git a/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile b/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile
index 18ee557a5141..078226a2218b 100644
--- a/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile
+++ b/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= Catalyst-Plugin-ErrorCatcher
-PORTVERSION= 0.0.8.9
+PORTVERSION= 0.0.8.12
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CHISEL
@@ -17,7 +17,7 @@ COMMENT= Catch application errors and emit them somewhere
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-Catalyst-Runtime>=5.80000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.80000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Catalyst-Plugin-Authentication>=0.10010:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
p5-Catalyst-Plugin-ConfigLoader>=0.22:${PORTSDIR}/www/p5-Catalyst-Plugin-ConfigLoader \
p5-Catalyst-Plugin-Session>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
@@ -29,26 +29,29 @@ RUN_DEPENDS= p5-Catalyst-Runtime>=5.80000:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime \
p5-File-Find-Rule>0:${PORTSDIR}/devel/p5-File-Find-Rule \
p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-File-Type>=0:${PORTSDIR}/devel/p5-File-Type \
p5-FindBin-libs>0:${PORTSDIR}/devel/p5-FindBin-libs \
+ p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-MIME-Lite>0:${PORTSDIR}/mail/p5-MIME-Lite \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
- p5-Module-Pluggable>0:${PORTSDIR}/devel/p5-Module-Pluggable \
p5-namespace-autoclean>0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-BUILD_DEPENDS:= ${RUN_DEPENDS}
-
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-NoTabs>=0:${PORTSDIR}/devel/p5-Test-NoTabs \
+ p5-Test-UseAllModules>=0:${PORTSDIR}/devel/p5-Test-UseAllModules
PERL_CONFIGURE= yes
-MAN3= \
- Catalyst::Plugin::ErrorCatcher.3 \
- Catalyst::Plugin::ErrorCatcher::Email.3 \
- Catalyst::Plugin::ErrorCatcher::File.3 \
- Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::CaughtException.3 \
- Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::Pg::MissingColumn.3 \
- Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::TxnDo.3
+MAN3= Catalyst::Plugin::ErrorCatcher.3 \
+ Catalyst::Plugin::ErrorCatcher::Email.3 \
+ Catalyst::Plugin::ErrorCatcher::File.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::CaughtException.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::Pg::ForeignKeyConstraint.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::Pg::MissingColumn.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::Pg::TransactionAborted.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::TxnDo.3
.include <bsd.port.mk>